Bug 950 - Could not to install printer
: Could not to install printer
Status: RESOLVED DUPLICATE of bug 1041
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
: ROSA 2012.1 Beta
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 21:47 MSD by FirstLevel
Modified: 2012-12-22 20:17 MSK (History)
3 users (show)

See Also:
RPM Package: drakconf-12.19.2-9-rosa2012.1.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments
cups.png (123.79 KB, image/png)
2012-10-16 21:47 MSD, FirstLevel
Details
cups-error.png (124.07 KB, image/png)
2012-10-16 21:47 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-16 21:47:01 MSD
Created attachment 714 [details]
cups.png

Description of problem:
1. Launch drakconf
2. Open section Hardware - Printer settings
3. You'll see that there are two variants: Start the service (disabled) and Connect to server (enabled)
4. If You click "Connect" You cannot to install local printer - because an error occured to connect to local cups



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-10-16 21:47:15 MSD
Created attachment 715 [details]
cups-error.png
Comment 2 Postnikov Dmitry 2012-10-18 11:36:12 MSD
Similarly in 499th iso
Comment 3 Denis Silakov 2012-10-26 19:10:55 MSD
The core issue is that 'Start service' is disabled. Cups is not running by default, so you should start it. 'Connect' button is intended to connect to remote cups servers, not for the local one.

But you still can start cups  by launching 'service cups start' in console, after this you will be able to configure printer.
Comment 4 FirstLevel 2012-10-26 23:40:38 MSD
(In reply to comment #3)
> The core issue is that 'Start service' is disabled. Cups is not running by
> default, so you should start it. 'Connect' button is intended to connect to
> remote cups servers, not for the local one.
> 
> But you still can start cups  by launching 'service cups start' in console,
> after this you will be able to configure printer.

Is this recomendation for ussual user? Could we enable auto-start for cups service by default?
Comment 5 Denis Silakov 2012-10-27 13:39:29 MSD
(In reply to comment #4)
> (In reply to comment #3)
> > But you still can start cups  by launching 'service cups start' in console,
> > after this you will be able to configure printer.
> 
> Is this recomendation for ussual user?

Currently yes.

> Could we enable auto-start for cups service by default?

Enabling cups by default has its pros and cons. The most correct solution that would satisfy almost everyone would be to enable 'Start service' button in the pinter configuration dialog or at least provide a convenient way to start/stop cups (using GUI).

Current problems actually come from migration to systemd, there are some still things to improve in this area.
Comment 6 FirstLevel 2012-10-27 15:58:35 MSD
(In reply to comment #5)
> Currently yes.
> Enabling cups by default has its pros and cons. The most correct solution
> that would satisfy almost everyone would be to enable 'Start service' button
> in the pinter configuration dialog or at least provide a convenient way to
> start/stop cups (using GUI).
> 
> Current problems actually come from migration to systemd, there are some
> still things to improve in this area.

Please could You describe me, why in system for desktop users, who has printers, scanners or multifunction device, we have this strange decision?
Imagine - You are windows user who came to ROSA. And what? 
"You can not just take and print to a local printer..." Boromir (c)
Comment 7 alexander barakin 2012-12-14 17:15:56 MSK
maybe related: bug #880

cups does not listen to port ipp (631) because port blocked by portreserve.service
Comment 8 Denis Silakov 2012-12-20 17:55:09 MSK
In the final release, installer asks user if he wants to launch CUPS and some other services by default.
Comment 9 Denis Silakov 2012-12-22 20:16:14 MSK
We have a separate bug #1041 for system-config-rpinter not able to start CUPS, so I would call this one fixed.
Comment 10 Denis Silakov 2012-12-22 20:17:23 MSK
... or better recategorized as a duplicate.

*** This bug has been marked as a duplicate of bug 1041 ***