Bug 904 - Missing dependencies for smolt-gui-1.4.3-9
: Missing dependencies for smolt-gui-1.4.3-9
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 19:42 MSD by JDronova
Modified: 2012-10-15 10:55 MSD (History)
2 users (show)

See Also:
RPM Package: smolt-gui-1.4.3-9-rosa.lts2012.0.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JDronova 2012-10-12 19:42:54 MSD
Description of problem:
Error on trying to launch smoltGui:
$ smoltGui
Traceback (most recent call last):
  File "/usr/bin/smoltGui", line 22, in <module>
    from PyQt4.QtCore import *
ImportError: No module named sip

After installing the following packages: python-twisted-core and
python-sip the GUI launches ok. (Not sure which one is providing the needed module since I've installed the python-sip right after the first error was received but nothing changed)

Version-Release number of selected component (if applicable):
$ rpm -qif /usr/bin/smoltGui
Name        : smolt-gui                    Relocations: (not relocatable)
Version     : 1.4.3                             Vendor: ROSA
Release     : 9                             Build Date: Чтв 20 Сен 2012 17:13:19
Install Date: Птн 21 Сен 2012 13:02   Build Host: rosabs4-build-rosa2011i586-4.rosalinux.ru
Group       : System/Configuration/Hardware Source RPM: smolt-1.4.3-9.src.rpm
Size        : 5646                             License: GPLv2+
Signature   : DSA/SHA1, Чтв 20 Сен 2012 17:13:19, Key ID e39b11ee10bcc870
URL         : http://fedorahosted.org/smolt
Summary     : Fedora hardware profiler gui
Architecture: noarch
Description :
Provides smolt's gui functionality.  Not included in the default package to
ensure that deps are kept small.


How reproducible:
always

Steps to Reproduce:
1.Install smolt-gui package
2.Run from console
smoltGui
3.See the error
Comment 1 JDronova 2012-10-12 19:52:20 MSD
Forgot to mention - that is LXDE Marathon edition.
Comment 2 Denis Silakov 2012-10-15 10:55:49 MSD
Missing dependency is added. Updated package should appear on mirrors during the day.