Bug 903 - /var could not be placed on separate disk
: /var could not be placed on separate disk
Status: RESOLVED FIXED
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 10:02 MSD by FirstLevel
Modified: 2013-01-15 14:14 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
desktop alpha2 error (113.41 KB, image/png)
2012-10-15 10:04 MSD, FirstLevel
Details
desktop alpha2 error on first console (96.11 KB, image/png)
2012-10-15 10:04 MSD, FirstLevel
Details
desktop alpha2 error on 12 console (124.63 KB, image/png)
2012-10-15 10:05 MSD, FirstLevel
Details
error in the installator (54.00 KB, image/jpeg)
2012-10-26 09:24 MSD, FirstLevel
Details
messages on ctrl-f12 in beta (252.18 KB, image/jpeg)
2012-10-26 09:24 MSD, FirstLevel
Details
fdisk -l for beta (125.70 KB, image/jpeg)
2012-10-26 09:25 MSD, FirstLevel
Details
mount -l for beta (201.48 KB, image/jpeg)
2012-10-26 09:25 MSD, FirstLevel
Details
var.zip (242.59 KB, application/octet-stream)
2012-12-24 16:36 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-12 10:02:14 MSD
/var could not be placed on separate disk for ROSA 2012 LTS.
As Denis Silakov said "bug is caused by the fact that we are launching squashfs, which has a hard-links from /var to another directory in the root partition, so /var, and / in Marathon should be on the same drive."
But there are some situations where /var should be placed on separate disk.
Please modify installation process.
Comment 1 FirstLevel 2012-10-12 10:03:38 MSD
If /var loated on separate disk from / for ROSA 2012 LTS an error occured "Could not copy files to the new root directory"
Comment 2 Denis Silakov 2012-10-12 10:17:51 MSD
*** Bug 316 has been marked as a duplicate of this bug. ***
Comment 3 FirstLevel 2012-10-15 10:03:46 MSD
In the ROSA Desktop 2012 alpha 2 I have such situation.
Comment 4 FirstLevel 2012-10-15 10:04:23 MSD
Created attachment 662 [details]
desktop alpha2 error
Comment 5 FirstLevel 2012-10-15 10:04:46 MSD
Created attachment 663 [details]
desktop alpha2 error on first console
Comment 6 FirstLevel 2012-10-15 10:05:03 MSD
Created attachment 664 [details]
desktop alpha2 error on 12 console
Comment 7 Konstantin Vlasov 2012-10-19 16:32:14 MSD
(In reply to comment #3)
> In the ROSA Desktop 2012 alpha 2 I have such situation.

On ROSA Desktop Alpha2 I cannot reproduce this situation. Does it really occur in your tests? If yes then, please, give us more information: specific iso build number and configured list of partitions with their respective mount points
Comment 8 FirstLevel 2012-10-21 13:33:18 MSD
(In reply to comment #7)
> (In reply to comment #3)
> > In the ROSA Desktop 2012 alpha 2 I have such situation.
> 
> On ROSA Desktop Alpha2 I cannot reproduce this situation. Does it really
> occur in your tests? If yes then, please, give us more information: specific
> iso build number and configured list of partitions with their respective
> mount points
isonumber - 403
Disk partitions: two sata disks. First - root partition and swap, second - /var
Comment 9 FirstLevel 2012-10-21 13:33:18 MSD
(In reply to comment #7)
> (In reply to comment #3)
> > In the ROSA Desktop 2012 alpha 2 I have such situation.
> 
> On ROSA Desktop Alpha2 I cannot reproduce this situation. Does it really
> occur in your tests? If yes then, please, give us more information: specific
> iso build number and configured list of partitions with their respective
> mount points
isonumber - 403
Disk partitions: two sata disks. First - root partition and swap, second - /var
Comment 10 Konstantin Vlasov 2012-10-22 12:29:32 MSD
403 is really a VERY old build! It's not even available in the ABF downloads anymore. Please, try with the recent iso builds. Most preferably, the latest 499 (pre-Beta).
Comment 11 FirstLevel 2012-10-22 14:07:36 MSD
(In reply to comment #10)
> 403 is really a VERY old build! It's not even available in the ABF downloads
> anymore. Please, try with the recent iso builds. Most preferably, the latest
> 499 (pre-Beta).

I think I am waiting for real beta
Comment 12 FirstLevel 2012-10-26 09:24:32 MSD
Created attachment 792 [details]
error in the installator
Comment 13 FirstLevel 2012-10-26 09:24:51 MSD
Created attachment 793 [details]
messages on ctrl-f12 in beta
Comment 14 FirstLevel 2012-10-26 09:25:07 MSD
Created attachment 794 [details]
fdisk -l for beta
Comment 15 FirstLevel 2012-10-26 09:25:32 MSD
Created attachment 795 [details]
mount -l for beta
Comment 16 Konstantin Vlasov 2012-12-19 20:10:27 MSK
In final Desktop.Fresh 2012 images this problem seems to be fixed. Could you please test it?
Comment 17 FirstLevel 2012-12-24 16:36:33 MSK
(In reply to comment #16)
> In final Desktop.Fresh 2012 images this problem seems to be fixed. Could you
> please test it?

No. I have tested such situation in Virtualbox with separate HDD for /var - error occured.
See attach var.zip
Comment 18 FirstLevel 2012-12-24 16:36:49 MSK
Created attachment 965 [details]
var.zip
Comment 19 Konstantin Vlasov 2013-01-15 14:14:21 MSK
The problem was caused by postfix chroot configuration, and in the latest builds it is fixed. The next ISO builds will contain this fix. At the moment, you can check it in the test ISO build 835:
https://abf.rosalinux.ru/platforms/144/products/25/product_build_lists/835