Bug 880 - systemd bug: CUPS interface error for "Administration" option
: systemd bug: CUPS interface error for "Administration" option
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: High critical
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 14:23 MSD by Eugene Sobolev
Modified: 2012-12-17 11:22 MSK (History)
5 users (show)

See Also:
RPM Package: cups
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
dmitry.romashkin: secteam_verified+
alex.burmashev: published+


Attachments
CUPS error for web-administration (after install) (59.03 KB, image/png)
2012-10-08 14:23 MSD, Eugene Sobolev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Sobolev 2012-10-08 14:23:46 MSD
Created attachment 644 [details]
CUPS error for web-administration (after install)

Description of problem:

CUPS error 500 (see attachment)

Version-Release number of selected component (if applicable):

ROSA Marathon 2012 RP1

How reproducible:

1. Go to "http://localhost:631/admin" in browser after install
Comment 1 Aleksandr Kazantcev 2012-10-08 14:38:06 MSD
1. Disable extension (like adblock and similar)
2. Check, if CUPS service running
Comment 2 Aleksandr Kazantcev 2012-10-08 14:38:32 MSD
*** Bug 881 has been marked as a duplicate of this bug. ***
Comment 3 Eugene Sobolev 2012-10-08 14:42:06 MSD
1. Disable AdBlock extension - no effect.
2. CUPS check:

[root@oev СПО]# /etc/init.d/cups status
cups.service - CUPS printing server daemon
          Loaded: loaded (/lib/systemd/system/cups.service; enabled)
          Active: active (running) since Fri, 05 Oct 2012 12:41:07 +0400; 3 days ago
         Process: 1301 ExecStart=/usr/sbin/cupsd (code=exited, status=0/SUCCESS)
         Process: 1299 ExecStartPre=/sbin/portrelease cups (code=exited, status=0/SUCCESS)
        Main PID: 1302 (cupsd)
          CGroup: name=systemd:/system/cups.service
                  └ 1302 /usr/sbin/cupsd -C /etc/cups/cupsd.conf
Comment 4 Eugene Sobolev 2012-12-11 13:14:28 MSK
User created by default should be added to the group "lp". It's solution.
Comment 5 alexander barakin 2012-12-14 12:41:39 MSK
https://qa.mandriva.com/show_bug.cgi?id=63577#c11

> i found that almost always cups is not listening on port 631·
> 
> i see in /var/log/cups/error_log the following lines:
> "Unable to bind socket for address 127.0.0.1:631 - Address already in use."
> 
> this occurs due to the fact that the daemon portreserve too late to start·
> 
> the best solution I have found so far is to disable this daemon:
> $ sudo systemctl disable portreserve.service

может, пора уже выкинуть к чертям этот portreserve, а?
ну, раз мы не можем выкинуть systemd, который не в состоянии вовремя остановить ненужного демона?
Comment 6 alexander barakin 2012-12-14 12:49:31 MSK
bug is related to systemd, not to cups.
Comment 7 alexander barakin 2012-12-14 17:06:51 MSK
advisory: start cups.service after portreserve.service; closes bug #880

https://abf.rosalinux.ru/build_lists/856738
https://abf.rosalinux.ru/build_lists/856739
Comment 8 Alexander Petryakov 2012-12-17 00:46:37 MSK
cups-1.4.8-10
************** Advisory **************
start cups.service after portreserve.service;
**************************************
QA Verified