Bug 8735 - [Update Request] gzdoom
: [Update Request] gzdoom
Status: IN_PROGRESS
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-06 21:20 MSK by Zombie Ryushu
Modified: 2018-02-07 16:57 MSK (History)
2 users (show)

See Also:
RPM Package: gzdoom
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2018-02-06 21:20:50 MSK
The Current version of GzDoom is 3.2.5, Please import from OpenSuse.
Comment 1 Andrey Bondrov 2018-02-07 08:39:36 MSK
Done, our GzDoom package is updated to 3.2.5 for rosa2016.1. 

We can also backport it to rosa2014.1. But new version is SDL2-based. And SDL2 in rosa2014.1 is not as good as in rosa2016.1. So it's up to you to decide if we should backport.

If you need to test rosa2014.1 build, use these containers:

https://abf.rosalinux.ru/build_lists/2919212
https://abf.rosalinux.ru/build_lists/2919213
Comment 2 Zombie Ryushu 2018-02-07 12:55:29 MSK
Our Current build is absent 

/usr/share/games/gzdoom/ dirrectory and gzdoom.pk3
Comment 3 Andrey Bondrov 2018-02-07 13:44:17 MSK
(In reply to comment #2)
> Our Current build is absent 
> 
> /usr/share/games/gzdoom/ dirrectory and gzdoom.pk3

That's because new version strongly recommends to use standard path for Doom engines: /usr/share/doom/

Likely you need to edit old config if you have any.
Comment 4 Zombie Ryushu 2018-02-07 16:57:19 MSK
Your new Packages do seem to correct the PK3 problem, however. the test failed on the build.