Bug 866 - rosa media player could not play mms video stream
: rosa media player could not play mms video stream
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Lowest enhancement
: ---
Assigned To: Denis Silakov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 16:08 MSD by FirstLevel
Modified: 2015-04-03 17:36 MSD (History)
5 users (show)

See Also:
RPM Package: rosa-media-player-1.5-12-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments
rosa media player and VLC (321.13 KB, image/png)
2012-10-06 16:08 MSD, FirstLevel
Details
Stream properties in VLC (644.68 KB, image/png)
2012-10-06 16:08 MSD, FirstLevel
Details
romp1 (1.34 MB, image/png)
2013-03-02 21:29 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-06 16:08:01 MSD
Created attachment 640 [details]
rosa media player and VLC

Description of problem:
On the page  http://www.veseloeradio.ru/?an=trans_umor there is embedded player with streaming video with such url  http://www.101.ru/asxv.asx?uid=260301
If You try to open this URL in  rosa-media-player - nothing happens
BTW VLC could play this video stream
As You can see it is mms video stream with Microsoft media codecs

[sergei@ltsrp1-64 ~]$ rpm -qa | grep vlc
lib64vlccore5-2.0.1-2plf-plf2012.0.x86_64
lib64vlc5-2.0.1-2plf-plf2012.0.x86_64
vlc-2.0.1-2plf-plf2012.0.x86_64
vlc-plugin-theora-2.0.1-2plf-plf2012.0.x86_64
vlc-plugin-pulse-2.0.1-2plf-plf2012.0.x86_64
[sergei@ltsrp1-64 ~]$ 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-10-06 16:08:27 MSD
Created attachment 641 [details]
Stream properties in VLC
Comment 2 Denis Koryavov 2012-10-07 09:21:48 MSD
This adress works for me perfectly mms://89.20.132.26/v3_1?st=&WMContentBitrate=2790000 in ROSA Media Player.
Comment 3 FirstLevel 2012-10-07 11:48:56 MSD
(In reply to comment #2)
> This adress works for me perfectly
> mms://89.20.132.26/v3_1?st=&WMContentBitrate=2790000 in ROSA Media Player.

Ok. May be conditions for this case are some wrong.
I'll try to describe.
1. I have openned http://www.veseloeradio.ru/?an=trans_umor in firefox and did not see videotranslation
2. I have clicked right mouse button on player and selected "Copy URL". It was http://www.101.ru/asxv.asx?uid=260301
3. I have openned this URL in VLC and seen the translation
4. I have openned this URL in ROMP and could see nothing
Could You repeat my steps?
Comment 4 Denis Koryavov 2012-10-08 11:27:47 MSD
OK, I understand. We'll try to fix this bug ASAP.
Comment 5 Denis Koryavov 2013-03-01 16:06:12 MSK
Is this bug still exist?
Comment 6 FirstLevel 2013-03-02 16:17:30 MSK
I have such problem for 
rosa-media-player-plugin-1.0-2-rosa.lts2012.0.i586
rosa-media-player-1.5.1-1-rosa.lts2012.0.i586
Comment 7 Postnikov Dmitry 2013-03-02 21:29:49 MSK
Created attachment 1244 [details]
romp1

(In reply to comment #3)
> 2. I have clicked right mouse button on player and selected "Copy URL". It
> was http://www.101.ru/asxv.asx?uid=260301
> 4. I have openned this URL in ROMP and could see nothing
> Could You repeat my steps?


All works in ROMP 1.5.1-7
and mms:// also work.
Comment 8 FirstLevel 2013-03-03 14:37:05 MSK
(In reply to comment #7)
> Created attachment 1244 [details]
> romp1
> 
> (In reply to comment #3)
> > 2. I have clicked right mouse button on player and selected "Copy URL". It
> > was http://www.101.ru/asxv.asx?uid=260301
> > 4. I have openned this URL in ROMP and could see nothing
> > Could You repeat my steps?
> 
> 
> All works in ROMP 1.5.1-7
> and mms:// also work.

As You can see bug is presented in LTS release with rosa-media-player-1.5.1-1-rosa.lts2012.0.i586
Comment 9 Stanislav Fomin 2013-10-15 12:45:46 MSD
OK, need backporting.
Comment 10 Denis Silakov 2013-10-15 17:56:24 MSD
ROMP from Desktop Fresh can be built without any changes for Marathon, let's check how it works.

Advisory:
Backported ROSA Media Player 1.6.9 from Desktop Fresh R1 with several fixes including MMS video stream support.

Build lists:
https://abf.rosalinux.ru/build_lists/1353326
https://abf.rosalinux.ru/build_lists/1353325
Comment 11 Vladimir Potapov 2013-10-17 11:41:51 MSD
1) http://bugs.rosalinux.ru/show_bug.cgi?id=1157#c21  Update to mplayer1.1 needed 
new ROMP omen DVD only with menu, but menu don't work
2) add romp-plugin
********************
QA Denied
Comment 12 Denis Silakov 2013-10-17 15:38:38 MSD
(In reply to comment #11)
> 1) http://bugs.rosalinux.ru/show_bug.cgi?id=1157#c21  Update to mplayer1.1
> needed 
> new ROMP omen DVD only with menu, but menu don't work

Hm, can we update mplayer separately from ROMP? Currently mplayer 1.1 fails to build for LTS and I have not time to investigate the reasons.

ROMP update by itself should fix not only this bug, but also bug #68 and bug #191.
Comment 13 Vladimir Potapov 2013-10-17 15:52:10 MSD
But ROMP can't play all DVD - it's fatal bug.
mplayer 1.1 already build for lts long time age.
Comment 14 Denis Silakov 2013-10-17 16:00:54 MSD
Mpalyer was built to containers. Containers are automatically destroyed in a month, so that builds were destroyed long ago.

Currently it fails to be built (likely because some libraries were updated).

What I wanted to say is that mplayer is not required to build rosa-media-player. We can update romp, then if we find time we update mplayer and romp will automatically get possibility to work with DVDs correctly.
Comment 15 Vladimir Potapov 2013-10-17 16:13:49 MSD
Now DVD play correct (but without menu). After update to new version DVD can't play. It's big regression.
Comment 16 Denis Silakov 2013-10-17 16:15:11 MSD
Ah, ok. I thought that there is no regression here.
Comment 17 Denis Silakov 2015-04-03 17:36:10 MSD
"wontfix" for Marathon. New ROMP with requested functionality will be available in the next version of Enterprise Desktop.