Bug 8647 - [UPDATE REQUEST 2016.1] gig 4.0.0 -> 4.1.0
: [UPDATE REQUEST 2016.1] gig 4.0.0 -> 4.1.0
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-08 22:04 MSK by Giovanni Mariani
Modified: 2018-01-08 22:06 MSK (History)
0 users

See Also:
RPM Package: gig-4.0.0-5.src.rpm
ISO-related:
Bad POT generating:
Upstream:
mc2374: qa_verified?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2018-01-08 22:04:09 MSK
Update available to release 4.1.0 for gig library.

Notable changes since our actual 4.0.0 release:
* support for gig or DLS files greater than 2 GB;

* fixed a bunch of CVEs: CVE-2017-12950, CVE-2017-12951, CVE-2017-12952, CVE-2017-12953 and CVE-2017-12954;

* fixed potential crashes in command line tools gig2stereo, korg2gig, korgdump and sf2extract;

* added new parameter "--verify" which allows to check the raw wave form data integrity of all samples;

* added and implemented new parameter "--rebuild-checksums" which allows to recalculate the CRC32 checksum of all samples' raw wave data and rebuilding the gig file's global checksum table (i.e. in case the file's checksum table was damaged).

* minor fixes to man pages and for spelling mistakes.

While being a library, the update is rather safe because all the packages depending upon this one (lmms, linuxsampler, gigedit and qsampler) have updates pending and require the new gig release...
Comment 1 Giovanni Mariani 2018-01-08 22:06:13 MSK
Advisory:
Update gig to the 4.1.0 release.
Needed by lmms, linuxsampler, gigedit and qsampler packages.

Packages for Rosa 2016.1 / Main:
https://abf.rosalinux.ru/build_lists/2916822
https://abf.rosalinux.ru/build_lists/2916823