Bug 8568 - [UPDATE REQUEST] KF5 5.38 -> 5.41
: [UPDATE REQUEST] KF5 5.38 -> 5.41
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-12 19:54 MSK by Andrey Bondrov
Modified: 2017-12-18 13:14 MSK (History)
1 user (show)

See Also:
RPM Package: kf5
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
vladimir.potapov: published?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2017-12-12 19:54:00 MSK
We need to update KF5 to new version 5.41.

Please use this repository for testing: http://abf-downloads.rosalinux.ru/kde5_backports_personal/repository/rosa2016.1/
Comment 1 Vladimir Potapov 2017-12-15 06:39:39 MSK
urpmi kalarm not install akonadi
Comment 2 Vladimir Potapov 2017-12-15 06:55:52 MSK
в образ забыли включить filelight
Comment 3 Vladimir Potapov 2017-12-15 07:00:19 MSK
а зачем в комплекте два akonadi, причем конфликтующих?
Comment 4 Vladimir Potapov 2017-12-15 07:09:28 MSK
kmail тоже требует akonadi
Comment 5 Vladimir Potapov 2017-12-15 07:23:18 MSK
knotes не работает (вероятно, тоже с akonadi связано)
Comment 6 Andrey Bondrov 2017-12-15 07:23:45 MSK
(In reply to comment #3)
> а зачем в комплекте два akonadi, причем конфликтующих?

Ты имеешь в виду, что один от KDE 4 (akonadi), а другой от Plasma 5 (plasma5-akonadi)?

Вообще, сейчас добавлю plasma5-akonadi в зависимости к kalarm и kmail, но это относится к KDE Applications, а не к KF5. Так что соберётся уже в составе KDE Applications 17.12.x.
Comment 7 Andrey Bondrov 2017-12-15 07:25:12 MSK
(In reply to comment #5)
> knotes не работает (вероятно, тоже с akonadi связано)

(In reply to comment #6)
> 
> Вообще, сейчас добавлю plasma5-akonadi в зависимости к kalarm и kmail, но
> это относится к KDE Applications, а не к KF5. Так что соберётся уже в
> составе KDE Applications 17.12.x.

Или лучше заведи отдельный общий баг на пакеты, которым plasma5-akonadi не хвататило, чтобы я туда билд-листы скидывал.
Comment 8 Andrey Bondrov 2017-12-15 07:30:16 MSK
Хотя не помню, не для того ли я не добавлял в зависимости plasma5-akonadi, что в KDE 4 надо ставить не его, а просто akonadi (который совместим с plasma5-akonadi). И надо не зависимости править, а пакет в образы Plasma 5 включать.
Comment 9 Vladimir Potapov 2017-12-15 10:03:01 MSK
(In reply to comment #8)
> Хотя не помню, не для того ли я не добавлял в зависимости plasma5-akonadi,
> что в KDE 4 надо ставить не его, а просто akonadi (который совместим с
> plasma5-akonadi). И надо не зависимости править, а пакет в образы Plasma 5
> включать.
Ну в общем это надо как-то решить, т.к. множество программ не запускаются и на первый взгляд непонятно, что ставить чтоб они взлетели (два несовместимых аконади)
Comment 10 Vladimir Potapov 2017-12-18 13:14:35 MSK
QA Verified
***************************