Bug 855 - Libre Office have Slovenian dictionary no Russian
: Libre Office have Slovenian dictionary no Russian
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal trivial
: when fixed upstream
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
: ROSA 2012.1 Beta2
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 01:02 MSD by Postnikov Dmitry
Modified: 2013-11-11 14:16 MSK (History)
2 users (show)

See Also:
RPM Package: libreoffice-core-3.6.2-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream: known


Attachments
Slovenian dict no Russian (196.10 KB, image/png)
2012-10-06 01:02 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2012-10-06 01:02:28 MSD
Created attachment 627 [details]
Slovenian dict no Russian

Description of problem:
Libre Office somehow dictionary of the English and Slovenian, no Russian.

See attachment
Comment 1 Aleksandr Kazantcev 2012-10-06 02:19:03 MSD
It's not a bug - some feature or joke in upstream.

If you see http://pkgs.org/search/?keyword=libreoffice-common - you may find this dictionary in all LO-common package since 3.5.x version.

Now LO not used internal dictionary, but external Myspell or Hunspell. Word's check is working now liki in Mozilla and other programs. You only need install correct Myspell lang package.

Bug will close, because it not been solved without break build. We need wait upstream fix.
Comment 2 Denis Koryavov 2012-10-06 12:08:07 MSD
But why we should close this bug? OK, this is upstream bug, but it is a bug!
Comment 3 Denis Koryavov 2012-10-06 12:17:49 MSD
According to the our bug policy (see Bugs/Workflow on the our corpwiki) this bug should be in "CONFIRMED" state. I don't know this bug will be reported to upstream or not, so I used "unknown" in the "Upstream" field.
Comment 4 Aleksandr Kazantcev 2012-10-06 12:42:48 MSD
It's NOT a bug. Now dictionary in Linux not uppear in menu. But we do not remove package from it - sl package using in build test and US too.

It's feature current build in LO with external dictionary.
Comment 5 Aleksandr Kazantcev 2012-10-06 13:44:15 MSD
It's known in upstream and i'm say 'that is not a bug'. It's normal for LO > 3.5.0. 

Why we need has it confirmed? We don't drop sl dictionary, don't break LO (if user wants add you's dictionary) and don't add myspell/hunspell dict in a list - it's problem for croosplatform realisation.
Comment 6 Denis Koryavov 2012-10-07 09:14:21 MSD
OK, let's discuss what we should do with this situation. Indeed, why I see in LO settings Slovenian dictionary for Russian language? Is this situation normal?
Comment 7 Postnikov Dmitry 2012-11-22 20:23:47 MSK
In 546th iso - Added "standard", and the Slovenian and still is.
Comment 8 Postnikov Dmitry 2013-11-11 13:43:11 MSK
In version libreoffice-4.1.2.3 the problem remained.
Comment 9 Aleksandr Kazantcev 2013-11-11 14:16:36 MSK
And again - this is upstream bug. LO in Linux don't use this section. We use system hunspell, that not able visible in menu - this menu only for custom and aspell dictionary. Situation similar in all distro with hunspell.