Bug 8504 - No support for NVMe devices in the installer
: No support for NVMe devices in the installer
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: m.voznesensky
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-21 19:11 MSK by Eugene Shatokhin
Modified: 2017-11-23 18:46 MSK (History)
2 users (show)

See Also:
RPM Package: draklive-install
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2017-11-21 19:11:52 MSK
The installer of ROSA simply ignores NVMe devices at the moment and does not allow to install ROSA there.

The same problem may affect SD/MMC devices as well.

Most likely, this is because of the naming scheme: the installer seems to expect the storage devices to be /dev/sd*, /dev/hd* or /dev/vd* while it gets /dev/nvmeXnY, e.g., /dev/nvme0n1 for NVMe. For SD/MMC, it would be something like /dev/mmcblkX.

Note that QEMU VMs can be used to emulate NVMe devices, which may help in debugging and testing. See the instructions here (in Russian): http://wiki.rosalab.ru/ru/index.php/QEMU_-_%D0%BF%D0%BE%D0%BB%D0%B5%D0%B7%D0%BD%D1%8B%D0%B5_%D1%81%D0%BE%D0%B2%D0%B5%D1%82%D1%8B
Comment 1 Sergei Trusov 2017-11-23 16:22:04 MSK
MMC works just fine

https://linux-hardware.org/index.php?probe=a419e65f55&log=blkid
Comment 2 Eugene Shatokhin 2017-11-23 18:46:43 MSK
(In reply to comment #1)
> MMC works just fine
> 
> https://linux-hardware.org/index.php?probe=a419e65f55&log=blkid

Ah, that's good. It is only needed to add support for NVMe then.