Bug 8493 - [UPDATE REQUEST 2016.1] sdl2 2.0.5 -> 2.0.7
: [UPDATE REQUEST 2016.1] sdl2 2.0.5 -> 2.0.7
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-17 07:32 MSK by Andrey Bondrov
Modified: 2017-11-28 06:54 MSK (History)
1 user (show)

See Also:
RPM Package: sdl2
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2017-11-17 07:32:44 MSK
New version of SDL2 was released. We also need to build it with -mstackrealign flag to fix segfaults of FPC-compiled applications that use SDL2.
Comment 1 Andrey Bondrov 2017-11-17 07:33:43 MSK
Advisory: "Update SDL2 to new version 2.0.7. Enable Wayland support. Build with -mstackrealign flag."

https://abf.rosalinux.ru/build_lists/2913226
https://abf.rosalinux.ru/build_lists/2913227
Comment 2 Andrey Bondrov 2017-11-17 07:35:23 MSK
Please test this build before and after SDL2 update. Before update it's likely to fail on mission start.

Advisory: "Update hedgewars to new version 0.9.23. Switch to use SDL2."

https://abf.rosalinux.ru/build_lists/2913224
https://abf.rosalinux.ru/build_lists/2913225
Comment 3 Vladimir Potapov 2017-11-17 11:18:31 MSK
(In reply to comment #2)
> Please test this build before and after SDL2 update. Before update it's
> likely to fail on mission start.
> 
> Advisory: "Update hedgewars to new version 0.9.23. Switch to use SDL2."
> 
> https://abf.rosalinux.ru/build_lists/2913224
> https://abf.rosalinux.ru/build_lists/2913225

Hm, I can't reproduce the bug. I try R9 GNOME X64 and plasma i586, nvidia proprietary drivers
Comment 4 Vladimir Potapov 2017-11-21 17:51:50 MSK
The update is sent to expanded testing
***************************************
Comment 5 Vladimir Potapov 2017-11-28 06:34:23 MSK
SDL2-2.0.7-3
https://abf.rosalinux.ru/build_lists/2913226
https://abf.rosalinux.ru/build_lists/2913227
************************* Advisory ***************************
Update SDL2 to new version 2.0.7. Enable Wayland support. Build with -mstackrealign flag.
**************************************************************
QA Verified