Bug 84 - Ktorrent always creates a "Private torrent (DHT denied)"
: Ktorrent always creates a "Private torrent (DHT denied)"
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: i586 Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 01:02 MSD by Postnikov Dmitry
Modified: 2013-04-09 11:50 MSD (History)
2 users (show)

See Also:
RPM Package: ktorrent-4.1.1-3-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2012-04-19 01:02:06 MSD
Description of problem:
EN:
In 240th iso image. Ktorrent always creates a "Private torrent (DHT denied)", even when not selected "Private Torrent (DHT denied)." That is always followed by a torrent file in Ktorrent - DHT distribution is denied.

RU:
В 240м образе. Ktorrent всегда создает "Частный торрент (DHT запрещен)" даже когда не выбрана опция "Частный торрент (DHT запрещен)". То есть всегда после создания торрент файла в Кторрент - DHT раздача запрещена.

Version-Release number of selected component (if applicable):
libktorrent-common-1.1.1-3-rosa.lts2012.0.i586
libktorrent3-1.1.1-3-rosa.lts2012.0.i586
ktorrent-4.1.1-3-rosa.lts2012.0.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Postnikov Dmitry 2012-12-27 16:06:30 MSK
In ktorrent-4.3.0-1-rosa2012.1.x86_64 problem remains.
lib64ktorrent5-1.3.0-1-rosa2012.1.x86_64
Comment 2 symbianflo 2013-01-29 21:38:18 MSK
(In reply to comment #1)
> In ktorrent-4.3.0-1-rosa2012.1.x86_64 problem remains.
> lib64ktorrent5-1.3.0-1-rosa2012.1.x86_64

I can not reproduce this bug so can you please try libktorrent-1.3.1/ktorrent-4.3.1 from my_personal .
For 586:
http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/rosa2012lts/i586/main/release/
For x86_64:
http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/rosa2012lts/x86_64/main/release/
and see if it's fixed ?
Thank you.
Comment 3 Denis Silakov 2013-04-09 11:50:54 MSD
Me too - I can't reproduce this issue neither with old ktorrent, nor with the new one. Maybe something was wrong with global Ktorrent settings or settings reused from older versions? It would be useful to have a reproducer on a clear system.