Bug 8395 - [UPDATE REQUEST 2016.1] obs-studio 19.0.3 -> 20.0.1
: [UPDATE REQUEST 2016.1] obs-studio 19.0.3 -> 20.0.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-09 00:17 MSD by Giovanni Mariani
Modified: 2017-11-13 19:19 MSK (History)
4 users (show)

See Also:
RPM Package: obs-studio-19.0.3-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2017-10-09 00:17:33 MSD
New release 20.0.1 for obs-studio.

Changes since our last 19.0.3 package:
* Fixed a crash with the image slide show that could happen under certain circumstances

* Fixed a bug which caused the Stats window to stop monitoring streaming/recording unless they were both active at the same time

* Fixed an issue where the settings window could sometimes get stuck with a bad size

* Fixed a bug where cropped sources would have incorrect alpha handling

* Fixed a bug where scene collections/profiles wouldn't properly overwrite existing if the user chooses to do so

* Fixed a crash that would happen if the program starts on a system with an unsupported video card, the program will now display a message as was originally intended

* Fixed various minor bugs

* Added new "modular" user interface that allows the user to move, disable, and customize elements of the UI. To unlock, go to the View menu, then the "Docks" sub-menu, and un-check "Lock UI". To reset to the default style, use "Reset UI"

* Added Stinger transitions, which allow the ability to use video files as a transition with a specific transitioning point timing during playback of the video

* Added a new "Auto" server for Twitch which will automatically select the server with the best routing. In addition, Twitch servers are now sorted based on the best route (as determined by Twitch)

* Added support for Mixer's FTL protocol which allows low-latency streaming on Mixer.

* Added the option to disable looping in the image slide show, and stop or become hidden when all slides have been played

* Added the option to change the visibility behavior of the image slide show: Pause when not in the current scene, restart when in the current scene, or always play regardless

* Added the option to manually control the image slide show with hotkeys

* Added the ability for the blackmagic source to automatically detect resolution/format rather than having to set it manually each time

* Added ability to lock sources to prevent accidentally clicking on and modifying the position of a source

* Added the ability to zoom in the preview for detailed editing while in canvas/output preview scaling modes.

* Added a "Defaults" button to the filters and properties windows which will reset values to their defaults

* Added a new "Rachni" theme

* Added a "Fullscreen Interface" option to the view menu

* Added the ability to use certain Japanese and European-specific keys as hotkeys

* Added the ability to modify projectors from the tray menu

* Added a network buffering option to the VLC source

* Added a --multi command line option to suppress the multiple instance warnings

* Added a "Below Normal" process priority to the process priority option in advanced settings on windows

* Audio meters will now temporarily change their color to red when audio is clipping (too loud)

* When using the auto-configuration dialog with Twitch, it will now automatically test the 3 servers with the best route

* Made a few key improvements to the windows AMD AMF encoder. Fixed a potential crash, added support for AMF 1.4.4, added compatibility for newer drivers such as 17.7.2, and improved support for older drivers like 16.11.5 and 16.12.1.
Comment 1 Giovanni Mariani 2017-10-09 00:19:03 MSD
Advisory:
update obs-studio to release 20.0.1.

Packages for Rosa 2016.1 / Restricted:
https://abf.rosalinux.ru/build_lists/2899655
https://abf.rosalinux.ru/build_lists/2899656
Comment 2 Алзим 2017-10-09 00:48:26 MSD
*** Bug 8111 has been marked as a duplicate of this bug. ***
Comment 3 Giovanni Mariani 2017-10-09 17:10:42 MSD
*** Bug 7021 has been marked as a duplicate of this bug. ***
Comment 4 Vladimir Potapov 2017-11-07 19:38:02 MSK
rebuild containers
https://abf.io/build_lists/2909005
https://abf.io/build_lists/2909006
Comment 5 Vladimir Potapov 2017-11-07 19:46:38 MSK
The update is sent to expanded testing
****************************************
Comment 6 Vladimir Potapov 2017-11-13 18:53:48 MSK
obs-studio-20.0.1-1
https://abf.io/build_lists/2909005
https://abf.io/build_lists/2909006
****************************** Advisory *****************************
update obs-studio to release 20.0.1.
*********************************************************************
QA Verified