Bug 8374 - [UPDATE REQUEST] nvidia384 384.90 + ldetect-lst 0.1.338
: [UPDATE REQUEST] nvidia384 384.90 + ldetect-lst 0.1.338
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-29 23:45 MSD by Eugene Shatokhin
Modified: 2017-10-18 04:15 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2017-09-29 23:45:59 MSD
New branch of NVidia drivers, 384.x + ldetect-lst 0.1.338.
Comment 1 Eugene Shatokhin 2017-09-29 23:55:48 MSD
Advisory:
Version 384.90 of NVidia graphics drivers is now available. The branch 384.x supports all the GPUs that 375.x did and adds a few more. Details: https://devtalk.nvidia.com/default/topic/1024243/unix-graphics-announcements-and-news/linux-solaris-and-freebsd-driver-384-90-long-lived-branch-release-/. ldetect-lst was updated accordingly for XFdrake to offer these new drivers when needed.


Build lists:
ldetect-lst:
	https://abf.io/build_lists/2896383
	https://abf.io/build_lists/2896384
nvidia384:
	https://abf.io/build_lists/2896385
	https://abf.io/build_lists/2896386

Notes:
The tests for nvidia384 failed on x86_64 because the driver requires 32-bit libglvnd from the 32-bit repos as well. This is expected.
Comment 2 VictorR2007 2017-09-30 21:38:05 MSD
Установил на ноутбук вчера.
Работает.
bash-4.4$ primusrun glxgears
285 frames in 5.0 seconds = 56.839 FPS
300 frames in 5.0 seconds = 59.965 FPS
300 frames in 5.0 seconds = 59.965 FPS
300 frames in 5.0 seconds = 59.966 FPS
300 frames in 5.0 seconds = 59.963 FPS
Comment 3 Vladimir Potapov 2017-10-02 16:26:35 MSD
The update is sent to expanded testing
***************************************
Comment 4 Eugene Shatokhin 2017-10-06 13:31:14 MSD
Cancelling QA for now: problems with Vulkan settings were found.
Comment 5 Eugene Shatokhin 2017-10-08 18:48:26 MSD
Advisory:
Version 384.90 of NVidia graphics drivers is now available. The branch 384.x supports all the GPUs that 375.x did and adds a few more. Details: https://devtalk.nvidia.com/default/topic/1024243/unix-graphics-announcements-and-news/linux-solaris-and-freebsd-driver-384-90-long-lived-branch-release-/. ldetect-lst was updated accordingly for XFdrake to offer these new drivers when needed.


Build lists:
ldetect-lst:
	https://abf.io/build_lists/2896383
	https://abf.io/build_lists/2896384
nvidia384:
	https://abf.io/build_lists/2899581
	https://abf.io/build_lists/2899582

Notes:
1. The tests for nvidia384 failed on x86_64 because the driver requires 32-bit libglvnd from the 32-bit repos as well. This is expected.

2. Please check if vulkaninfo shows something reasonable. There was a Vulkan-related regression in the previous build, should be fixed now.
Comment 6 Eugene Shatokhin 2017-10-08 18:51:43 MSD
Compared to v384.90-1, v384.90-2 changes only one file, nvidia_icd.json, containing Vulkan settings.

I have sent this version to Testing repos myself to speedup the process.
Comment 7 Vladimir Potapov 2017-10-17 19:53:33 MSD
ldetect-lst-0.1.338-1
https://abf.io/build_lists/2896383
https://abf.io/build_lists/2896384

nvidia384-384.90-2
https://abf.io/build_lists/2899581
https://abf.io/build_lists/2899582
****************************** Advisory **************************
Version 384.90 of NVidia graphics drivers is now available. The branch 384.x supports all the GPUs that 375.x did and adds a few more.
******************************************************************
QA Verified