Bug 835 - rm rp1 ee 2012 lts, privoxy does not start
: rm rp1 ee 2012 lts, privoxy does not start
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Marathon
: x86_64 Linux
: Normal normal
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 21:22 MSD by philippe.roubach
Modified: 2012-10-05 15:23 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe.roubach 2012-10-04 21:22:47 MSD
Description of problem:

when pc starts then privoxy doesn't start

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install privoxy
2.with drakproxy set privoxy as the system proxy
3.then restart pc
4 go to the MCC then list the services
then
you see privoxy is not started

try to use it with firefox then you can't access to internet

you can manualy start it.
starting works without pb; no error message
then
with firefox you can use it without pb
but
at the next restart no more privoxy
Comment 1 philippe.roubach 2012-10-04 21:24:04 MSD
it's privoxy 3.0.17


already with 2011 there were this pb
Comment 3 philippe.roubach 2012-10-04 21:41:00 MSD
(In reply to comment #2)
> My instruction
> http://wiki.rosalab.ru/ru/index.php/
> %D0%91%D0%BB%D0%BE%D0%BA%D0%B8%D1%80%D0%BE%D0%B2%D0%BA%D0%B0_%D0%B8%D0%BD%D1%
> 82%D0%B5%D1%80%D0%BD%D0%B5%D1%82_%D1%80%D0%B5%D0%BA%D0%BB%D0%B0%D0%BC%D1%8B_%
> D1%81_%D0%BF%D0%BE%D0%BC%D0%BE%D1%89%D1%8C%D1%8E_Privoxy
> (But only russian)

it's not a pb of how to install privoxy. i use privoxy for many years.

i assume there is a pb with systemd
Comment 4 Postnikov Dmitry 2012-10-04 22:01:56 MSD
You need to create a Service file for the systemd.
/etc/systemd/system/privoxy.service
==================
[Unit]
Description=Privacy enhancing HTTP Proxy
 
[Service]
ExecStart=/usr/sbin/privoxy --no-daemon /etc/privoxy/config
StandardOutput=syslog
StandardError=syslog

[Install]
WantedBy=multi-user.target
===================
https://bbs.archlinux.org/viewtopic.php?id=148069
Comment 5 philippe.roubach 2012-10-04 22:10:52 MSD
thanks i will try
Comment 6 philippe.roubach 2012-10-05 12:07:48 MSD
pb is solved since privoxy 3.0.18

please provide privoxy 3.019

explanation :

there is many reports about this bug.

it's a timing pb between privoxy and network manager during startup when dhcp is used

see bug https://bugzilla.redhat.com/show_bug.cgi?id=711587
Comment 8 philippe.roubach 2012-10-05 13:42:18 MSD
pb solved
Comment 9 Denis Silakov 2012-10-05 15:23:19 MSD
Ok, privoxy 3.0.19 is pushed to contrib/updates. Should be available on mirrors during a day.