Bug 8349 - RosaUpdate crashed
: RosaUpdate crashed
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-19 01:03 MSD by jdarnellj@yahoo.com
Modified: 2017-09-19 03:48 MSD (History)
0 users

See Also:
RPM Package: RosaUpdate
ISO-related:
Bad POT generating:
Upstream:


Attachments
lspcidrake -v output (3.03 KB, application/octet-stream)
2017-09-19 01:03 MSD, jdarnellj@yahoo.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jdarnellj@yahoo.com 2017-09-19 01:03:05 MSD
Created attachment 4731 [details]
lspcidrake -v output

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.The "RosaUpdate" program crashed. Drakbug-14.44 caught it.

Just installed system and was trying to run the first update.  Update would not proceed due to referenced error.

undefined package at /usr/lib/perl5/vendor_perl/5.20.3/x86_64-linux-thread-multi/URPM/Resolve.pm line 2080.
Perl's trace:
standalone::bug_handler() called from /usr/lib/perl5/vendor_perl/5.20.3/x86_64-linux-thread-multi/URPM/Resolve.pm:2080
URPM::_choose_best_pkg() called from /usr/lib/perl5/vendor_perl/5.20.3/x86_64-linux-thread-multi/URPM/Resolve.pm:2140
URPM::__ANON__() called from /usr/lib/perl5/vendor_perl/5.20.3/x86_64-linux-thread-multi/URPM/Resolve.pm:2162
URPM::request_packages_to_upgrade() called from /usr/lib/perl5/vendor_perl/5.20.3/Rpmdrake/pkg.pm:362
Rpmdrake::pkg::get_updates_list() called from /usr/lib/perl5/vendor_perl/5.20.3/Rpmdrake/pkg.pm:492
Rpmdrake::pkg::get_pkgs() called from /usr/lib/perl5/vendor_perl/5.20.3/Rpmdrake/gui.pm:631
Rpmdrake::gui::pkgs_provider() called from /usr/sbin/RosaUpdate:257
main::run_treeview_dialog() called from /usr/sbin/RosaUpdate:289

Theme name: Breeze
Kernel version = 4.9.20-nrj-desktop-1rosa-x86_64
Distribution=ROSA Desktop Fresh R9 release 2016.1 for x86_64
CPU=Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Comment 1 jdarnellj@yahoo.com 2017-09-19 03:48:54 MSD
After the initial error, I tried to reinstall and had much difficulty.  It appears part of the problem was how I configured the drives/partitions.  After much difficulty I finally got the OS to install.  RosaUpdate is now functioning properly.  Therefore, it appears the problem was likely a combination of specific hardware and my ignorance of how to properly partition my setup (I used custom partitioning).  This is the first distribution I have had difficulty partitioning so I am not sure if it is a bug, user error or just a coincidental/temporary glitch.  I am very satisfied now that everything is working as expected.