Bug 8324 - kodi will not run any plugins, displayes error in Python.
: kodi will not run any plugins, displayes error in Python.
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
https://forums.opensuse.org/showthrea...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-07 09:07 MSD by Zombie Ryushu
Modified: 2017-12-12 04:52 MSK (History)
3 users (show)

See Also:
RPM Package: kodi
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2017-09-07 09:07:05 MSD
extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_bytes() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_bytes() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.

Something is wrong with how kodi was compiled against Python.
Comment 1 Andrey Bondrov 2017-09-07 16:59:10 MSD
This should help.

Advisory: "Update python-cryptography-vectors and python-cryptography to new version 1.7.2"

python-cryptography-vectors:
https://abf.rosalinux.ru/build_lists/2892879
https://abf.rosalinux.ru/build_lists/2892880

python-cryptography:
https://abf.rosalinux.ru/build_lists/2892885
https://abf.rosalinux.ru/build_lists/2892886

Advisory: "Update python-OpenSSL to new version 17.0.0"

python-OpenSSL:
https://abf.rosalinux.ru/build_lists/2892889
https://abf.rosalinux.ru/build_lists/2892890

P.S. We update python-OpenSSL to 17.0.0 because 17.1+ is backward-incompatible with 16.0.0 (current version).
Comment 2 Andrey Bondrov 2017-12-07 19:46:05 MSK
Advisory: "Update python-cryptography-vectors and python-cryptography to new version 1.7.2"

python-cryptography-vectors:
https://abf.rosalinux.ru/build_lists/2914497
https://abf.rosalinux.ru/build_lists/2914498

python-cryptography:
https://abf.rosalinux.ru/build_lists/2914499
https://abf.rosalinux.ru/build_lists/2914500

Advisory: "Update python-OpenSSL to new version 17.0.0"

python-OpenSSL:
https://abf.rosalinux.ru/build_lists/2914503
https://abf.rosalinux.ru/build_lists/2914504

P.S. We update python-OpenSSL to 17.0.0 because 17.1+ is backward-incompatible with 16.0.0 (current version).
Comment 3 Vladimir Potapov 2017-12-08 17:58:59 MSK
The update is sent to expanded testing
**************************************
Comment 4 Vladimir Potapov 2017-12-11 18:25:48 MSK
python-cryptography-vectors-1.7.2-1
https://abf.rosalinux.ru/build_lists/2914497
https://abf.rosalinux.ru/build_lists/2914498

python-cryptography-1.7.2-1
https://abf.rosalinux.ru/build_lists/2914499
https://abf.rosalinux.ru/build_lists/2914500

python-OpenSSL-17.0.0-1
https://abf.rosalinux.ru/build_lists/2914503
https://abf.rosalinux.ru/build_lists/2914504
****************************** Advisory *******************************
Update python-cryptography-vectors and python-cryptography to new version 1.7.2 for fix kodi plugins. Update python-OpenSSL to new version 17.0.0
**********************************************************************
QA Verified