Bug 83 - KTorrent settings shows a few times.
: KTorrent settings shows a few times.
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: LXDE Edition
: Marathon
: i586 Linux
: Normal enhancement
: ---
Assigned To: Aleksandr Kazantcev
: ROSA Linux Bugs
:
Depends on: 337
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 00:52 MSD by Postnikov Dmitry
Modified: 2013-04-09 11:41 MSD (History)
3 users (show)

See Also:
RPM Package: ktorrent-4.1.1-3-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
Many setting one torrent file (199.44 KB, image/png)
2012-04-19 00:52 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2012-04-19 00:52:45 MSD
Created attachment 39 [details]
Many setting one torrent file

Description of problem:
EN:
In 240th iso imege. If the Ktorrent select torrent file and right-click to select the "Settings", and so do several times, several times Ktorrent will set the same torrent file. It should not be.
See attachment

RU:
В 240м образе. Если в Кторрент выделить торрент файл и правой кнопкой мыши выбрать "Настройки", и так сделать несколько раз, то Кторрент выдаст несколько раз настройки одного и того же торрент файла. Так не должно быть.
См. аттач файл

Version-Release number of selected component (if applicable):
libktorrent-common-1.1.1-3-rosa.lts2012.0.i586
libktorrent3-1.1.1-3-rosa.lts2012.0.i586
ktorrent-4.1.1-3-rosa.lts2012.0.i586

How reproducible:


Steps to Reproduce:
1. Start Ktorrent
2. Select one torrent file
3. Click right-mouse and select "Setting"
4. Click right-mouse and select "Setting"
5. Click right-mouse and select "Setting"
and more...
Comment 1 Alexander Khryukin 2012-06-05 14:48:34 MSD
Relevant update request
http://bugs.rosalinux.ru/show_bug.cgi?id=337
Comment 3 Alexander Khryukin 2012-06-28 16:28:17 MSD
BUMP
Comment 4 Postnikov Dmitry 2012-12-27 19:19:28 MSK
If earlier you could open the same file many times. After update, Ktorrent somehow missed, although in the repository has a NEW version. In repository only lib64 files, no ktorrent new package. Probably that ktorrent and not get updated.

[root@mindlife2 pastordi]# urpmf -ml ktorrent
ktorrent-debug:main
lib64ktorrent3:main
ktorrent-devel:main
libktorrent-common:main
ktorrent:main
libktorrent-debug:main
libktorrent-devel:main
lib64ktorrent4:main updates
libktorrent-common:main updates
libktorrent-debug:main updates
libktorrent-devel:main updates
[root@mindlife2 pastordi]#
Comment 5 Denis Silakov 2013-04-09 11:41:53 MSD
ktorrent has been updated once more since then (to 4.3.1), and the issue is fixed in that version.