Bug 8280 - [UPDATE REQUEST 2016.1] calf 0.0.60 -> 0.0.61
: [UPDATE REQUEST 2016.1] calf 0.0.60 -> 0.0.61
Status: RESOLVED DUPLICATE of bug 8459
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
http://calf-studio-gear.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-25 14:16 MSD by Giovanni Mariani
Modified: 2017-11-05 01:55 MSK (History)
2 users (show)

See Also:
RPM Package: calf-0.0.60-5.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2017-08-25 14:16:42 MSD
The last official release of calf was in 03/2015, but oh GitHUb there are fixes as recent as 10/08/2017: package a recent devel snapshot to pick up them.
See https://github.com/calf-studio-gear/calf/commits/master for all the gory details.
Comment 1 Giovanni Mariani 2017-08-25 14:20:52 MSD
Advisory:
Update calf to a recent (10/08/2017) devel snapshot.

Packages forRosa2016.1/Main:
https://abf.rosalinux.ru/build_lists/2888412
https://abf.rosalinux.ru/build_lists/2888413
Comment 3 Vladimir Potapov 2017-11-02 10:20:43 MSK
The update is sent to expanded testing
*****************************************
Comment 4 Anton Stankevich 2017-11-04 18:13:56 MSK
On Ardour 5.12 there are a problem: project created with old calf version have broken audio port connections. Each plugin has midi + two audio ports. DAW cannot autoconnect audio port correctly on mono strips with strict IO disabled. It leaves right channel unconnected. This can be fixed manually by pinout edit, but annoying. Midi port are used only for midi-leaning and general used does not need this feature. Please disable it if posible.
Comment 5 Giovanni Mariani 2017-11-05 00:37:29 MSK
(In reply to comment #4)
> On Ardour 5.12 there are a problem: project created with old calf version
> have broken audio port connections. Each plugin has midi + two audio ports.
> DAW cannot autoconnect audio port correctly on mono strips with strict IO
> disabled. It leaves right channel unconnected. This can be fixed manually by
> pinout edit, but annoying. Midi port are used only for midi-leaning and
> general used does not need this feature. Please disable it if posible.

In the calf sources AFAICT there is no obvious way to disable midi port for calf plugins: you can only enable/disable all ladspa and/or all lv2 plugins support.
However, please wait: there is a new official release of calf since just an hour ago. I will package it and we will see if this issue is still present...
Comment 6 Giovanni Mariani 2017-11-05 01:55:47 MSK
(In reply to comment #5)
> (In reply to comment #4)
> > On Ardour 5.12 there are a problem: project created with old calf version
> > have broken audio port connections. Each plugin has midi + two audio ports.
> > DAW cannot autoconnect audio port correctly on mono strips with strict IO
> > disabled. It leaves right channel unconnected. This can be fixed manually by
> > pinout edit, but annoying. Midi port are used only for midi-leaning and
> > general used does not need this feature. Please disable it if posible.
> 
> In the calf sources AFAICT there is no obvious way to disable midi port for
> calf plugins: you can only enable/disable all ladspa and/or all lv2 plugins
> support.
> However, please wait: there is a new official release of calf since just an
> hour ago. I will package it and we will see if this issue is still present...

Done, marking this bug as duplicate of the new package bug, and retiring QA and update request...

*** This bug has been marked as a duplicate of bug 8459 ***