Bug 8221 - [UPDATE REQUEST 2016.1] espeak 1.48.04 -> 1.48.15
: [UPDATE REQUEST 2016.1] espeak 1.48.04 -> 1.48.15
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 17:21 MSD by Giovanni Mariani
Modified: 2017-11-13 19:33 MSK (History)
2 users (show)

See Also:
RPM Package: espeak-1.48.04-4.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2017-08-09 17:21:36 MSD
This is really a snapshot from devel tree, but it allow us to have more than a year of updated and fixes:
* Language changes all around
* Language phoneme changes
* Phoneme tables added for Arabic
* New language: ia (interlingua)
* Added command-line options: --sep --tie
* Fixed character encoding problem with pt_rules
* Fix bug mispronouncing English words when using a voice with a non-Latin alphabet (eg. Tamil)
* Fix missing updates for mbrola US voices.
Comment 1 Giovanni Mariani 2017-08-09 17:24:02 MSD
Advisory:
Updated espeak to release 1.48.15.

Packages for Rosa 2016.1:
https://abf.rosalinux.ru/build_lists/2885810
https://abf.rosalinux.ru/build_lists/2885811
Comment 3 Vladimir Potapov 2017-11-02 10:22:10 MSK
ERROR: 'script' failed for espeak-1.48.15-1-rosa2016.1.x86_64: 
error: %pretrans(espeak-1.48.15-1.x86_64) scriptlet failed, exit status 1
Comment 4 Giovanni Mariani 2017-11-02 14:16:12 MSK
(In reply to comment #3)
> ERROR: 'script' failed for espeak-1.48.15-1-rosa2016.1.x86_64: 
> error: %pretrans(espeak-1.48.15-1.x86_64) scriptlet failed, exit status 1

This is a pre-existing issue: the same error shows also when installing our actual 1.48.04...
Try this:
1. remove all espeak packages
2. sudo urpmi espeak
3. whatch the same error message
However it looks like the message error is harmless: the package installs and works OK (at least on my PC or test VM)...
So I could argue that the also the old package should not pass the QA test...

Anyway, I guess I will remove the %pretrans thing. Moreover it looks like the thing was only needed for upgrade from 1.46.x to 1.47.x.
Comment 5 Giovanni Mariani 2017-11-02 14:32:42 MSK
Advisory:
Updated espeak to release 1.48.15.
Removed useless %pretrans scriptlet.

Packages for Rosa 2016.1 / Main:
https://abf.rosalinux.ru/build_lists/2907737
https://abf.rosalinux.ru/build_lists/2907738
Comment 6 Vladimir Potapov 2017-11-02 19:05:51 MSK
(In reply to comment #5)
> Advisory:
> Updated espeak to release 1.48.15.
> Removed useless %pretrans scriptlet.
> 
> Packages for Rosa 2016.1 / Main:
> https://abf.rosalinux.ru/build_lists/2907737
> https://abf.rosalinux.ru/build_lists/2907738

espeak test
Can't read data file: '/usr/share/espeak-data/phontab'
Failed to load espeak-data


It's regression, before update it works...
*****************************************
QA Denied
Comment 7 Giovanni Mariani 2017-11-03 02:20:06 MSK
(In reply to comment #6)
> (In reply to comment #5)
> > Advisory:
> > Updated espeak to release 1.48.15.
> > Removed useless %pretrans scriptlet.
> > 
> > Packages for Rosa 2016.1 / Main:
> > https://abf.rosalinux.ru/build_lists/2907737
> > https://abf.rosalinux.ru/build_lists/2907738
> 
> espeak test
> Can't read data file: '/usr/share/espeak-data/phontab'
> Failed to load espeak-data
> 
> 
> It's regression, before update it works...
> *****************************************
> QA Denied

The culprit is the tarball from Sourceforge: it does not contains all the needed stuff in espeak-data (and is so for *every* tarball from devel trunk, even for the one corresponding to our previous 1.48.04 release: only the official release source tarballs have all the file needed).

Luckily I somehow found a "test" tarball for 1.48.15 with all the needed stuff: I will build this one, instead of a svn dump of the trunk; while at it I also found an updated Russian dictionary, so took also this one...
Comment 8 Giovanni Mariani 2017-11-03 02:22:35 MSK
Advisory:
Updated espeak to release 1.48.15 (with the right sources).
Updated Source2 file.
Removed useless %pretrans scriptlet.

Packages for Rosa 2016.1 / Main:
https://abf.rosalinux.ru/build_lists/2907789
https://abf.rosalinux.ru/build_lists/2907790.

With this one, your test passes for me...
Comment 9 Vladimir Potapov 2017-11-08 20:03:51 MSK
The update is sent to expanded testing
****************************************
Comment 10 Vladimir Potapov 2017-11-13 18:16:59 MSK
espeak-1.48.15-3
https://abf.rosalinux.ru/build_lists/2907789
https://abf.rosalinux.ru/build_lists/2907790.
********************************** Advisory ***************************
Updated espeak to release 1.48.15.
***********************************************************************
QA Verified