Bug 8118 - [UPDATE REQUEST] openssl 1.0.2k -> 1.0.2l
: [UPDATE REQUEST] openssl 1.0.2k -> 1.0.2l
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest blocker
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 17:12 MSD by Andrey Bondrov
Modified: 2017-08-04 15:46 MSD (History)
2 users (show)

See Also:
RPM Package: openssl
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2017-06-30 17:12:54 MSD
New version of OpenSSL was released. Other then version update we should move engines directory to static location (/usr/lib[64]/openssl-1.0.0/engines instead of /usr/lib[64]/openssl-[version]/engines) to avoid rebuilding external engines after every OpenSSL minor version update.
Comment 1 Andrey Bondrov 2017-06-30 17:24:00 MSD
Advisory: "Update OpenSSL to new version 1.0.2l. Move engines to /usr/lib[64]/openssl-1.0.0/engines directory."

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2881194
https://abf.rosalinux.ru/build_lists/2881195

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2881196
https://abf.rosalinux.ru/build_lists/2881197
Comment 2 Andrey Bondrov 2017-07-01 04:12:01 MSD
Please check ASAP, the update blocks work on RED's crypto tools.
Comment 3 Vladimir Potapov 2017-07-01 19:04:16 MSD
The update is sent to expanded testing
****************************************
Comment 4 Andrey Bondrov 2017-07-03 11:37:01 MSD
We need to publish this update today.
Comment 5 Vladimir Potapov 2017-07-04 04:53:09 MSD
openssl-1.0.2l-1
rosa2016.1:
https://abf.rosalinux.ru/build_lists/2881194
https://abf.rosalinux.ru/build_lists/2881195

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2881196
https://abf.rosalinux.ru/build_lists/2881197
************************* Advisory ********************
Update OpenSSL to new version 1.0.2l. Move engines to /usr/lib[64]/openssl-1.0.0/engines directory.
*******************************************************
QA Verified