Bug 808 - Inscape freeze when try use file menu or file operation
: Inscape freeze when try use file menu or file operation
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High critical
: 2012 Desktop Beta2
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 11:55 MSD by Aleksandr Kazantcev
Modified: 2014-04-16 03:00 MSD (History)
3 users (show)

See Also:
RPM Package: inkscape-0.48.2-2
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2012-10-02 11:55:40 MSD
When you try open or save file in Inkscape, it freeze and may stop all system.

Reproduction:
1. Run Inkscape
2. Try open File menu
3. Enjoy freeze
Comment 1 rugyada 2012-11-02 19:34:56 MSK
Trying to open inkscape from console I get this output:


[cristina@localhost ~]$ inkscape
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

(inkscape:8500): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table != NULL' failed

(inkscape:8500): GLib-CRITICAL **: g_hash_table_insert_internal: assertion `hash_table != NULL' failed

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Errore di segmentazione (core dumped)
[cristina@localhost ~]$
Comment 2 Denis Koryavov 2012-11-27 20:15:26 MSK
Added an ugly fix to ROSA icons (1.0.31). This is because inkscape can't work with SVG files which created by himself.
Comment 3 Aleksandr Kazantcev 2012-11-27 20:16:45 MSK
Convert icons via inskape -l fix it. Problem with non-correct parsing text/css part in svg file.
Comment 4 Wade Colson 2014-04-16 03:00:59 MSD
*** Bug 260998 has been marked as a duplicate of this bug. ***
Seen from the domain http://volichat.com
Page where seen: http://volichat.com/teen-chat-rooms
Marked for reference. Resolved as fixed @bugzilla.