Bug 803 - Please add support of Exchange 2012 fro Evolution
: Please add support of Exchange 2012 fro Evolution
Status: UNCONFIRMED
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 08:27 MSD by FirstLevel
Modified: 2012-10-01 20:14 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-09-27 08:27:40 MSD
Now In ROSA 2012 LTS we have evolution with support of Exchange 2000/2003. It is based on OWA (Outlook Web Access).
But for Exchange 2007/2010 this method does not work, because Exchange 2007/2010 uses only RPC call.
In other distros there is evolution-mapi package that solves problem with access to Exchange 2007/2010
For example,
http://www.itsg33k.ca/en/2011/09/28/configuration-evolution-pour-exchange-2010-en-utilisant-mapi/
http://www.jones.ec/blogs/a/entry/evolution_evolution_mapi_and_exchange
http://www.andreagallazzi.com/2011/02/how-to-connect-evolution-to-exchange.html
http://pkgs.org/download/evolution-mapi
I think it is very important to add support of Exchange 2007/2010 to Evolution for LTS release, because it is oriented for Enterprise
Comment 1 symbianflo 2012-10-01 14:43:57 MSD
I think it's in import on abf ,
https://abf.rosalinux.ru/import/evolution-mapi
would be enough to fix the build and brach it to rosa2012lts
If nobody can do it until next weekend, I'll try.

greetings
Comment 2 symbianflo 2012-10-01 15:00:32 MSD
I think is related to 
http://mandriva.598463.n5.nabble.com/Bug-64864-New-Unsatisfied-devel-libreplace-in-libsamba-util-devel-td5031415.html

one of mandriva unsolved bug since Nov 29, 2011....
and it's a rosa2012LTS/main inherited problem.


greetings
Comment 3 Denis Silakov 2012-10-01 16:54:58 MSD
Yes, the main problem here is that evolution-mapi in its current state in ABF requires Samba4 which has been broken for a long time...
Comment 4 symbianflo 2012-10-01 20:14:46 MSD
(In reply to comment #3)
> Yes, the main problem here is that evolution-mapi in its current state in
> ABF requires Samba4 which has been broken for a long time...

I can not check it out right now but can you please verify if they have released new upstream releases and if it builds against samba 3.5 ?
( I think 3.5 we have on LTS) 




Greetigns