Bug 80 - krunner (Alt+F2) show two times terminal
: krunner (Alt+F2) show two times terminal
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: Ural Mullabaev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 13:42 MSD by FirstLevel
Modified: 2012-07-12 10:28 MSD (History)
6 users (show)

See Also:
RPM Package: kdebase4-workspace-4.8.2-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
krunner (140.54 KB, image/png)
2012-04-18 13:43 MSD, FirstLevel
Details
krunner-2 (99.22 KB, image/png)
2012-05-22 13:40 MSD, Postnikov Dmitry
Details
KRunner settings screenshot (1.13 MB, image/png)
2012-05-25 14:56 MSD, Andrey Bondrov
Details
Nepomuk returns doubled results (Dolphin search) (33.27 KB, image/png)
2012-06-09 15:35 MSD, Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-04-18 13:42:17 MSD
Description of problem:
If press "Alt+F2" and typing konsole, terminal will be shown twice
(see attache)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-04-18 13:43:08 MSD
Created attachment 36 [details]
krunner
Comment 2 Dmitry 2012-05-22 11:58:09 MSD
Many applications are shown twice.
Comment 3 Postnikov Dmitry 2012-05-22 13:40:05 MSD
Yes. Many app is double. R2012LTS i586.
See attach.
Comment 4 Postnikov Dmitry 2012-05-22 13:40:23 MSD
Created attachment 171 [details]
krunner-2
Comment 5 Andrey Bondrov 2012-05-25 14:56:39 MSD
Created attachment 189 [details]
KRunner settings screenshot
Comment 6 Andrey Bondrov 2012-05-25 14:59:18 MSD
The problem is caused by 

rosa-servicesEnabled=true
servicesEnabled=true

default settings in KRunner.

rosa-servicesEnabled comes from /usr/share/kde4/services/plasma-runner-rosa-services.desktop, a file from rosa-launcher package.

That's why we have 2 "Applications" entries in KRunner settings (see screenshot: Rosa 2012 LTS vs Mandriva 2010.2). There should be only one entry.
Comment 7 Dmitry 2012-06-09 15:35:31 MSD
Created attachment 251 [details]
Nepomuk returns doubled results (Dolphin search)
Comment 8 Dmitry 2012-06-09 15:37:11 MSD
(In reply to comment #7)
> Created attachment 251 [details]
> Nepomuk returns doubled results (Dolphin search)

Or it it better if I create new bug report?
Comment 9 Ural Mullabaev 2012-06-09 16:40:28 MSD
This problem has been already solved and fixes will be in updates soon.
Comment 10 Aleksey Yermakov 2012-06-09 16:51:09 MSD
Second service runner comes from rosa-launcher package. We're going to remove it and use standard system one. I will post an update for rosa-launcher later today, so this bug would be resolved soon.
Comment 11 Ural Mullabaev 2012-07-12 10:28:40 MSD
Fixed in the rosa-launcher-0.34.18.