Bug 799 - How should I use vesa driver during the installation?
: How should I use vesa driver during the installation?
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 13:19 MSD by FirstLevel
Modified: 2012-10-26 09:38 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-09-23 13:19:14 MSD
Description of problem:
I have such NVIDIA video card
00:05.0 VGA compatible controller: nVidia Corporation C51PV [GeForce 6150] (rev a2)
which is an nvidia chipset on ASUS M2NPV-VM mobo. It works with either nvidia or vesa drivers but not with nouveau or nv.
How should I use vesa driver during the installation Marathon 2012 RP1? I have choosen option
Install
Install (in safe mode)
and installation is broken because video driver is incompatible with my VGA adapter.
Is there any possibility to install ROSA MARATHON 2012 in text mode?


How reproducible:


Steps to Reproduce:
1.
2.
3.
This issue pertains to every version of ROSA I've used but at the moment I'm trying to install Marathon RP1 EE x86_64. What is the correct kernel option to get installer to use vesa driver? I've tried 'blacklist=nouveau xdriver=vesa xforce=vesa' in every combination and that doesn't do it. I've also tried simply 'vesa' which also doesn't work. This machine has this graphics:

00:05.0 VGA compatible controller: nVidia Corporation C51PV [GeForce 6150] (rev a2)

which is an nvidia chipset on ASUS M2NPV-VM mobo. It works with either nvidia or vesa drivers but not with nouveau or nv.

'Nuther question. Will ROSA installers work in text mode. I'm thinking that they won't.
Comment 1 Denis Koryavov 2012-09-23 14:38:52 MSD
> Will ROSA installers work in text mode. I'm thinking that they won't

Yes, you are right - ROSA's installer works only in graphic mode.
Comment 2 Alexander Burmashev 2012-09-23 15:04:20 MSD
One of the simple ways of starting install in vesa mode.
1) Boot in live mode ( even with broken graphics ).
2) Switch to another screen with ALT-F2
Comment 3 Alexander Burmashev 2012-09-23 15:05:44 MSD
Oops, occasional enter press.
So the next steps:
3) Run XFdrake and setup vesa graphic driver
4) Then at 7 screen restart X with CTRL-ALT-BACKSPACE
5) Login as live user
6) Run draklive-install-lock-storage from konsole
Comment 4 Denis Koryavov 2012-09-23 17:37:01 MSD
The way the for real Jedi. :)
Comment 5 Alexander Burmashev 2012-09-24 12:37:39 MSD
By the way, did you try "xdriver=vesa nomodeset" ?
I think it is proposed as the default method.
Comment 6 Ben Bullard 2012-10-26 05:20:52 MSD
xdriver=vesa nomodeset works here. And this bug was probably filed regarding my Ticket - ID 3189 filed with the help desk.

Thanks to all,
Ben Bullard
Comment 7 FirstLevel 2012-10-26 09:35:24 MSD
Is is resolved - fixed?
Comment 8 Ben Bullard 2012-10-26 09:38:48 MSD
Yes.