Bug 7975 - Missing /lib/systemd/systemd-sysv-install
: Missing /lib/systemd/systemd-sysv-install
Status: RESOLVED DUPLICATE of bug 8082
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-26 14:30 MSD by Dmitry Mikhirev
Modified: 2017-06-22 21:11 MSD (History)
1 user (show)

See Also:
RPM Package: systemd-230-5.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
This script is called by "systemctl enable/disable" when the given unit is a SysV init.d script. (1.33 KB, text/plain)
2017-06-19 07:58 MSD, Sergei Trusov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Mikhirev 2017-05-26 14:30:07 MSD
Description of problem:

systemctl is not fully functional. It cannot enable/disable sysv services or even systemd services, if sysv initscript for the same service is present.

$ sudo systemctl disable mandi.service
mandi.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable mandi
Failed to execute /lib/systemd/systemd-sysv-install: No such file or directory
$ sudo systemctl enable mandi.service
mandi.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable mandi
Failed to execute /lib/systemd/systemd-sysv-install: No such file or directory
$ 


Version-Release number of selected component (if applicable):

230-5

How reproducible:

Always
Comment 1 Sergei Trusov 2017-06-19 07:58:42 MSD
Created attachment 4659 [details]
This script is called by "systemctl enable/disable" when the given unit is a SysV init.d script.

Please consider including this into the systemd.

There are some hardware affected by systemd update http://forum.rosalab.ru/viewtopic.php?f=56&t=8259
Comment 2 Andrey Bondrov 2017-06-22 21:11:17 MSD

*** This bug has been marked as a duplicate of bug 8082 ***