Bug 7950 - [UPDATE REQUEST] audacity 2.1.2 -> 2.1.3
: [UPDATE REQUEST] audacity 2.1.2 -> 2.1.3
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-19 19:34 MSD by Giovanni Mariani
Modified: 2017-06-14 07:09 MSD (History)
3 users (show)

See Also:
RPM Package: audacity-2.1.2-4.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2017-05-19 19:34:56 MSD
New release for audacity.

New features:
* New Distortion effect, Rhythm Track (was called Click Track) and Sample Data Import. Also effects are no longer grayed-out when in pause.
* New scrub ruler.
* New ‘pinned’ option so the waveform moves and the recording/playing head stays still.
* New features in Timer Record.

Bug fixed - 64 bugs/annoyances in 2.1.2 fixed of which 15 were long standing issues.
Comment 1 Giovanni Mariani 2017-05-19 19:36:20 MSD
Advisory:
New release 2.1.3 for audacity.

Updated packages for Rosa 2016.1:
https://abf.rosalinux.ru/build_lists/2871904
https://abf.rosalinux.ru/build_lists/2871905
Comment 2 Vladimir Potapov 2017-05-29 19:21:15 MSD
Many regressions for Russian localizations
Comment 3 Giovanni Mariani 2017-05-31 21:52:40 MSD
(In reply to comment #2)
> Many regressions for Russian localizations
Vladimir, I'm sorry but I don't know a thing about Russian...
Who could help here?
Comment 4 Vladimir Potapov 2017-06-01 15:26:52 MSD
(In reply to comment #3)
> (In reply to comment #2)
> > Many regressions for Russian localizations
> Vladimir, I'm sorry but I don't know a thing about Russian...
> Who could help here?
It's regression. May be th project patched and the path not work?
Comment 5 Giovanni Mariani 2017-06-01 20:44:14 MSD
(In reply to comment #4)
> May be th project patched and the path not work?
No.
The thing is that Victor Ryzhikh (<victorr2007@yandex.ru>) provided in the past (see git log) a Source1 file containing an already compiled (ie binary) russian translation for audacity and the spec file directly installed it in the relevant directory, after removing the one built from sources:
***********
rm -rf %{buildroot}%{_datadir}/locale/ru/LC_MESSAGES/audacity.mo
cp %{SOURCE1} %{buildroot}%{_datadir}/locale/ru/LC_MESSAGES/audacity.mo
***********
The build log  for 2.1.3 does not show any error or warning about translation files, so I can only guess that our Source1 is no more in-sync with the new release sources.
I will try to build audacity without doing the above substitution, after the ongoing mass build will be done and submit to you for testing...

> It's regression.
Yes.
But I can't even "see" it: my default LANG is en_GB and anyway I can't read cyrillic or understand russian, so even if I switch it to ru_RU I have very hard times at catching what is wrongly changing with the new release...

If the binary translation file built from the new sources will still show the "many regressions", then I will be stuck...
BTW this was the reason of my request: "Who could help here?"

It would be a real pity if we cannot updated the package only because nobody can/bother to update Source1...
Comment 6 Giovanni Mariani 2017-06-02 12:54:54 MSD
(In reply to comment #5)
> I will try to build audacity without doing the above substitution, after the
> ongoing mass build will be done and submit to you for testing...
> 
Voilà, new packages without the Source1:
https://abf.rosalinux.ru/build_lists/2877763 (x86_64)
https://abf.rosalinux.ru/build_lists/2877611 (i586)

Please test...
Comment 7 VictorR2007 2017-06-03 16:42:09 MSD
Updated Russian translanions
https://abf.rosalinux.ru/build_lists/2877824
https://abf.rosalinux.ru/build_lists/2877825
Comment 8 Vladimir Potapov 2017-06-08 22:30:22 MSD
The update is sent to expanded testing
*****************************************
Comment 9 Vladimir Potapov 2017-06-13 19:45:45 MSD
audacity-2.1.3-3
https://abf.rosalinux.ru/build_lists/2877824
https://abf.rosalinux.ru/build_lists/2877825
******************************** Advisory *****************************
New release 2.1.3 for audacity.
***********************************************************************
QA Verified