Bug 7858 - [UPDATE REQUEST] krusader 2.5.0 to 2.6.0
: [UPDATE REQUEST] krusader 2.5.0 to 2.6.0
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-13 03:48 MSD by VictorR2007
Modified: 2017-05-22 21:27 MSD (History)
3 users (show)

See Also:
RPM Package: krusader
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
ss (282.73 KB, image/png)
2017-05-16 17:20 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VictorR2007 2017-04-13 03:48:44 MSD
Advisory:
Update required krusader
https://abf.rosalinux.ru/build_lists/2868733
https://abf.rosalinux.ru/build_lists/2868734
Comment 1 VictorR2007 2017-04-14 23:41:05 MSD
Пересобрал с небольшой чисткой спека
https://abf.rosalinux.ru/build_lists/2868862
https://abf.rosalinux.ru/build_lists/2868863
Comment 2 VictorR2007 2017-04-18 06:04:39 MSD
Забыл написать. Сейчас нет ярлыка запуска от рута.
Это не ошибка, а так задумано разработчиками.
Режим рута запускается через меню «Сервис - Запустить .. и.т.д.»
Появится предупреждение и т.д.
Comment 3 VictorR2007 2017-05-05 22:06:50 MSD
Оказалось неудобно без ярлыка запуска в режиме root.
И в режиме рута не запоминало последний каталог.
Собрал с ярлыком запуска в режиме root.
Стало гораздо удобнее, и начало при запуске 
открывать последний открытый каталог в режиме root.
https://abf.rosalinux.ru/build_lists/2870688
https://abf.rosalinux.ru/build_lists/2870689
Comment 4 Vladimir Potapov 2017-05-16 17:20:47 MSD
Created attachment 4639 [details]
ss

press F4, see error
Comment 5 Vladimir Potapov 2017-05-16 17:24:55 MSD
(In reply to comment #4)
> Created attachment 4639 [details]
> ss
> 
> press F4, see error

urpmi plasma5-kate
fix the bug
Comment 6 VictorR2007 2017-05-17 03:48:27 MSD
Не думаю, что нужно urpmi plasma5-kate.
Не всем он нуже, лучше plasma5-kwrite.
На plasma5 такой проблемы нет с plasma5-kwrite.
Сейчас пересоберу.
Comment 7 VictorR2007 2017-05-17 04:11:14 MSD
Добавил 
Suggests:  plasma5-kwrite

https://abf.rosalinux.ru/build_lists/2871620
https://abf.rosalinux.ru/build_lists/2871621

Надеюсь, что на KDE4 тоже будет работать, как на plasma5.
Comment 8 Vladimir Potapov 2017-05-18 15:17:19 MSD
(In reply to comment #7)
> Добавил 
> Suggests:  plasma5-kwrite
> 
> https://abf.rosalinux.ru/build_lists/2871620
> https://abf.rosalinux.ru/build_lists/2871621
> 
> Надеюсь, что на KDE4 тоже будет работать, как на plasma5.
Увы
urpmi krusader
Следующий пакет будет удалён для обновления остальных:
kwrite-4.14.3-4-rosa2016.1.x86_64
 (из-за конфликтов с plasma5-kwrite-16.12.3-1-rosa2016.1.x86_64) (y/N) 

ну и прошу поднимать релиз при каждой пересборке, иначе легко запутаться - какая версия где стоит.
Comment 9 VictorR2007 2017-05-18 15:56:51 MSD
(In reply to comment #8)
> Увы
> urpmi krusader
> Следующий пакет будет удалён для обновления остальных:
> kwrite-4.14.3-4-rosa2016.1.x86_64
>  (из-за конфликтов с plasma5-kwrite-16.12.3-1-rosa2016.1.x86_64) (y/N) 
> 
> ну и прошу поднимать релиз при каждой пересборке, иначе легко запутаться -
> какая версия где стоит.
А что не так с установкой?
Всё правильно, при plasma5-kwrite должна удаляться пакет kwrite-4.14.3.
В том и смысл, что krusader не работает с приложениями KDE4.
Только с plasma5-kate и plasma5-kwrite.
А KDE4 работает и с kate и kwrite, и с plasma5-kate и plasma5-kwrite.
В принципе, это одна и та же программа, только новые версии с переименованы.
Вот при установке и идёт замена kwrite на plasma5-kwrite.
Лично мне будет очень мешать установленный plasma5-kate.
И его постоянно придётся удалять.
Я plasma5-kate добавлять не буду.
Пусть останется без обновления.
Comment 10 VictorR2007 2017-05-18 17:17:07 MSD
Добавил 
Suggests:  plasma5-kate
https://abf.rosalinux.ru/build_lists/2871751
https://abf.rosalinux.ru/build_lists/2871752
Comment 11 Vladimir Potapov 2017-05-18 17:53:01 MSD
Please, add require ktexteditor-kf5
Comment 12 VictorR2007 2017-05-18 18:37:22 MSD
Added ktexteditor-kf5 dependency.
https://abf.rosalinux.ru/build_lists/2871757
https://abf.rosalinux.ru/build_lists/2871758
Comment 13 Vladimir Potapov 2017-05-19 08:31:43 MSD
The update is sent to expanded testing
************************************
Comment 14 Vladimir Potapov 2017-05-22 19:00:48 MSD
krusader-2.6.0-3
https://abf.rosalinux.ru/build_lists/2871757
https://abf.rosalinux.ru/build_lists/2871758
***************************** Advisory *****************************
New version, requirement corrected
********************************************************************
QA Verified