Bug 7770 - [UPDATE REQUEST] librsvg 2.40.13 -> 2.40.16
: [UPDATE REQUEST] librsvg 2.40.13 -> 2.40.16
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-08 22:10 MSK by Andrey Bondrov
Modified: 2017-03-13 10:45 MSK (History)
1 user (show)

See Also:
RPM Package: librsvg
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
vladimir.potapov: published?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2017-03-08 22:10:24 MSK
We need to update librsvg because current version has broken -w and -h options for rsvg-convert utility (reported upstream as https://bugzilla.gnome.org/show_bug.cgi?id=762115 ).

It seems to be fixed in 2.40.16.

How to test. Try to build gr-lida package. It uses rsvg-convert to create icons.

--------
# Install icons of various sizes
for s in 256 128 96 48 32 22 16 ; do
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${s}x${s}/apps
rsvg-convert -w ${s} -h ${s} -a \
    %{name}.svg -o \
    %{buildroot}%{_datadir}/icons/hicolor/${s}x${s}/apps/%{name}.png
done
--------

With current librsvg in rosa2016.1 small icons (16x16, 22x22 etc) are cropped, not scaled. 16x16 looks like an empty box, 22x22 has only few pixels of the picture.
Comment 1 Andrey Bondrov 2017-03-08 22:27:53 MSK
Advisory: "Update librsvg to new version 2.40.16 to fix regression with scaling images"

https://abf.rosalinux.ru/build_lists/2855529
https://abf.rosalinux.ru/build_lists/2855530
Comment 2 Vladimir Potapov 2017-03-09 19:47:37 MSK
The update is sent to expanded testing
****************************************
Comment 3 Vladimir Potapov 2017-03-13 10:45:08 MSK
librsvg-2.40.16-3
https://abf.rosalinux.ru/build_lists/2855529
https://abf.rosalinux.ru/build_lists/2855530
************************** Advisory **************************
Update librsvg to new version 2.40.16 to fix regression with scaling images
***************************************************************
QA Verified