Bug 7762 - Request Kernel Headers
: Request Kernel Headers
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-04 19:11 MSK by daz
Modified: 2017-03-08 22:33 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Sophos Anti-Virus for Linux user manual (169.80 KB, application/pdf)
2017-03-04 19:11 MSK, daz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daz 2017-03-04 19:11:14 MSK
Created attachment 4586 [details]
Sophos Anti-Virus for Linux user manual

H Eugene

Description of problem:
I need to " obtain or build suitable kernel support " to install Sophos-Antivrius 
to start process of elimination of infected system/server hack. 

 daz_2017@daz ~ $ sudo su
[sudo] password for daz_2017: 
daz daz_2017 # cd ~/Downloads
bash: cd: /root/Downloads: No such file or directory
daz daz_2017 # no cd '/home/<your username>/Downloads
> ls
> ^C
daz daz_2017 # cd /home/daz_2017 
daz daz_2017 # ls
Desktop/    Downloads/  Music/     Public/               snapshot1.png  sohpos.mp4  TARSOPHOS.zip  Videos/
Documents/  hw.info/    Pictures/  sav-linux-free-9.tgz  snapshot2.png  TARSOPHOS/  Templates/     VMware-Player-12.5.2-4638234.x86_64.bundle
daz daz_2017 # whoami
root
daz daz_2017 # mv sav-v-linux-free-9.tgz /tmp
mv: cannot stat ‘sav-v-linux-free-9.tgz’: No such file or directory
daz daz_2017 # mv sav-linux-free-9.tgz /tmp
daz daz_2017 # cd /tmp
daz tmp # ls
akonadi-daz_2017.IfGZf0/  mozilla_daz_20170/    systemd-private-07dc540e45904662b1e7f6737e3adccf-cups.service-h5oTaA/
kde-daz_2017/             sav-linux-free-9.tgz  systemd-private-07dc540e45904662b1e7f6737e3adccf-systemd-timesyncd.service-yPhggh/
daz tmp # tar xsvf sav-linux-free-9.tgz
sophos-av/
sophos-av/sav.tar
sophos-av/talpa.tar
sophos-av/uncdownload.tar
sophos-av/install.sh
daz tmp # 6.
bash: 6.: command not found
daz tmp # Run the install scr
bash: Run: command not found
daz tmp # ipt:
bash: ipt:: command not found
daz tmp # ./sophos-av/install.sh



Sophos Anti-Virus
=================
Copyright (c) 1989-2016 Sophos Limited. All rights reserved.

Welcome to the Sophos Anti-Virus installer. Sophos Anti-Virus contains an on-access scanner, an on-demand command-line scanner, the Sophos Anti-Virus
daemon, and the Sophos Anti-Virus GUI.

On-access scanner         Scans files as they are accessed, and grants access
                          to only those that are threat-free.
On-demand scanner         Scans the computer, or parts of the computer,
                          immediately.
Sophos Anti-Virus daemon  Background process that provides control, logging,
                          and email alerting for Sophos Anti-Virus.
Sophos Anti-Virus GUI     User interface accessed through a web browser.


Press <return> to display Licence. Then press <spc> to scroll forward.
*********************************
NOTICE
This Sophos software contains software licensed by Sophos as well as software licensed by other parties. Some software license terms may grant You
rights with respect to such software (including distribution rights) which are in addition to those rights granted to You by Sophos with respect to
this Sophos product in the Sophos End User License Agreement. Please review the Copyright section of product documentation for further details
regarding Your rights to any such software which has been provided to You and to view the respective copyright notices.
*********************************


Sophos End User License Agreement
If you use any of our software, read our legally binding agreement between Sophos and all end users of Sophos software products. If you wish to view
this information in other languages (German, Spanish, French, Italian, Japanese, Simplified Chinese or Traditional Chinese) then visit this page to
download a PDF: <https://www.sophos.com/en-us/legal/sophos-end-user-license-agreement.aspx>.

SOPHOS END USER LICENSE AGREEMENT

Please read the following legally binding License Agreement between Sophos and Licensee carefully. By selecting the accept option, breaking the seal
on the software package, or installing, copying or otherwise using the Products, Licensee acknowledges that Licensee has read, understands, and agrees
to be bound by the terms and conditions of this License Agreement, including without limitation the terms and conditions of documents and policies
which are incorporated herein by reference.

If Licensee does not agree with the terms and conditions of this License Agreement, Licensee is not authorized to install or otherwise use the
Products for any purpose whatsoever. If Licensee returns the unused Products and all accompanying items in their original condition and packaging
within twenty-one (21) calendar days of delivery by Sophos, together with proof of purchase, Licensee may receive a full refund.
Where a reseller, service provider, consultant, contractor or other party downloads, installs, manages or otherwise uses the Products on Licensee's
behalf, such party will be deemed to be Licensee's agent and (i) Licensee will be deemed to have accepted all of the terms and conditions of this
License Agreement, and (ii) to the extent permitted by applicable law, Licensee, not Sophos, shall be responsible for the acts or omissions of such
party in relation to its management or use of the Products on Licensee's behalf.

NOW IT IS AGREED as follows:

1. DEFINITIONS
1.1 'Affiliates' means, with respect to each party, entities that control, are controlled by, or are under common control with such party. For the
purposes of this definition, "control" means the beneficial ownership of more than fifty per cent (50%) of the voting power or equity in an entity.
1.2 'Computer' means any device or computing environment which benefits from the Licensed Product (for example but without limitation, workstations,

Do you accept the licence? Yes(Y)/No(N) [N]
> y

Where do you want to install Sophos Anti-Virus? [/opt/sophos-av]
> 

Do you want to enable on-access scanning? Yes(Y)/No(N) [Y]
> 

Sophos recommends that you configure Sophos Anti-Virus to auto-update.

It can update either from Sophos directly (requiring username/password details) or from your own server (directory or website (possibly requiring
username/password)).

Which type of auto-updating do you want? From Sophos(s)/From own server(o)/None(n) [s]
> n

Auto-updating is disabled. Your computer will not be fully protected. Enable updating as soon as possible (using /opt/sophos-av/bin/savsetup).

Installing Sophos Anti-Virus....
Selecting appropriate kernel support...

Installation completed.
On-access scanning not available. It was not possible to obtain or build suitable kernel support.
daz tmp # 

Kindest Regards Darren
Comment 1 Eugene Shatokhin 2017-03-05 18:36:45 MSK
Well, I cannot help much here. The development packages for our kernels are installed by default and available, many out-of-tree drivers build fine.

So the problem is likely on the Sophos's side somewhere. As that application does not specify what it needs from the kernel exactly, we can do nothing.
Comment 2 daz 2017-03-08 00:26:37 MSK
Hi Eugene,

Could you please review the following and provide some feedback. 

A converstaion between me and another Linux user. The original problem was an issue installing 
Sophos Antivirus. The cause ended up being related to Kernel headers for my current Kernel. 

The purpose of this post is to get your feedback once reading the below. If the below information is correct , could you please explain how I can upgrade my system in the way that is mentioned below including the install of Kernel 4.9 ( + Kernel Header ) . Ill call other Linux user Max. 

DAZ: My Kernel : Linux skye 4.8.17-nrj-desktop-1rosa-x86_64 #1 SMP PREEMPT Tue Jan 10 15:44:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

NOTE: When I run system update urpmi: I got message that when I reboot that Kernel 4.1 will be installed. 4.1 come with ISO then upgraded to 4.3. I rebooted and selected to boot back into 4.8
Why do I have 2 Kernels listed. ( NOTE: I have no Kernel Headers installed for 4.8 ( see below )

MAX: Meaning you have somehow installed the 4.3 kernel as a downgrade. Grub2 will boot in the latest you installed i.e. 4.3 but will give you an option to boot into 4.8 if you want to.
In the background it appears you are upgrading from 4.1 according to the package manager. Just untick those kernel upgrades.
Apparently you didn't install 4.8 through your package manager.

DAZ: I manually installed 4.8

MAX:That might be what's causing troubles with kernel headers i.e you still have the old ones marked as valid.

MAX:That will cause Sophos and/or Virtualbox or any other requiring own made kernel modules to fail as they will be pointing to the previous one.

DAZ: http://wiki.rosalab.ru/en/index.php/ROSA_Desktop_Fresh_R8_Release_Notes

DAZ: LTS kernel 4.1.25 is used by default. Kernel 4.4.x (x86_64, i586) and 4.6.x (x86_64, i586) are available in additional repositories.

MAX: On boot the current kernel is marked as valid. Tho you will be needing kernel-headers for the manually installed one and threpos wont help you there.

MAX: Or you add the repo where the 4.8 kernel came from but that could cause all kind of mayhem as it is prolly still in "cooker"

DAZ: Well the person who gave me instructions to do the new Kernel was the guy who made the Kernel for ROSA

DAZ: sudo urpmi.addmedia kernel_4.8 http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/
rosa2014.1/x86_64/kernel_4_8/release/

DAZ: THEN: RUN: sudo urpmi kernel-nrj-desktop-4.8-latest kernel-nrj-desktop-4.8-devel-latest cpupower

MAX: Ah yes but where is it going to get the headers and/or source from?v

MAX:There's even 4.9 on offer there.

MAX:What I don't understand is why you use 2014.1 release and not a 2016 one.

MAX: So you might as well install OpenMandriva too for the hardware backing.

MAX: Anywhow there is a newer version of Rosa available than the one you are using now

DAZ: NO WAY !

MAX: Oh but there is: http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/
There's a 2 year cycle there from what I see


MAX: There's a 2 year cycle there from what I see

DAZ: Me confused. They released version 8 . Version 7 can urpmi upgrade to 8. Why is urpmi update not upgrading to 2016 and I to my surpirse and stuck back in the past 2014

DAZ:When I run all updates now there is nothing to update. Moreover I just run and update and I was given the option of installing Kernel 4.1 despite me having 4.8 why cant it identify I have Kernel 4.8 and disable 4.1,4.3 come on

MAX:Prolly because 2016.1 is testing/cooker. The last entries there were today.

http://abf-downloads.rosalinux.ru/rosa2016.1/repository/x86_64/

MAX: Just go up (click the "../")to http://abf-downloads.rosalinux.ru/ and let your jaw drop at the options. 

MAX: It's not an ISO just the repositories.

MAX: Adding those in place of your existing ones will/should upgrade to testing when invoked.

there's "main", "contrib", "non-free" and "rstrcted" there.

DAZ: Adding those 10,000 would take me about as long as it would be when ROSA uses Kernel version 4 Billion

MAX:there prolly is no ISO for 9 yet.
No not really. Use urpmi.addmedia to replace the repositories you allready have like "main" and "contrib", etc.


MAX: I suspect there's a urpmi.delmedia or such too. 
It will take a long time to upgrade, depending on the connection speed you have and prolly break something in the process.
MAX: But hey: It was only for testing.


MAX: It might just work too.
Do you have something like "urpmi.showmedia -a" to show all the repositories you have enabled?


MAX:urpmi.showmedia -a

DAZ: command not found

MAX: try "man urpmi"

MAX: I was there when urpmi was developped on Mandriva but that was a long time ago.

MAX: There it is: Upgrade to the latest ROSA version using urpmi Urpmi can also be used to upgrade your box to a newer version of ROSA Linux: add the mirror's URL with the directory of the new versions packages to your urpmi configuration: ROSA Linux Control Center --> Software Management --> Select from where software packages are downloaded when updating the system

MAX: The URL's are in http://abf-downloads.rosalinux.ru/rosa2016.1/repository/x86_64/

MAX: Adding media for a distribution urpmi can add important media (e.g. main, updates, contrib ...) from a chosen mirror with a single command. As root type in a console: and so on and so on.
It's in the wiki, like you said.

Thanks Eugene. Can you break that down for me in a simple way.
Comment 3 Eugene Shatokhin 2017-03-08 22:33:38 MSK
(In reply to comment #2)
> Hi Eugene,
> 
> Could you please review the following and provide some feedback. 

There is usually a lot of confusion regarding the kernel headers and the files needed to build the kernel modules.

First of all: to build custom kernel modules (including VirtualBox modules mentioned in the discussion) in ROSA one DOES NOT need kernel-headers package. kernel-nrj-desktop-devel-* matching the kernel is what is needed and it is installed by default when you install or update the kernel.

See the output of 'rpm -qa | grep kernel.*devel' to check which such packages are installed.

For each kernel you have installed from our repositories, the appropriate -devel package should already be installed.

As for kernel-headers package, it is mostly needed to rebuild glibc and some other userspace components. It is NOT needed to build custom drivers or such.

Anyway, kernel-headers package is also installed by default and you can safely update it with "urpmi kernel-headers". Nothing should break as a result.
-------------------------

Now to the Sophos.

Please check if there is a way for it to be more verbose about what is missing and what it needs. Some command-line option of its install.sh or may be something else.

It would be helpful to know what exactly is checks and what exactly it expects to find. Its error message gives too little information right now.

Atm, I have no time to dig into this, so if you or someone else could help, the problem would be solved easier.