Bug 7723 - error while loading shared libraries while installing zoom.us video conferencing software
: error while loading shared libraries while installing zoom.us video conferenc...
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-16 17:47 MSK by daz
Modified: 2017-04-24 15:57 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
graphics card 1 gm108mgeforce840m.jpeg (101.62 KB, image/jpeg)
2017-02-17 17:43 MSK, daz
Details
graphics card 2 hdgraphics5500.jpeg (102.59 KB, image/jpeg)
2017-02-17 17:44 MSK, daz
Details
Konsole output:~/zoom $ /usr/bin/zoom (118.45 KB, image/jpeg)
2017-04-23 07:06 MSD, daz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daz 2017-02-16 17:47:43 MSK
Description of problem:

I am attempting to install the software ( Zoom ) https://zoom.us/download
Linux install guide: https://support.zoom.us/hc/en-us/articles/204206269-Linux-Installation ( I am using the .tar ) 

This is the process I took:

izzymate@izzymate ~ $ tar xf zoom_x86_64.tar.xz
izzymate@izzymate ~ $ ls
Desktop/    Downloads/  Pictures/  Templates/  zoom/
Documents/  Music/      Public/    Videos/     zoom_x86_64.tar.xz
izzymate@izzymate ~ $ ./zoom
bash: ./zoom: Is a directory
izzymate@izzymate ~ $ cd zoom
izzymate@izzymate ~/zoom $ ls
application-x-zoom.png       libQt5Script.so.5.6@
audio/                       libQt5Script.so.5.6.2*
config-dump.sh               libQt5WebChannel.so@
dingdong1.pcm*               libQt5WebChannel.so.5@
dingdong.pcm*                libQt5WebChannel.so.5.6@
doc/                         libQt5WebChannel.so.5.6.2*
Droplet.pcm                  libQt5WebEngineCore.so@
Droplet.wav*                 libQt5WebEngineCore.so.5@
egldeviceintegrations/       libQt5WebEngineCore.so.5.6@
generic/                     libQt5WebEngineCore.so.5.6.2*
getmem.sh                    libQt5WebEngine.so@
iconengines/                 libQt5WebEngine.so.5@
icudtl.dat                   libQt5WebEngine.so.5.6@
imageformats/                libQt5WebEngine.so.5.6.2*
leave.pcm*                   libQt5WebEngineWidgets.so@
libcrypto.so@                libQt5WebEngineWidgets.so.5@
libcrypto.so.1.0.0*          libQt5WebEngineWidgets.so.5.6@
libcrypto.so.1.0.1e@         libQt5WebEngineWidgets.so.5.6.2*
libfaac1.so*                 libQt5Widgets.so@
libicudata.so.56@            libQt5Widgets.so.5@
libicudata.so.56.1*          libQt5Widgets.so.5.6@
libicui18n.so.56@            libQt5Widgets.so.5.6.2*
libicui18n.so.56.1*          libQt5X11Extras.so@
libicuuc.so.56@              libQt5X11Extras.so.5@
libicuuc.so.56.1*            libQt5X11Extras.so.5.6@
libqgsttools_p.so@           libQt5X11Extras.so.5.6.2*
libqgsttools_p.so.1@         libQt5XcbQpa.so@
libqgsttools_p.so.1.0@       libQt5XcbQpa.so.5@
libqgsttools_p.so.1.0.0*     libQt5XcbQpa.so.5.6@
libQt5Core.so@               libQt5XcbQpa.so.5.6.2*
libQt5Core.so.5@             libssl.so@
libQt5Core.so.5.6@           libssl.so.1.0.0*
libQt5Core.so.5.6.2*         libssl.so.1.0.1e@
libQt5DBus.so@               libturbojpeg.so@
libQt5DBus.so.5@             libturbojpeg.so.0.0.0*
libQt5DBus.so.5.6@           platforminputcontexts/
libQt5DBus.so.5.6.2*         platforms/
libQt5Gui.so@                platformthemes/
libQt5Gui.so.5@              Qt/
libQt5Gui.so.5.6@            QtQml/
libQt5Gui.so.5.6.2*          QtQuick/
libQt5Network.so@            QtQuick.2/
libQt5Network.so.5@          QtWebChannel/
libQt5Network.so.5.6@        QtWebEngine/
libQt5Network.so.5.6.2*      qtwebengine_locales/
libQt5OpenGL.so@             QtWebEngineProcess*
libQt5OpenGL.so.5@           qtwebengine_resources_100p.pak
libQt5OpenGL.so.5.6@         qtwebengine_resources_200p.pak
libQt5OpenGL.so.5.6.2*       qtwebengine_resources.pak
libQt5Positioning.so@        ring.pcm*
libQt5Positioning.so.5@      ring.wav
libQt5Positioning.so.5.6@    sqldrivers/
libQt5Positioning.so.5.6.2*  translations/
libQt5Qml.so@                version.txt
libQt5Qml.so.5@              xcbglintegrations/
libQt5Qml.so.5.6@            zcacert.pem
libQt5Qml.so.5.6.2*          zoom*
libQt5Quick.so@              ZoomLauncher*
libQt5Quick.so.5@            Zoom.png
libQt5Quick.so.5.6@          zoom.sh*
libQt5Quick.so.5.6.2*        zopen*
libQt5Script.so@             ZXMPPROOT.cer
libQt5Script.so.5@
izzymate@izzymate ~/zoom $ ./zoom
./zoom: error while loading shared libraries: libxcb-xtest.so.0: cannot open shared object file: No such file or directory
izzymate@izzymate ~/zoom $ ./zoom.sh
=============================================================================================
This is debug mode of zoom client. Once crash, zoom will generate core dump under this mode.
=============================================================================================
Instead of writing the core dump to disk, your system is configured to send it to the "|/lib/systemd/systemd-coredump %p %u %g %s %t %e" instead.
Do you want to modify the default core dump file name?
 (yes) or (no):no
current user role:
izzymate
/home/izzymate/zoom/.
/home/izzymate/zoom/./zoom: error while loading shared libraries: libxcb-xtest.so.0: cannot open shared object file: No such file or directory
izzymate@izzymate ~/zoom $ 

NOTE: I thought it might be the wrong lib 32 vs 64 bit for libxcb-xtest.so.0
I have not found any answers in support groups or Zoom support center. 
If you can provide any assistance that would be most appreciated. 

Thanks
Comment 1 Eugene Shatokhin 2017-02-16 18:52:07 MSK
Is lib64xcb-xtest0 installed? If not, please install it.
Comment 2 daz 2017-02-16 19:27:01 MSK
UPDATE :

Output to long for here:

https://goo.gl/NFojGI

( PASTEBIN )
Comment 3 Eugene Shatokhin 2017-02-16 21:54:13 MSK
(In reply to comment #2)
> UPDATE :
> 
> Output to long for here:
> 
> https://goo.gl/NFojGI
> 
> ( PASTEBIN )

You have installed 32-bit packages while you probably need 64-bit ones. Try 'urpmi lib64qt5webenginewidgets5'

BTW, 'urpmf <file>' will tell which packages the <file> belongs to. This makes it easier to see what to install.
Comment 4 daz 2017-02-16 23:52:40 MSK
Well I did get some what further but think I messed up with the urpmf idea:

https://goo.gl/QXdDF2
Comment 5 Eugene Shatokhin 2017-02-17 11:03:40 MSK
(In reply to comment #4)
> Well I did get some what further but think I messed up with the urpmf idea:
> 
> https://goo.gl/QXdDF2

So, as you can see, urpmf tells that the 64-bit libQt5Positioning.so.5 is provided by lib64qt5positioning5:

izzy@izzy ~ $ urpmf libQt5Positioning.so.5
lib64qt5positioning5:/usr/lib64/libQt5Positioning.so.5

You need to install lib64qt5positioning5.

There is a convention in ROSA that the names of the packages with 64-bit libraries should start with "lib64", names of the ones with 32-bit libraries - with just "lib" and no "64". The packages do not always follow that but still it helps.
Comment 6 daz 2017-02-17 14:27:00 MSK
Eugine ,

Getting very close. For the first time the Zoom Software has started. 
However the video is not working on neither in inbuilt HD Webcam or my UVC USB Webcam. The Audio is being picked up and the speaker test works fine. My guess is I have two graphics cards in my laptop but thats about the extent of what I know. I have had situations with other distro's Ive need to change cards ( via Konsole ) to resolve issues. I would have no idea how to do this in ROSA. 

HARDWARE: PROBE: https://linux-hardware.org/index.php?probe=cdd5988f0d

OUTPUT: To start Zoom ( NOTE THE COMMAND GET TO Error: Send error, 22 Invalid argument ) This is usually not a Problem I have seen this happen is other disto's with no issues on stability. 

izzy@izzy ~/zoom $ ./zoom
[CZPClientLogMgr::LogClientEnvironment] [MacAddr: F0:76:1C:74:09:B5][client: Linux][OS: ROSA Desktop Fresh R8 EE 2014.1 Desktop][Hardware: CPU Core:4 Frenquency:2.40146 G Memory size:15967MB CPU Brand:Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz][Req ID: ]
Linux Client Version is 2.0.81497.0116
Graphics Card Info:: 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
Zoom package arch is 64bit, runing OS arch is x86_64
AppIconMgr::systemDesktopName log Desktop Name: default 
QSG_RENDER_LOOP is 
Error: Send error, 22 Invalid argument
Error: Send error, 22 Invalid argument
Error: Send error, 22 Invalid argument
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:28, ret:1
CSBConfUI::OnConfStatusChanged  cmd:29, ret:0
CSBConfUI::OnConfStatusChanged  cmd:30, ret:1
CSBConfUI::OnConfStatusChanged  cmd:31, ret:1
CSBConfUI::OnConfStatusChanged  cmd:79, ret:0
CSBConfUI::OnConfStatusChanged  cmd:88, ret:0
CSBConfUI::OnConfStatusChanged  cmd:9, ret:1
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:28, ret:1
CSBConfUI::OnConfStatusChanged  cmd:29, ret:0
CSBConfUI::OnConfStatusChanged  cmd:30, ret:1
CSBConfUI::OnConfStatusChanged  cmd:31, ret:1
CSBConfUI::OnConfStatusChanged  cmd:79, ret:0
CSBConfUI::OnConfStatusChanged  cmd:88, ret:0
CSBConfUI::OnConfStatusChanged  cmd:9, ret:1
CSBConfUI::OnConfStatusChanged  cmd:81, ret:0
CSBConfUI::OnConfStatusChanged  cmd:6, ret:0
CSBConfUI::OnConfStatusChanged  cmd:8, ret:0
CSBConfUI::OnConfStatusChanged  cmd:7, ret:0
CSBConfUI::OnConfStatusChanged  cmd:5, ret:0
CSBConfUI::OnConfStatusChanged  cmd:32, ret:0
CSBConfUI::OnConfStatusChanged  cmd:33, ret:0
CSBConfUI::OnConfStatusChanged  cmd:53, ret:0
CSBConfUI::OnConfStatusChanged  UI_CMD_SHARE_READYCSBConfUI::OnConfStatusChanged  cmd:17, ret:0
CSBConfUI::OnConfStatusChanged  cmd:104, ret:0
CSBConfUI::OnConfStatusChanged  cmd:18, ret:0
CSBConfUI::OnConfStatusChanged  cmd:18, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:67, ret:0
CSBConfUI::OnConfStatusChanged  cmd:0, ret:0
CSBConfUI::OnConfStatusChanged  cmd:1, ret:0
zmbCNativeTrace fail open file /home/izzy/logs/xcode_error_20170217_30302_22030.log, errno 2

Thanks !!!!!!!
Comment 7 Eugene Shatokhin 2017-02-17 14:47:35 MSK
(In reply to comment #6)
> Getting very close. For the first time the Zoom Software has started. 
> However the video is not working on neither in inbuilt HD Webcam or my UVC
> USB Webcam. The Audio is being picked up and the speaker test works fine. My
> guess is I have two graphics cards in my laptop but thats about the extent
> of what I know. 

It seems unlikely that this issue is because there are 2 graphics cards: the one from NVidia will not be used unless you ask it explicitly.

I have no time to dig into this atm. Perhaps, I could try zoom this weekend or later. IIRC, I made it work for one of our users some time ago but I do not remember the details now.
Comment 8 daz 2017-02-17 17:43:36 MSK
Created attachment 4584 [details]
graphics card 1 gm108mgeforce840m.jpeg

graphics card 1 gm108mgeforce840m.jpeg
Comment 9 daz 2017-02-17 17:44:54 MSK
Created attachment 4585 [details]
graphics card 2 hdgraphics5500.jpeg

graphics card 2 hdgraphics5500.jpeg
Comment 10 daz 2017-02-17 17:47:10 MSK
Eugine ,

I have attached specs of the 2 graphics I have on my system.
If that what the next step is to swap them over
Comment 11 Eugene Shatokhin 2017-02-19 23:16:42 MSK
(In reply to comment #10)
> Eugine ,
> 
> I have attached specs of the 2 graphics I have on my system.
> If that what the next step is to swap them over

As I said earlier, it is likely you do not have to. The problem is probably related to webcam detection rather than to the graphics cards.

I reproduced the problem with zoom from zoom_x86_64.tar.xz.

However, everything seems to be working OK with zoom installed from the RPM intended for Fedora. You can download it from the same place at zoom.us where you got the archive.

Save that file zoom_x86_64.rpm somewhere, open a console there and run the following as root to install the package:

  rpm -i --nodeps ./zoom_x86_64.rpm

After the installation, you can run /usr/bin/zoom and see if that works for you.
It worked OK on my machine.
Comment 12 daz 2017-04-23 07:04:36 MSD
Hey Eugene,

A follow up question on Zoom. Your previous comment/solution

( Eugene : I reproduced the problem with zoom from zoom_x86_64.tar.xz.

However, everything seems to be working OK with zoom installed from the RPM intended for Fedora. You can download it from the same place at zoom.us where you got the archive.

Save that file zoom_x86_64.rpm somewhere, open a console there and run the following as root to install the package:

  rpm -i --nodeps ./zoom_x86_64.rpm

After the installation, you can run /usr/bin/zoom and see if that works for you.
It worked OK on my machine. )

This ^ worked fine for me on previous Kernel. I have since had to re-image my laptop and re-installed Fresh8.1 now with Kernel:
4.9.20-nrj-desktop-1rosa-x86_64

This is what I get now when I follow the same steps.... ( See attached ) alzan@alzan ~/zoom $ /usr/bin/zoom
ZoomLauncher started.
cmd line: 
$HOME = /home/alzan 
/opt/zoom/zoom: error while loading shared libraries: libxcb-xtest.so.0: cannot open shared object file: No such file or directory
success to create child process,status is 32512.
zoom exited normally.
Something went wrong while running zoom,exit code is 127.
ZoomLauncher exit.
alzan@alzan ~/zoom $ urpmi libxcb-xtest.so.0
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/updates/libxcb-xtest0-1.11.1-2-rosa2014.1.i586.rpm
                                                                                                 

installing libxcb-xtest0-1.11.1-2-rosa2014.1.i586.rpm from /var/cache/urpmi/rpms
Preparing...                     ###############################################################
      1/1: libxcb-xtest0         ###############################################################
alzan@alzan ~/zoom $ /usr/bin/zoom
ZoomLauncher started.
cmd line: 
$HOME = /home/alzan 
/opt/zoom/zoom: error while loading shared libraries: libxcb-xtest.so.0: cannot open shared object file: No such file or directory                   
success to create child process,status is 32512.                                                                                                     
zoom exited normally.                                                                                                                                
Something went wrong while running zoom,exit code is 127.                                                                                            
ZoomLauncher exit.                                                                                                                                   
alzan@alzan ~/zoom $

** Is there any reason change of Kernel would effect this? Can u replicate ?
Thanks !!!!!!!!!
Comment 13 daz 2017-04-23 07:05:25 MSD
Attached from previous post by Daz :
Comment 14 daz 2017-04-23 07:06:49 MSD
Created attachment 4619 [details]
Konsole output:~/zoom $ /usr/bin/zoom

Konsole output: running: alzan@alzan ~/zoom $ /usr/bin/zoom
Comment 15 Eugene Shatokhin 2017-04-23 17:12:39 MSD
(In reply to comment #12)
> /opt/zoom/zoom: error while loading shared libraries: libxcb-xtest.so.0:
> cannot open shared object file: No such file or directory                   
> success to create child process,status is 32512.                            
You likely need the 64-bit library but you have installed the 32-bit one. Install the correct one as follows:

  urpmi lib64xcb-xtest0

If zoom complains about other libraries then, make sure you install 64-bit packages for these as well. You can find which packages provide a library using the following command:

  urpmf library_name | grep lib64

Example:

  urpmf libxcb-xtest.so.0 | grep lib64

> ** Is there any reason change of Kernel would effect this?
No, the kernel does not matter here. It is all about missing libraries.
Comment 16 daz 2017-04-24 13:46:38 MSD
(In reply to comment #15)
> (In reply to comment #12)
> > /opt/zoom/zoom: error while loading shared libraries: libxcb-xtest.so.0:
> > cannot open shared object file: No such file or directory                   
> > success to create child process,status is 32512.                            
> You likely need the 64-bit library but you have installed the 32-bit one.
> Install the correct one as follows:
> 
>   urpmi lib64xcb-xtest0
> 
> If zoom complains about other libraries then, make sure you install 64-bit
> packages for these as well. You can find which packages provide a library
> using the following command:
> 
>   urpmf library_name | grep lib64
> 
> Example:
> 
>   urpmf libxcb-xtest.so.0 | grep lib64
> 
> > ** Is there any reason change of Kernel would effect this?
> No, the kernel does not matter here. It is all about missing libraries.

This is the outcome:

Comment from ROSA:
 
> You likely need the 64-bit library but you have installed the 32-bit one.
> Install the correct one as follows:
>
> urpmi lib64xcb-xtest0
>
> If zoom complains about other libraries then, make sure you install 64-bit
> packages for these as well. You can find which packages provide a library
> using the following command:
>
> urpmf library_name | grep lib64
>
> Example:
>
> urpmf libxcb-xtest.so.0 | grep lib64
>
> > ** Is there any reason change of Kernel would effect this?
> No, the kernel does not matter here. It is all about missing libraries.

MY RESPONSE:

OK...
I ran :
azlan4 zoom # urpmf library_name | grep lib64

and got :

lib64xcb-xtest0:/usr/lib64/libxcb-xtest.so.0
lib64xcb-xtest0:/usr/lib64/libxcb-xtest.so.0.0.0

SO...
I run urpmi libxcb-xtest.so.0
& azlan4@azlan4 ~ $ urpmi libxcb-xtest.so.0
Package libxcb-xtest0-1.12-4-rosa2016.1.i586 is already installed

# THIS IS .i586?

NEXT
urpmi urpmi libxcb-xtest.so.0.0.0
no package as what was listed on the grep output
BUT there is lib64/libxcb-xtest.so.0 installed also .i586

SO I tried to lauch Zoom ./zoom
and got
azlan4 zoom # ./zoom
./zoom: error while loading shared libraries: libQt5WebEngineWidgets.so.5: cannot open shared object file: No such file or directory

so I ..

azlan4 zoom # urpmi libQt5WebEngineWidgets.so.5 and installed like 200 Mb of mixed 64bit and 32bit libs. I dont unserstand why this happens?

Anyway then..

azlan4 zoom # ./zoom
./zoom: error while loading shared libraries: libQt5WebEngineWidgets.so.5: cannot open shared object file: No such file or directory

Then..

azlan4 zoom # urpmi libQt5WebEngineWidgets.so.5
Package libqt5webenginewidgets5-5.8.0-2-rosa2016.1.i586 is already installed

Again ^ .i586

AT THIS POINT :

I can now run zoom as follows :

Non-root:

ls

cd zoom

./zoom.sh ( debug )

This is debug mode of zoom client. Once crash, zoom will generate core dump under this mode.
=============================================================================================
Instead of writing the core dump to disk, your system is configured to send it to the "|/lib/systemd/systemd-coredump %P %u %g %s %t %c %e" instead.
Do you want to modify the default core dump file name?
(yes) or (no):y
sudo...
[sudo] password for azlan4:
Do you want to specify a core dump file name or use the default one?
(1) Default core dump file name(/tmp/core_zoom_%p)
(2) Specify a file name(file name must start with an absolute path)
Your selection?1
current user role:
azlan4
/home/azlan4/zoom/.
zoom started.
[CZPClientLogMgr::LogClientEnvironment] [MacAddr: F0:76:1C:74:09:B5][client: Linux][OS: ROSA Desktop Fresh R9 EE 2016.1 Desktop][Hardware: CPU Core:4 Frenquency:2.41216 G Memory size:15968MB CPU Brand:Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz][Req ID: ]
Linux Client Version is 2.0.89826.0417
QSG_RENDER_LOOP is
Graphics Card Info:: 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
Zoom package arch is 64bit, runing OS arch is x86_64
AppIconMgr::systemDesktopName log Desktop Name: default
Error: Send error, 22 Invalid argument
Error: Send error, 22 Invalid argument
Error: Send error, 22 Invalid argument
CSBConfUI::OnConfStatusChanged UI_CMD_SHARE_READYzoom started.
Transcoding...


Conclusions at this point:

Zoom debug is running. Zoom and there seems to be no issues with the exception the record to cloud option is not working. This is messy and Ill close this ticket at this point.
Thanks for all the supported

Regards
Darren