Bug 772 - Eth0 lost connection after hibernation
: Eth0 lost connection after hibernation
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 10:31 MSD by FirstLevel
Modified: 2014-06-13 09:54 MSD (History)
2 users (show)

See Also:
RPM Package: networkmanager-0.9.2.0-4-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
net-01.png (188.08 KB, image/png)
2012-09-17 10:31 MSD, FirstLevel
Details
net-02.png (178.48 KB, image/png)
2012-09-17 10:31 MSD, FirstLevel
Details
net-03.png (200.03 KB, image/png)
2012-09-17 10:31 MSD, FirstLevel
Details
ifconfig-a.txt (1.14 KB, text/plain)
2012-09-17 10:31 MSD, FirstLevel
Details
ip-addr.txt (147 bytes, text/plain)
2012-09-17 10:32 MSD, FirstLevel
Details
lspcidrake.txt (3.00 KB, text/plain)
2012-09-17 10:32 MSD, FirstLevel
Details
messages.txt (20.48 KB, text/plain)
2012-09-17 10:33 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-09-17 10:31:16 MSD
Created attachment 544 [details]
net-01.png

Description of problem:
After reboot the network interface is not up. Writes that "the cable is disconnected."
Thus in parallel with Windows - network is.
When physically disconnect the network cable and connect it back - in / var / log / messages there are no messages.
If the applet's "Network Connections" to remove and put the checkbox "Network Management", the network appears.
I have attached diagnostic information.
net-01.png, net-02.png, net-03.png, ifconfig-a.txt, ip-addr.txt - state eth0 after boot
iconfig-new.txt - appeared incomprehensible eth1
messages.txt - / var / log / messages when removing and installing the jackdaws "Network Management"
Kernel - 3.0.38-nrj-desktop-1rosa.lts

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-09-17 10:31:29 MSD
Created attachment 545 [details]
net-02.png
Comment 2 FirstLevel 2012-09-17 10:31:39 MSD
Created attachment 546 [details]
net-03.png
Comment 3 FirstLevel 2012-09-17 10:31:54 MSD
Created attachment 547 [details]
ifconfig-a.txt
Comment 4 FirstLevel 2012-09-17 10:32:09 MSD
Created attachment 548 [details]
ip-addr.txt
Comment 5 FirstLevel 2012-09-17 10:32:59 MSD
Created attachment 549 [details]
lspcidrake.txt
Comment 6 FirstLevel 2012-09-17 10:33:10 MSD
Created attachment 550 [details]
messages.txt
Comment 7 FirstLevel 2012-09-25 15:08:45 MSD
Guaranteed shown at resuming from sleep and hibernation
Comment 8 FirstLevel 2012-11-18 10:10:14 MSK
Is there any progress?
Comment 9 alexander barakin 2012-12-18 19:57:44 MSK
8169? oh, ye...

try this:
# urpmi ethtool
# touch /sbin/ifup-pre-local
# chmod +x /sbin/ifup-pre-local
# echo '[ "$1" == "eth0" ] && /usr/sbin/ethtool -s $1 autoneg off' > /sbin/ifup-pre-local
# reboot && exit

the recipe is taken from here:
http://adam.rosi-kessel.org/weblog/2008/06/21/a-much-simpler-fix-for-the-r8169-link-down-problem
Comment 10 FirstLevel 2012-12-19 09:19:46 MSK
(In reply to comment #9)
> 8169? oh, ye...
> 
> try this:
> # urpmi ethtool
> # touch /sbin/ifup-pre-local
> # chmod +x /sbin/ifup-pre-local
> # echo '[ "$1" == "eth0" ] && /usr/sbin/ethtool -s $1 autoneg off' >
> /sbin/ifup-pre-local
> # reboot && exit
> 
> the recipe is taken from here:
> http://adam.rosi-kessel.org/weblog/2008/06/21/a-much-simpler-fix-for-the-
> r8169-link-down-problem

It does not work for me. 
Wireless connection is up after hibernation but eth0 (wired connection) is shown status "unplugged".
Comment 11 alexander barakin 2012-12-24 12:23:31 MSK
(In reply to comment #10)
> after hibernation

this is a completely different bug.

"after reboot" and "after hibernation" are two big differences, as they say in odessa.
Comment 12 FirstLevel 2012-12-24 12:41:05 MSK
(In reply to comment #11)
> (In reply to comment #10)
> > after hibernation
> 
> this is a completely different bug.
> 
> "after reboot" and "after hibernation" are two big differences, as they say
> in odessa.

After hibernation is see at my laptop too. "After reboot
Comment 13 FirstLevel 2012-12-24 12:41:39 MSK
(In reply to comment #11)
> (In reply to comment #10)
> > after hibernation
> 
> this is a completely different bug.
> 
> "after reboot" and "after hibernation" are two big differences, as they say
> in odessa.

I have changed subject to "Eth0 lost connection after hibernation"
Comment 14 Alexander Burmashev 2012-12-24 13:17:20 MSK
Try please
- Create file /etc/pm/config.d/unload
- Open it and write a string SUSPEND_MODULES="r8169"
- Save the file and try hibernate/
Comment 15 FirstLevel 2012-12-24 14:37:24 MSK
(In reply to comment #14)
> Try please
> - Create file /etc/pm/config.d/unload
> - Open it and write a string SUSPEND_MODULES="r8169"
> - Save the file and try hibernate/

I could not check Your solution because I have only 2012.1 on the laptop :(
Comment 16 FirstLevel 2014-06-13 09:54:12 MSD
Case is not actual with latest updates