Bug 7666 - [UPDATE REQUEST] Qt Creator 4.0.2 -> 4.2.2
: [UPDATE REQUEST] Qt Creator 4.0.2 -> 4.2.2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-27 18:14 MSK by Andrey Bondrov
Modified: 2017-05-10 13:38 MSD (History)
1 user (show)

See Also:
RPM Package: qt-creator
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
ss (13.26 KB, image/png)
2017-02-09 21:30 MSK, Vladimir Potapov
Details
ss3 (73.43 KB, image/png)
2017-05-02 19:51 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2017-01-27 18:14:34 MSK
We need to update Qt Creator to new version 4.2.1 with better support for Qt 5.8 (system Qt is still 5.6 but users may want to use local Qt builds).
Comment 1 Andrey Bondrov 2017-01-27 18:15:21 MSK
Advisory: "Update Qt Creator to new version 4.2.1"

https://abf.rosalinux.ru/build_lists/2798591
https://abf.rosalinux.ru/build_lists/2798592
Comment 2 Vladimir Potapov 2017-02-09 21:30:01 MSK
Created attachment 4583 [details]
ss
Comment 3 Vladimir Potapov 2017-04-25 18:57:14 MSD
please, up to 4.2.2
Comment 4 Andrey Bondrov 2017-04-27 11:24:22 MSD
(In reply to comment #3)
> please, up to 4.2.2

Advisory: "Update Qt Creator to new version 4.2.2"

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2870183
https://abf.rosalinux.ru/build_lists/2870184

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2870185
https://abf.rosalinux.ru/build_lists/2870185
Comment 5 Vladimir Potapov 2017-04-27 16:57:32 MSD
bug with "file.file" is present... :-(
I can't find the bug in google. Maybe build the project without patches?
Comment 6 Andrey Bondrov 2017-04-27 17:43:05 MSD
(In reply to comment #5)
> bug with "file.file" is present... :-(
> I can't find the bug in google. Maybe build the project without patches?

Does it happen in rosa2014.1, rosa2016.1 or both of them?
Comment 7 Vladimir Potapov 2017-04-27 18:45:58 MSD
(In reply to comment #6)
> (In reply to comment #5)
> > bug with "file.file" is present... :-(
> > I can't find the bug in google. Maybe build the project without patches?
> 
> Does it happen in rosa2014.1, rosa2016.1 or both of them?
I tested for 2014.1
Comment 8 Andrey Bondrov 2017-04-27 18:48:17 MSD
(In reply to comment #7)
> > Does it happen in rosa2014.1, rosa2016.1 or both of them?
> I tested for 2014.1

Please test rosa2016.1 build too.
Comment 10 Vladimir Potapov 2017-04-28 20:40:20 MSD
The update is sent to expanded testing
****************************************
Comment 11 Vladimir Potapov 2017-05-02 18:50:17 MSD
Please, add libqt5declarative5
Comment 12 Vladimir Potapov 2017-05-02 19:05:41 MSD
new project - qtquick, compile error
"Project ERROR: Unknown module(s) in QT: qml quick"
Comment 13 Vladimir Potapov 2017-05-02 19:51:16 MSD
Created attachment 4632 [details]
ss3
Comment 14 Andrey Bondrov 2017-05-03 08:58:39 MSD
Advisory: "Update Qt Creator to new version 4.2.2. Fix headers path detection when running gcc. Suggest more packages to fix qml and quick modules detection."

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2870480
https://abf.rosalinux.ru/build_lists/2870481

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2870482
https://abf.rosalinux.ru/build_lists/2870483
Comment 15 Vladimir Potapov 2017-05-03 14:06:23 MSD
Please, add requirements:
lib64qt5-qtquickcontrols2-qml
lib64qt5-qtcanvas3d-qml
Comment 16 Andrey Bondrov 2017-05-03 16:45:03 MSD
(In reply to comment #15)
> Please, add requirements:
> lib64qt5-qtquickcontrols2-qml
> lib64qt5-qtcanvas3d-qml

Done.

Advisory: "Update Qt Creator to new version 4.2.2. Fix headers path detection when running gcc. Suggest more packages to fix qml and quick modules detection."

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2870526
https://abf.rosalinux.ru/build_lists/2870527

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2870528
https://abf.rosalinux.ru/build_lists/2870529
Comment 17 Andrey Bondrov 2017-05-04 05:03:09 MSD
Advisory: "Update Qt Creator to new version 4.2.2. Fix headers path detection when running gcc. Suggest more packages to fix qml and quick modules detection. Don't set LD_LIBRARY_PATH to /usr/lib[64] because it doesn't allow Qt Creator to use OpenGL with nVidia proprietary drivers."

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2870575
https://abf.rosalinux.ru/build_lists/2870576

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2870577
https://abf.rosalinux.ru/build_lists/2870578
Comment 18 Vladimir Potapov 2017-05-04 08:05:36 MSD
(In reply to comment #17)
> Advisory: "Update Qt Creator to new version 4.2.2. Fix headers path
> detection when running gcc. Suggest more packages to fix qml and quick
> modules detection. Don't set LD_LIBRARY_PATH to /usr/lib[64] because it
> doesn't allow Qt Creator to use OpenGL with nVidia proprietary drivers."
> 
> rosa2016.1:
> https://abf.rosalinux.ru/build_lists/2870575
> https://abf.rosalinux.ru/build_lists/2870576
> 
> rosa2014.1:
> https://abf.rosalinux.ru/build_lists/2870577
> https://abf.rosalinux.ru/build_lists/2870578

The bug with nvidia not fixed :-(
Comment 19 Andrey Bondrov 2017-05-05 10:02:47 MSD
Fixed rosa2014.1 packages.

Advisory: "Update Qt Creator to new version 4.2.2. Fix headers path detection when running gcc. Suggest more packages to fix qml and quick modules detection. Don't set LD_LIBRARY_PATH to /usr/lib[64] because it doesn't allow Qt Creator to use OpenGL with nVidia proprietary drivers."

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2870575
https://abf.rosalinux.ru/build_lists/2870576

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2870630
https://abf.rosalinux.ru/build_lists/2870631
Comment 20 Vladimir Potapov 2017-05-05 13:29:50 MSD
The update is sent to expanded testing
***************************************
Comment 21 Vladimir Potapov 2017-05-10 12:52:59 MSD
qt-creator-4.2.2-5

rosa2016.1:
https://abf.rosalinux.ru/build_lists/2870575
https://abf.rosalinux.ru/build_lists/2870576

rosa2014.1:
https://abf.rosalinux.ru/build_lists/2870630
https://abf.rosalinux.ru/build_lists/2870631
************************* Advisory ******************************
Update Qt Creator to new version 4.2.2. Fix headers path detection when running gcc. Suggest more packages to fix qml and quick modules detection. Don't set LD_LIBRARY_PATH to /usr/lib[64] because it doesn't allow Qt Creator to use OpenGL with nVidia proprietary drivers.
******************************************************************
QA Verified