Bug 7637 - Why is ROSA forcing 32bit libs on my 64bit OS.. A TOTAL MESS
: Why is ROSA forcing 32bit libs on my 64bit OS.. A TOTAL MESS
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Localization
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: JDronova
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-07 01:46 MSK by daz
Modified: 2017-01-28 17:13 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Software" WINE " shows mixed libs 32 & 64 bit (138.70 KB, image/png)
2017-01-07 01:46 MSK, daz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daz 2017-01-07 01:46:43 MSK
Created attachment 4579 [details]
Software" WINE " shows mixed libs 32 & 64 bit

Description of problem:
Why is it that when I go to install a program the download files are a mix 32bit and 64bit install files. Why is it when I run I need to install urpmi  libxcb-xtest.so.0 when I am on a 64_bit OS  ROSA is forcibly install the 32-bit libs. Why is is that when I go to install many things its a mix of 32bit and 64bit libs. Yes I use a development version the free OS which gives ROSA valuable feedback for your more stable enterprise release. Yet for people like myself that do lots of testing report bugs you wont even sell the enterprise version to those in Australia. Please explain  .. I have marked as critical and it can stay that way as without the correct files I cant install https://zoom.us/download which I require urgently for an important meeting. I guess this is why people should not use development 

OS:
ROSA:8 
Attached is a screen shot example of Wine I was going to install... Why ??? 64bit and rest 32bit when Im running 64bit 


Thanks !
Comment 1 daz 2017-01-07 01:54:48 MSK
Why ????????????? When my System is 64 bit the OS 64 everything about my computer is 64 but yet I get this 

azlan melange # urpmi libX11.so.6
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "Main32 Updates")
 libx11_6                       1.6.3        3             rosa  2014.1 i586 
 libxau6                        1.0.8        5             rosa  2014.1 i586 
 libxcb1                        1.11.1       2             rosa  2014.1 i586 
 libxdmcp6                      1.1.2        1             rosa  2014.1 i586 
1.4MB of additional disk space will be used.
622KB of packages will be retrieved.
Proceed with the installation of the 4 packages? (Y/n) y
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/updates/libxcb1-1.11.1-2-rosa2014.1.i586.rpm
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/updates/libx11_6-1.6.3-3-rosa2014.1.i586.rpm                                 
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/updates/libxau6-1.0.8-5-rosa2014.1.i586.rpm                                  
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/media/main/updates/libxdmcp6-1.1.2-1-rosa2014.1.i586.rpm                                
                                                                                                                                                     

installing libx11_6-1.6.3-3-rosa2014.1.i586.rpm libxdmcp6-1.1.2-1-rosa2014.1.i586.rpm libxau6-1.0.8-5-rosa2014.1.i586.rpm libxcb1-1.11.1-2-rosa2014.1.i586.rpm from /var/cache/urpmi/rpms
Preparing...                     ###################################################################################################################
      1/4: libxau6               ###################################################################################################################
      2/4: libxdmcp6             ###################################################################################################################
      3/4: libxcb1               ###################################################################################################################
      4/4: libx11_6              ###################################################################################################################
azlan melange #
Comment 2 Denis Silakov 2017-01-28 17:13:26 MSK
Answer for the first question is that 64bit wine is only able to launch 64bit Win programs. If you want to launch 32bit Win apps (and this is the case for most users) then you should use 32bit wine. That's why we use a different name for 64bit wine - "wine64" - and install 32bit wine by default.

Note also that there are also several other proprietary packages (like skype) that exist only in 32bit form and to use them in 64bit system we have to install 32bit libraries.

As for "urpmi libX11.so.6", "libX11.so.6" is an internal provide used to install 32bit libx11 package. If you want to have 64bit one, you should use "urpmi 'libX11.so.6()(64bit)'".

So all this is done by design, there is nothing wrong here. But if you really don't want to have 32bit then you can simply disable 32bit repositories (look for repos that contain "32" in their names, like "Main32" and "Main32 Updates"; they are enabled by default in 64bit systems).