Bug 7460 - [UPDATE REQUEST] rosa-crypto-tool
: [UPDATE REQUEST] rosa-crypto-tool
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-27 12:18 MSD by m.voznesensky
Modified: 2017-11-23 16:08 MSK (History)
3 users (show)

See Also:
RPM Package: rosa-crypto-tool-0.1.4-2.src.rpm
ISO-related:
Bad POT generating:
Upstream:
m.voznesensky: qa_verified?
andrey.bondrov: published+


Attachments
ss1 (5.40 KB, image/png)
2016-12-09 12:07 MSK, Vladimir Potapov
Details
ss2 (48.39 KB, image/png)
2016-12-09 12:13 MSK, Vladimir Potapov
Details
ss3 (46.39 KB, image/png)
2016-12-09 12:18 MSK, Vladimir Potapov
Details
diags1 (3.51 KB, text/plain)
2016-12-16 12:27 MSK, Vladimir Potapov
Details
diags2 (313 bytes, text/plain)
2016-12-16 12:30 MSK, Vladimir Potapov
Details
ss4 (107.92 KB, image/png)
2016-12-16 19:05 MSK, Vladimir Potapov
Details
ss5 (30.26 KB, image/png)
2016-12-20 13:15 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.voznesensky 2016-10-27 12:18:33 MSD
Advisory:

ROSA Crypto Tool - Program to work with electronic digital signatures

x64: https://abf.io/build_lists/2744981
x86: https://abf.io/build_lists/2744980
Comment 1 Andrey Bondrov 2016-10-28 19:55:03 MSD
Advisory: "Update rosa-crypto-tool to new version 0.1.5"

https://abf.rosalinux.ru/build_lists/2745305
https://abf.rosalinux.ru/build_lists/2745306
Comment 2 Andrey Bondrov 2016-10-28 19:55:15 MSD
*** Bug 7465 has been marked as a duplicate of this bug. ***
Comment 3 Vladimir Potapov 2016-10-29 14:28:58 MSD
The update is sent to expanded testing
**************************************
Comment 4 Vladimir Potapov 2016-10-31 18:55:35 MSK
rosa-crypto-tool-0.1.5-1
https://abf.rosalinux.ru/build_lists/2745305
https://abf.rosalinux.ru/build_lists/2745306
************************* Advisory ******************************
Update rosa-crypto-tool to new version 0.1.5
*****************************************************************
QA Verified
Comment 5 m.voznesensky 2016-11-21 11:25:58 MSK
Advisory: "Update rosa-crypto-tool to new version 0.1.6"

2014.1:
x86_64: https://abf.io/build_lists/2756902
i586: https://abf.io/build_lists/2756901

2016.1:
x86_64: https://abf.io/build_lists/2756900
i586: https://abf.io/build_lists/2756899
Comment 6 m.voznesensky 2016-12-01 15:00:42 MSK
Advisory: "Update rosa-crypto-tool to new version 0.2.0"

2014.1:
x86_64: https://abf.io/build_lists/2762222
i586: https://abf.io/build_lists/2762221

2016.1:
x86_64: https://abf.io/build_lists/2762224
i586: https://abf.io/build_lists/2762223
Comment 7 Vladimir Potapov 2016-12-09 12:07:02 MSK
Created attachment 4563 [details]
ss1
Comment 8 Vladimir Potapov 2016-12-09 12:08:47 MSK
Если файл не выбран, а кликаешь на "Подписать", программа говорит "Пожалуйста, выберите файл для подписи". В современном интерфейсе это делается дизаблированием кнопки если строка выбора файла не заполнена.
Comment 9 Vladimir Potapov 2016-12-09 12:13:54 MSK
Created attachment 4564 [details]
ss2

Неизвестная ошибка, говорит.
Comment 10 Vladimir Potapov 2016-12-09 12:18:49 MSK
Created attachment 4565 [details]
ss3
Comment 11 m.voznesensky 2016-12-12 12:46:12 MSK
Advisory: "Update rosa-crypto-tool to new version 0.2.1"

2014.1:
x86_64: https://abf.io/build_lists/2790302
i586: https://abf.io/build_lists/2790301

2016.1:
x86_64: https://abf.io/build_lists/2790300
i586: https://abf.io/build_lists/2790299
Comment 12 Vladimir Potapov 2016-12-16 12:27:28 MSK
Created attachment 4566 [details]
diags1

не работает
Comment 13 Vladimir Potapov 2016-12-16 12:30:46 MSK
Created attachment 4567 [details]
diags2
Comment 14 modd1e 2016-12-16 16:34:06 MSK
Покажите вывод при такой команде (набранной в директории файла):
/opt/cprocsp/bin/amd64/cryptcp -sign -dn 'Михайлов О. А.' Testovyy_dokument.odt Testovyy_dokument.odt.sgn

Если код ошибки нулевой, попробуйте также /opt/cprocsp/bin/amd64/cryptcp -verify -dn 'Михайлов О. А.' Testovyy_dokument.odt.sgn
Comment 15 Vladimir Potapov 2016-12-16 19:03:58 MSK
/opt/cprocsp/bin/amd64/cryptcp -sign -dn 'Михайлов О. А.' Testovyy_dokument.odt Testovyy_dokument.odt.sgn
CryptCP 4.0 (c) "Crypto-Pro", 2002-2015.
Command prompt Utility for file signature and encryption.

The following certificate will be used:
RDN:RU, "г. Москва, г. Зеленоград", "НТЦ ИТ ""РОСА""", Михайлов О. А., o.mihailov@rosalinux.ru
Valid from 07.11.2016 07:07:11 to 07.02.2017 07:17:11

Certificate chains are checked.
Folder './':
Testovyy_dokument.odt... Signing the data...    
    
Signed message is created.
[ReturnCode: 0]
Comment 16 Vladimir Potapov 2016-12-16 19:05:39 MSK
Created attachment 4568 [details]
ss4
Comment 17 modd1e 2016-12-16 19:15:25 MSK
Подпись как таковая видимо работает. Значит, скорее всего, дело не в токене и не в пакетах КриптоПро. Скорее всего не хватает каких то пакетов связанных с rosa-crypto-tool. Надо запустить программу из консоли и посмотреть, что она напишет (можно скинуть полный вывод программы в текстовом варианте). Тут не могу обещать, что сразу пойму в чём дело, это скорее вопрос к Михаилу.
Comment 18 m.voznesensky 2016-12-19 19:08:09 MSK
Advisory: "Update rosa-crypto-tool to new version 0.2.1"

2014.1:
x86_64: https://abf.io/build_lists/2790677
i586: https://abf.io/build_lists/2790676

2016.1:
x86_64: https://abf.io/build_lists/2790675
i586: https://abf.io/build_lists/2790674

Fix translated bug
User friendly forms
Dynamic status bar for token
Comment 19 Vladimir Potapov 2016-12-20 13:15:36 MSK
Created attachment 4569 [details]
ss5

Небольшое замечание. При работе без токена если отсутствует сертификат то жмешь на кнопку зашифровать и ничего не происходит. Непонятно, что делать. Или уж задизаблить кнопку если нет сертификата, или добавить при нажатии сообщение о том, где этот сертификат взять.
Comment 20 m.voznesensky 2016-12-21 17:32:08 MSK
Advisory: "Update rosa-crypto-tool to new version 0.2.2"

2014.1:
x86_64: https://abf.io/build_lists/2790874
i586: https://abf.io/build_lists/2790873

2016.1:
x86_64: https://abf.io/build_lists/2790872
i586: https://abf.io/build_lists/2790871

Add message if certificate not install
Comment 21 Vladimir Potapov 2016-12-21 19:16:29 MSK
The update is sent to expanded testing
*****************************************
Comment 22 Vladimir Potapov 2016-12-21 19:20:10 MSK
Замечания для будущей версии
1) Нужно удаление установленного сертификата
2) Т.к. на сайте уже новая версия, возможно в ней исправлена работа с русскими именами и можно обойтись без транслита
3) Очень хочется, кроме интерфейса, добавление действий в контекстное меню KDE.

Типа - правой кнопкой на файле  - в контекстном меню строка подменю КриптоПро а в нем все четыре действия - Подписать, Проверить подпись, Зашифровать, Расшифровать.
Ну и для остальных сред типа GNOME или MATE такое сделать, это несложно - разве что потребует добавить в программу работу с параметрами, чтоб можно было из командной строки вызывать.
Comment 23 Vladimir Potapov 2016-12-21 19:21:47 MSK
если совсем правильно, то все это требует разделения на две проги - для работы в командной строке с четырьмя командами и несколькими ключами и GUI для этого.
Comment 24 Vladimir Potapov 2017-01-02 13:10:40 MSK
rosa-crypto-tool-0.2.2-1
https://abf.io/build_lists/2790873
https://abf.io/build_lists/2790874
************************* Advisory *****************************
Update rosa-crypto-tool to new version 0.2.2
****************************************************************
QA Verified
Comment 25 m.voznesensky 2017-11-23 16:08:21 MSK
Advisory:

Update rosa-crypto-tool to new version 0.3.0

Add ability create signature and decryption without tokens (if container local install)
Program work witch CryptoPro since 3.6
Fixed UI:
    - Buttons on toolbar dynamic strech on others DE, styles (now word is not cut)
    - Form is not strech then clicked on button details on other DE, styles

2014.1:
x86_64: https://abf.io/build_lists/2913619
i586: https://abf.io/build_lists/2913618

2016.1:
x86_64: https://abf.io/build_lists/2913617
i586: https://abf.io/build_lists/2913616