Bug 7418 - Development package of spice-gtk missing some dependencies
: Development package of spice-gtk missing some dependencies
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-06 18:43 MSD by Andrey Bondrov
Modified: 2016-10-27 12:45 MSD (History)
3 users (show)

See Also:
RPM Package: spice-gtk
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2016-10-06 18:43:38 MSD
Development package of spice-gtk missing some dependencies. It should require lib[64]spice-client-gtk2.0_4.
Comment 1 Andrey Bondrov 2016-10-06 18:44:19 MSD
Advisory: "Fix dependencies of spice-gtk development package"

https://abf.rosalinux.ru/build_lists/2724106
https://abf.rosalinux.ru/build_lists/2724107
Comment 2 Vladimir Potapov 2016-10-06 20:44:22 MSD
1) Clipboard not work. In logs

Warning: generating old-style constructor for:spice_display_new
Could not write method SpiceMainChannel.clipboard_grab: No ArgType for int*

2) Maybe lz compression not activated. From fedora
BuildRequires:  zlib-devel
BuildRequires:  pkgconfig(liblz4)

--enable-lz4 in flags
Comment 3 Vladimir Potapov 2016-10-07 10:07:39 MSD
1) - solved
but
3) add webdav support needed
requirement libphodav and key
--enable-webdav
Comment 4 Andrey Bondrov 2016-10-11 18:35:34 MSD
Advisory: "Fix dependencies of spice-gtk development package. Enable lz4 and webdav support"

https://abf.rosalinux.ru/build_lists/2724806
https://abf.rosalinux.ru/build_lists/2724807
Comment 5 Vladimir Potapov 2016-10-20 17:54:49 MSD
The update is sent to expanded testing
****************************************
Comment 6 Vladimir Potapov 2016-10-24 14:01:50 MSD
spice-gtk-0.31-3
https://abf.rosalinux.ru/build_lists/2724806
https://abf.rosalinux.ru/build_lists/2724807
**************************** Advisory *******************************
Fix dependencies of spice-gtk development package. Enable lz4 and webdav support
*********************************************************************
QA Verified
Comment 7 Vladimir Potapov 2016-10-25 12:53:24 MSD
test
Comment 8 consta 2016-10-25 13:14:36 MSD
test mail 2
Comment 9 consta 2016-10-25 15:19:19 MSD
test mail 3
Comment 10 consta 2016-10-27 12:45:59 MSD
test mail 4