Bug 7411 - OpenOffice 4.1.2 crash on startup on all R8.Fresh flavors except R8.MATE
: OpenOffice 4.1.2 crash on startup on all R8.Fresh flavors except R8.MATE
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: -Enter Bugs Here-
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Desktop Triage Team
: Desktop Triage Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-05 02:13 MSD by grem
Modified: 2016-10-07 01:26 MSD (History)
1 user (show)

See Also:
RPM Package: http://downloads.sourceforge.net/project/openofficeorg.mirror/4.1.2/binaries/en-US/Apache_OpenOffice_4.1.2_Linux_x86-64_install-rpm_en-US.tar.gz
ISO-related:
Bad POT generating:
Upstream:


Attachments
gdb ./soffice.bin (23.99 KB, text/plain)
2016-10-05 02:13 MSD, grem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grem 2016-10-05 02:13:48 MSD
Created attachment 4546 [details]
gdb ./soffice.bin

Description of problem:

I tried to launch Apache OpenOffice 4.1.2 (AOO, installed or from local directory) that I downloaded from official site and application crash on startup.
I use R7.Fresh.KDE updated to actual state. Also I tried to lauch AOO on some others flavors in Live mode on VirtualBox: R8.Fresh.[KDE | GNOME | PLASMA] and result was the same except R8.Fresh.MATE and also R6.Fresh.LXQT where startup of application was successful and work.

This applicaiton from the same RPM package succesfully launched on CensOS (installed in VirtualBox); Mageia 5, OpenMandriva Lx 3 (both in Live mode in VirtualBox) so package is not corrupted.


Steps to Reproduce:
The simplest way to reproduce without installation (Live mode is also acceptable to check)

$ mkdir ./temp
$ cd ./temp
$ wget http://downloads.sourceforge.net/project/openofficeorg.mirror/4.1.2/binaries/en-US/Apache_OpenOffice_4.1.2_Linux_x86-64_install-rpm_en-US.tar.gz
$ tar -xvf Apache_OpenOffice_4.1.2_Linux_x86-64_install-rpm_en-US.tar.gz
$ cd ./en-US/RPMS
$ for i in ./*.rpm; do rpm2cpio $i | cpio -idvm; done
$ cd ./opt/openoffice4/program
$ ./soffice[/code]


Actual Result:

$ ./soffice
javaldx: Could not find a Java Runtime Environment!
terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'
Application Error

Fatal exception: Signal 6
./soffice: line 121:  4841 Aborted                 (core dumped) "$sd_prog/$sd_binary" "$@"


Expected Result:

Application (OpenOffice) starts successfully (maybe just with or without notification "javaldx: Could not find a Java Runtime Environment!" depends on jre or jdk installation presence in system).

Please NOTE that application starts successfully on R8.Fresh.MATE, R6.Fresh.LXQT and crash on other R8.Fresh flavors (KDE, GNOME, PLASMA).

Also I attached "gdb ./soffice.bin" output for "run" and "where" (see attachment).
Comment 1 grem 2016-10-05 02:17:47 MSD
Sorry, the last line in "Steps to Reproduce" must be

$ ./soffice

or 

$ ./soffice.bin
Comment 2 grem 2016-10-05 16:28:53 MSD
I created new "strace ./soffice.bin" output files for R8.FRESH.MATE and .KDE while trying start OpenOffice and carefully compared them with deleting the similar blocks of text. Approximatly at line 1042 of ~7000 lines in ".KDE" strace-output I found that "libgdk_pixbuf_xlib-2.0.so.0" couldn't be loaded (it doesn't exist in the KDE system by default).

After installing "lib64gdk_pixbuf_xlib2.0_0" library that is installed already in R8.FRESH.MATE the OpenOffice starts successfuly in R8.FRESH.KDE.
Comment 3 grem 2016-10-07 01:26:21 MSD
Related issues in the OpenOffice bugtracker:

https://bz.apache.org/ooo/show_bug.cgi?id=127153
https://bz.apache.org/ooo/show_bug.cgi?id=124948#c4

As reported in second issue, the "not found" library could be found also by executing:

$ ldd -v /opt/openoffice4/program/libvclplug_gtk.so