Bug 7399 - [UPDATE REQUEST] hw-probe 1.1: new web UI and secure HTTPS connection
: [UPDATE REQUEST] hw-probe 1.1: new web UI and secure HTTPS connection
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-28 19:31 MSD by Andrey Ponomarenko
Modified: 2016-10-25 13:46 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
Works well on ROSA R8 KDE4 [EN] (185.44 KB, image/png)
2016-09-28 19:31 MSD, Andrey Ponomarenko
Details
Works well on ROSA R8 KDE4 [RU] (283.07 KB, image/png)
2016-09-28 19:32 MSD, Andrey Ponomarenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2016-09-28 19:31:28 MSD
Created attachment 4542 [details]
Works well on ROSA R8 KDE4 [EN]

Advisory: HW Probe Tool (hw-probe) was updated to 1.1 version.

Changes since 0.9.3:

1. New fast and scalable web UI at https://linux-hardware.org
2. Uses secure HTTPS to upload probes
3. Returns URL for private access to probe data
4. Uses XZ compression
5. Larger storage for 110.000 probes
6. Detects release of a distribution
7. Detects real Mac-address
8. Carefully detects devices on board
9. Saves created probes in the $HOME/HW_PROBE directory

Private access URL is used to access all probe data (ID of the probe, node name, ...), some logs (top, ps, ...) and editing statuses of devices (will be implemented in the near future).

This update requires long testing.

Build lists:
https://abf.io/build_lists/2722637 (x86_64)
https://abf.io/build_lists/2722636 (i586)

Advisory: HW Probe GUI (hw-probe-gui) was updated to 1.1 version.

Changes since 1.0-5:

1. Uses HW Probe 1.1
2. Prints URL for private access to probe data

Build lists:
https://abf.io/build_lists/2722633 (x86_64)
https://abf.io/build_lists/2722632 (i586)
Comment 1 Andrey Ponomarenko 2016-09-28 19:32:18 MSD
Created attachment 4543 [details]
Works well on ROSA R8 KDE4 [RU]
Comment 2 Vladimir Potapov 2016-09-29 17:21:45 MSD
The update is sent to expanded testing
**************************************
Comment 3 Vladimir Potapov 2016-10-03 19:21:16 MSD
*** Bug 7102 has been marked as a duplicate of this bug. ***
Comment 4 Vladimir Potapov 2016-10-25 11:44:23 MSD
hw-probe-1.1-1
https://abf.io/build_lists/2722637
https://abf.io/build_lists/2722636

hw-probe-gui-1.1-1
https://abf.io/build_lists/2722633
https://abf.io/build_lists/2722632

********************************** Advisory ***************************
HW Probe Tool (hw-probe) was updated to 1.1 version.

Changes since 0.9.3:

1. New fast and scalable web UI at https://linux-hardware.org
2. Uses secure HTTPS to upload probes
3. Returns URL for private access to probe data
4. Uses XZ compression
5. Larger storage for 110.000 probes
6. Detects release of a distribution
7. Detects real Mac-address
8. Carefully detects devices on board
9. Saves created probes in the $HOME/HW_PROBE directory

1. Uses HW Probe 1.1
2. Prints URL for private access to probe data
*************************************************************************
QA Verified