Bug 739 - [UPDATE REQUEST] ROMP
: [UPDATE REQUEST] ROMP
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 18:03 MSD by Julia Mineeva
Modified: 2014-04-26 12:08 MSD (History)
5 users (show)

See Also:
RPM Package: rosa-media-player
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
mp3id2 (180.53 KB, audio/mpeg)
2012-09-10 18:40 MSD, Vladimir Potapov
Details
bad russian tags (298.48 KB, image/png)
2012-09-11 15:18 MSD, Vladimir Potapov
Details
midi files don't linked to ROMP (243.24 KB, image/png)
2012-09-11 15:23 MSD, Vladimir Potapov
Details
ID3v2.4 UTF-8 russian (180.53 KB, audio/mpeg)
2012-09-11 15:38 MSD, Vladimir Potapov
Details
Settings for EasyTag (213.40 KB, image/png)
2012-09-11 15:45 MSD, Denis Koryavov
Details
ROMP_playing_tagged_file (107.67 KB, image/png)
2012-09-11 15:46 MSD, Denis Koryavov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julia Mineeva 2012-09-04 18:03:08 MSD
New version of ROMP
Comment 1 Julia Mineeva 2012-09-04 18:03:53 MSD
Advisory:
new version of ROSA Media Player:
- support midi files, 
- support ID3V2 tag, 
- new icons of control panel,
- updated translations (french, sloveninan, russian), 
- redesign settings window

Buildlists:
https://abf.rosalinux.ru/build_lists/701751
https://abf.rosalinux.ru/build_lists/701750
Comment 2 Julia Mineeva 2012-09-04 18:06:29 MSD
*** Bug 738 has been marked as a duplicate of this bug. ***
Comment 3 Vladimir Potapov 2012-09-05 14:35:09 MSD
DVD support bugs are not fixed (#387 #389 #742)
Localization bug is not fixed  (#191)
AudioCD bug is not fixed (#390)
:-(
Comment 4 Julia Mineeva 2012-09-05 14:47:24 MSD
This bugs will be fixed in next releases.
Comment 5 Pavel Shved 2012-09-05 14:52:41 MSD
Julia, by clearing "Request for Update" checkbox you have cancelled the update request, so the Update Verification Team won't see your update in their searches.  It is best to request the update again--if you still want this exact version to be uploaded  to repositories, of course.
Comment 6 Denis Koryavov 2012-09-05 15:04:28 MSD
Yes, we know about these bugs and will try to fix them in the next versions of ROMP. Current version of ROMP will not be changed.
Comment 7 Vladimir Potapov 2012-09-05 15:15:30 MSD
My little son can not watch a DVD with cartoons in my favorite system. 
This is sad. :-(
Ok, please, add '?' to qa_verified...
Comment 8 Denis Koryavov 2012-09-05 15:18:40 MSD
Well it is a pity for me too, but you must admit that it can't be a blocker for update (because we have no regressions). But I promise to you that we'll consider this issue.
Comment 9 Julia Mineeva 2012-09-05 15:49:56 MSD
Advisory:
new version of ROSA Media Player:
- support midi files, 
- support ID3V2 tag, 
- new icons of control panel,
- updated translations (french, sloveninan, russian), 
- redesign settings window

Buildlists:
https://abf.rosalinux.ru/build_lists/701751
https://abf.rosalinux.ru/build_lists/701750
Comment 10 Vladimir Potapov 2012-09-10 18:40:23 MSD
Created attachment 532 [details]
mp3id2

How can I check for changes in the tags support?
I could not notice the changes, information in the example (Id3v2) supported in the version 1.0
Comment 11 Denis Koryavov 2012-09-10 18:47:41 MSD
Just add some (for example) Russian letters to an audio file and disable all tags except of ID3v2.4 (you can use EasyTag for this). After that you can check this file on ROMP 1.0 and ROMP 1.5. ROMP 1.0 will show only the file name, but the ROMP 1.5 will show the information that you will store in the file ID3v2.4 tag.
Comment 12 Vladimir Potapov 2012-09-11 15:18:07 MSD
Created attachment 533 [details]
bad russian tags
Comment 13 Denis Koryavov 2012-09-11 15:22:24 MSD
Tags should be in UTF-8. Which encoding do you use?
Comment 14 Vladimir Potapov 2012-09-11 15:23:41 MSD
Created attachment 534 [details]
midi files don't linked to ROMP
Comment 15 Vladimir Potapov 2012-09-11 15:25:35 MSD
(In reply to comment #13)
> Tags should be in UTF-8. Which encoding do you use?

I don`t know - EasyTag, default settings....
Comment 16 Denis Koryavov 2012-09-11 15:27:27 MSD
Please look at EasyTag settings. About midi - we'll fix this bug asap.
Comment 17 Vladimir Potapov 2012-09-11 15:38:10 MSD
Created attachment 535 [details]
ID3v2.4 UTF-8 russian
Comment 18 Denis Koryavov 2012-09-11 15:45:20 MSD
Created attachment 536 [details]
Settings for EasyTag

Here is the screenshot with the settings for EasyTag.
Comment 19 Denis Koryavov 2012-09-11 15:46:11 MSD
Created attachment 537 [details]
ROMP_playing_tagged_file
Comment 20 Vladimir Potapov 2012-09-11 16:25:37 MSD
(In reply to comment #18)
> Created attachment 536 [details]
> Settings for EasyTag
> 
> Here is the screenshot with the settings for EasyTag.
With these settings works fine.
But it no "support ID3V2 tag". It is "support ID3V2 tags in some cases"
Comment 21 Denis Koryavov 2012-09-11 16:35:48 MSD
No, it is support of ID3v2.4 tags. With default setting for EasyTag you also added ID3v1.x tag in ISO-88-59-1 encoding and ROMP used it instead of ID3v2.4. Why? Because of many users (most of europian users still use single-byte encodings) use this tag for their collections. 

Yes, ROMP does not support automatic encoding detection, but it is other task.
Comment 22 Vladimir Potapov 2012-09-11 17:13:27 MSD
(In reply to comment #21)
> No, it is support of ID3v2.4 tags. With default setting for EasyTag you also
> added ID3v1.x tag in ISO-88-59-1 encoding and ROMP used it instead of
> ID3v2.4. Why? Because of many users (most of europian users still use
> single-byte encodings) use this tag for their collections. 
> 
> Yes, ROMP does not support automatic encoding detection, but it is other
> task.
Most programs use UTF-8 for ID3v2.4 by default. Maybe make a simple fix  - if exist ID3v1.x tag, then ID3V2.4 set to UTF-8?
EasyTAG is default ROSA program and ROMP and EasyTAG must working together.
Comment 23 Julia Mineeva 2012-09-11 18:29:00 MSD
Advisory:
new version of ROSA Media Player:
- support midi files, 
- support ID3V2 tag, 
- new icons of control panel,
- updated translations (french, sloveninan, russian), 
- redesign settings window

Buildlists:
https://abf.rosalinux.ru/build_lists/715215
https://abf.rosalinux.ru/build_lists/715216
Comment 24 Vladimir Potapov 2012-09-12 14:18:23 MSD
rosa-media-player-1.5-12-rosa.lts2012.0
*********** Advisory *****************
+ support midi files, 
+ support ID3V2 tag, 
+ new icons of control panel,
+ updated translations (french, sloveninan, russian), 
+ redesign settings window
*************************************
QA Verified
Comment 25 Denis Koryavov 2012-09-12 14:53:16 MSD
>  Maybe make a simple fix  - if exist ID3v1.x tag, then ID3V2.4 set to UTF-8?
EasyTAG is default ROSA program and ROMP and EasyTAG must working together.

Well, yes, it is a good idea, but it will be not so easy. We have no a good mechanism for automatic encoding detection. When we find it we'll do this feature.
Comment 26 Vladimir Potapov 2012-09-12 15:57:51 MSD
http://www.id3.org/id3v2.4.0-structure

Frames that allow different types of text encoding contains a text
   encoding description byte. Possible encodings:

     $00   ISO-8859-1 [ISO-8859-1]. Terminated with $00.
     $01   UTF-16 [UTF-16] encoded Unicode [UNICODE] with BOM. All
           strings in the same frame SHALL have the same byteorder.
           Terminated with $00 00.
     $02   UTF-16BE [UTF-16] encoded Unicode [UNICODE] without BOM.
           Terminated with $00 00.
     $03   UTF-8 [UTF-8] encoded Unicode [UNICODE]. Terminated with $00.