Bug 7379 - [UPDATE REQUEST] irssi security vulnerability
: [UPDATE REQUEST] irssi security vulnerability
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
http://www.linuxsecurity.com/content/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-24 09:01 MSD by Zombie Ryushu
Modified: 2016-09-27 14:25 MSD (History)
2 users (show)

See Also:
RPM Package: irssi
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2016-09-24 09:01:52 MSD
Gabriel Campana and Adrien Guinet from Quarkslab discovered two remotely
exploitable crash and heap corruption vulnerabilities in the format
parsing code in Irssi, a terminal based IRC client.

For the stable distribution (jessie), these problems have been fixed in
version 0.8.17-1+deb8u1.
Comment 1 Zombie Ryushu 2016-09-24 10:34:20 MSD
Managed to build an update, but for some strange reason it only builds under x64.
Comment 2 Denis Silakov 2016-09-27 14:25:37 MSD
Fixed.