Bug 7332 - NetworkManager and system-networkd enabled at the same time
: NetworkManager and system-networkd enabled at the same time
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-07 14:06 MSD by Vladimir Potapov
Modified: 2016-12-07 12:25 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2016-09-07 14:06:20 MSD
Two auto-config service (NetworkManager and system-networkd) enabled at the same time. In result, for any  cases manual net config inpossible.

Solution
disable systemd-networkd
disable systemd-resolved
Comment 1 Vladimir Potapov 2016-09-14 14:40:57 MSD
Also need disable non-worked service 
systemd-timesyncd.service

in file
/lib/systemd/system-preset/90-systemd-preset
Comment 2 Vladimir Potapov 2016-10-05 16:52:40 MSD
systemd-resolved use /etc/resolv.conf -> /run/systemd/resolve/resolv.conf
Correct path for NM /var/run/NetworkManager/resolv.conf

For correct disable the service needed switch the link
Comment 3 Vladimir Potapov 2016-11-29 17:05:13 MSK
Pull request
https://abf.io/import/systemd/pull_requests/11
Comment 4 Vladimir Potapov 2016-11-29 17:40:18 MSK
*** Bug 7421 has been marked as a duplicate of this bug. ***
Comment 5 Andrey Bondrov 2016-11-29 17:43:44 MSK
(In reply to comment #3)
> Pull request
> https://abf.io/import/systemd/pull_requests/11

Advisory: "Fix services with systemd"

https://abf.rosalinux.ru/build_lists/2761748
https://abf.rosalinux.ru/build_lists/2761749
Comment 6 Vladimir Potapov 2016-11-29 17:46:01 MSK
For 2016.1
https://abf.io/import/systemd/pull_requests/12
Comment 7 Vladimir Potapov 2016-11-29 18:47:07 MSK
The update is sent to expanded testing
***************************************
Comment 8 Vladimir Potapov 2016-12-06 19:24:59 MSK
systemd-219-1.20150505.22
https://abf.rosalinux.ru/build_lists/2761748
https://abf.rosalinux.ru/build_lists/2761749
************************* Advisory ********************************
Fix services with systemd, disable systemd-networkd, 
systemd-resolved, systemd-timesyncd
*******************************************************************
QA Verified