Bug 731 - When unmounting my USB drive, plasma-desktop consumes 7% to 11% of CPU
: When unmounting my USB drive, plasma-desktop consumes 7% to 11% of CPU
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 14:46 MSD by Pavel Shved
Modified: 2015-02-02 14:33 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Shved 2012-09-02 14:46:07 MSD
Description of problem:

Normally, plasma-desktop consumes 1% of CPU.
When I unmount a USB-drive via the "Available Devices" tray button, the consumption raises to 7%.
When I actually click at "Available Devices" in the system tray to watch the animation of the disk being unmounted, the consumption raises to 11%, and drops back to 7 when I hide the panel.
When unmounting is finished, the consumption drops back to normal 1%

The process of unmounting took a couple of minutes, as it was flushing buffers, so I had a plenty of time to measure.


How reproducible:

Didn't try to reproduce; just noticed it.

Steps to Reproduce:
1. Copy something large to a USB drive (1Gb file worked for me).  Watch the plasma-desktop CPU consumption (with, say, Ctr+Esc).
2. Unmount it immediately, without waiting for the buffers to get flushed automatically.
3. Notice the increase in CPU%.
Comment 1 Pavel Shved 2012-09-02 15:02:32 MSD
Just reproduced it again with similar CPU consumption figures.
Comment 2 FirstLevel 2014-06-09 09:11:22 MSD
Case is actual?
Comment 3 Denis Silakov 2015-02-02 14:33:37 MSK
No answer for a long time and no similar bug reports, let's close this one.