Bug 7276 - [UPDATE REQUEST] diffutils 3.3 → 3.4
: [UPDATE REQUEST] diffutils 3.3 → 3.4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-10 13:04 MSD by Алзим
Modified: 2016-09-01 22:10 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Алзим 2016-08-10 13:04:58 MSD
Advisory: «Updated to 3.4»

Build lists:
https://abf.io/build_lists/2696285
https://abf.io/build_lists/2696286

Пользователям эта утилита может особо и ненужна, но для сборки новой платформы может пригодиться.
В ней немного изменены алгоритмы сравнения.
Comment 1 VictorR2007 2016-08-14 12:06:30 MSD
А в нём есть обратная совместимость?
А то сделал сейчас патч для исправления этой ошибки
http://bugs.rosalinux.ru/show_bug.cgi?id=5980
и он несколько отличается от привычного вида патчей.
Теперь не знаю, может стоит пока откатить diffutils,
и сделать патч со старой версией.
Comment 2 VictorR2007 2016-08-14 12:21:57 MSD
(In reply to comment #1)
> А в нём есть обратная совместимость?
> А то сделал сейчас патч для исправления этой ошибки
> http://bugs.rosalinux.ru/show_bug.cgi?id=5980
> и он несколько отличается от привычного вида патчей.
> Теперь не знаю, может стоит пока откатить diffutils,
> и сделать патч со старой версией.

Ой, извиняюсь.
В команде была опечатка, и поэтому патч немного отличался. :)
Comment 3 Vladimir Potapov 2016-08-16 07:51:13 MSD
2016.1 пока обновляется без QA так что закрываю.