Bug 7275 - okularplugin hangs and needs to be updated.
: okularplugin hangs and needs to be updated.
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
https://github.com/afrimberger/okular...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-10 12:41 MSD by Zombie Ryushu
Modified: 2016-09-28 11:31 MSD (History)
2 users (show)

See Also:
RPM Package: okularplugin
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2016-08-10 12:41:37 MSD
okularplugin hangs and needs to be updated.

Minor bugfixing relase.

Changes:
 - Add mouse drag button to be compliant with newer okular versions
 - Add ebuilds for gentoo
 - Remove unnecessary statusbar
Comment 1 Andrey Bondrov 2016-08-10 13:19:17 MSD
Done, okularplugin was updated to 1.0.1.
Comment 2 Zombie Ryushu 2016-08-10 13:30:15 MSD
The error was 'BadColor (invalid Colormap parameter)'.
  (Details: serial 17 error_code 12 request_code 84 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() wait for reply: Connection closed
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2228):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2278):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2487):invoke_NPP_NewStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2159):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))
ERROR: ld.so: object '/usr/lib/libaoss.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
dirname: missing operand
Try 'dirname --help' for more information.
The program 'npviewer.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadColor (invalid Colormap parameter)'.
  (Details: serial 17 error_code 12 request_code 84 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() wait for reply: Connection closed
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2228):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2278):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2487):invoke_NPP_NewStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2228):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2228):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2278):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2159):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))

I got a new error.
Comment 3 Andrey Bondrov 2016-08-10 13:46:50 MSD
That's bad. There were no commits to okularplugin git for 3 years. And I don't think I can patch it myself. Perhaps we should just drop it as all other distros did?
Comment 4 Zombie Ryushu 2016-08-13 00:42:55 MSD
Okay, I think this needs to be rebranded as a General FireFox bug. I just tried to use the AcroRead NPPDF Plugin from 9.5.5, and got this

The program 'npviewer.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadColor (invalid Colormap parameter)'.
  (Details: serial 17 error_code 12 request_code 84 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() wait for reply: Connection closed
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2228):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2278):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2487):invoke_NPP_NewStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2278):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2278):invoke_NPP_GetValue: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2228):invoke_NPP_SetWindow: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper/src/npw-wrapper.c:2159):invoke_NPP_Destroy: assertion failed: (rpc_method_invoke_possible(plugin->connection))
Comment 5 Zombie Ryushu 2016-08-16 20:08:09 MSD
This bug apprears to be related to NSS, and not Okular Plugin, or FireFox. I am still investigating, but I have discovered a deadlock.
Comment 7 Zombie Ryushu 2016-08-17 09:05:34 MSD
I need a favor. Would you try this build?



d5ea187 is the last one in jeremysanders/okularplugin

https://github.com/jeremysanders/okularplugin Can you try this github for me?
Comment 8 Andrey Bondrov 2016-08-18 05:17:25 MSD
(In reply to comment #7)
> I need a favor. Would you try this build?
> 
> d5ea187 is the last one in jeremysanders/okularplugin
> 
> https://github.com/jeremysanders/okularplugin Can you try this github for me?

No need to do it. The diff between latest snapshot from this git repository and okularplugin 1.0.1 is empty. It's the same code.
Comment 9 Zombie Ryushu 2016-08-18 05:19:51 MSD
It appears to be a deadlock in the Plugin-container module of FireFox itself triggered by a change in gtk+, glib, or all of the above. Strace of this yeilds a FUTEX Lock. Normally, that means deadlock.
Comment 10 Andrey Bondrov 2016-08-18 06:28:34 MSD
(In reply to comment #9)
> It appears to be a deadlock in the Plugin-container module of FireFox itself
> triggered by a change in gtk+, glib, or all of the above. Strace of this
> yeilds a FUTEX Lock. Normally, that means deadlock.

Can you please check if it works with Firefox ESR (firefox-esr24 package)? Just to be sure the issue is caused by Firefox itself.
Comment 11 Zombie Ryushu 2016-08-18 06:39:15 MSD
Yes, in fact not only that it happens with palemoon.
Comment 12 Andrey Bondrov 2016-08-18 13:50:45 MSD
(In reply to comment #11)
> Yes, in fact not only that it happens with palemoon.

Hmm, can it be nspluginwrapper issue then? What happens if nspluginwrapper is removed from the system?
Comment 13 Zombie Ryushu 2016-08-19 02:32:20 MSD
Okularplugin does not use nspluginwrapper, and even if it is removed, Okularlugin still hangs, but without nspluginwrapper, you can't use AcroRead in FireFox.
Comment 14 Zombie Ryushu 2016-08-19 07:45:33 MSD
Under Mageia 5, Okular Plugin and Acroread function as intended with builds from Rosa 2014.1. This includes the v1.0.1 binary pushed.
Comment 15 Zombie Ryushu 2016-08-20 06:21:48 MSD
(gdb) bt full
#0  0x00007ffff26389ca in  () at /usr/lib64/firefox-46.0.1/libxul.so
#1  0x00007ffff26330e2 in  () at /usr/lib64/firefox-46.0.1/libxul.so
#2  0x00007ffff26332bc in  () at /usr/lib64/firefox-46.0.1/libxul.so
#3  0x00007ffff6d12611 in  () at /usr/lib64/libgdk-3.so.0
#4  0x00007ffff6d128f6 in  () at /usr/lib64/libgdk-3.so.0
#5  0x00007ffff6ce6979 in gdk_display_get_event () at /usr/lib64/libgdk-3.so.0
#6  0x00007ffff6d12692 in  () at /usr/lib64/libgdk-3.so.0
#7  0x000000397b2490d7 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#8  0x000000397b249338 in  () at /lib64/libglib-2.0.so.0
#9  0x000000397b2493dc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#10 0x00007ffff2639168 in  () at /usr/lib64/firefox-46.0.1/libxul.so
#11 0x00007ffff261d2d0 in  () at /usr/lib64/firefox-46.0.1/libxul.so
#12 0x00007ffff261d456 in  () at /usr/lib64/firefox-46.0.1/libxul.so
#13 0x00007ffff13324e9 in  () at /usr/lib64/firefox-46.0.1/libxul.so
#14 0x00007ffff134cdfc in  () at /usr/lib64/firefox-46.0.1/libxul.so
#15 0x00007ffff15562ad in  () at /usr/lib64/firefox-46.0.1/libxul.so
#16 0x00007ffff1520dff in  () at /usr/lib64/firefox-46.0.1/libxul.so
#17 0x00007ffff261b5aa in  () at /usr/lib64/firefox-46.0.1/libxul.so
#18 0x00007ffff2be6f9f in  () at /usr/lib64/firefox-46.0.1/libxul.so
#19 0x00007ffff2c1915e in  () at /usr/lib64/firefox-46.0.1/libxul.so
#20 0x00007ffff2c193f3 in  () at /usr/lib64/firefox-46.0.1/libxul.so
#21 0x00007ffff2c195e6 in XRE_main () at /usr/lib64/firefox-46.0.1/libxul.so

I found something.
Comment 16 Zombie Ryushu 2016-09-28 11:31:54 MSD
Not an Okular Plugin issue. Underlying NSS issue.