Bug 7216 - Missing dependency in ipython 5.0
: Missing dependency in ipython 5.0
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-15 01:34 MSD by Eugene Budanov
Modified: 2016-07-20 00:40 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Budanov 2016-07-15 01:34:57 MSD
When I tried to run ipython 5.0 I see error:

ipython
Traceback (most recent call last):
  File "/usr/bin/ipython", line 4, in <module>
    from IPython import start_ipython
  File "/usr/lib/python2.7/site-packages/IPython/__init__.py", line 48, in <module>
    from .core.application import Application
  File "/usr/lib/python2.7/site-packages/IPython/core/application.py", line 23, in <module>
    from traitlets.config.application import Application, catch_config_error
ImportError: No module named traitlets.config.application
Comment 1 Denis Silakov 2016-07-18 18:52:20 MSD
Should be fixed now.
Comment 2 Eugene Budanov 2016-07-18 23:39:55 MSD
Not fixed:

ipython
Traceback (most recent call last):
  File "/usr/bin/ipython", line 4, in <module>
    from IPython import start_ipython
  File "/usr/lib/python2.7/site-packages/IPython/__init__.py", line 48, in <module>
    from .core.application import Application
  File "/usr/lib/python2.7/site-packages/IPython/core/application.py", line 23, in <module>
    from traitlets.config.application import Application, catch_config_error
  File "/usr/lib/python2.7/site-packages/traitlets/config/__init__.py", line 6, in <module>
    from .application import *
  File "/usr/lib/python2.7/site-packages/traitlets/config/application.py", line 16, in <module>
    from decorator import decorator
ImportError: No module named decorator
Comment 3 Denis Silakov 2016-07-19 12:26:43 MSD
Pushed one more requirement (python-decorator), please try again.
Comment 4 Eugene Budanov 2016-07-20 00:40:08 MSD
(In reply to comment #3)
> Pushed one more requirement (python-decorator), please try again.

Yep. All fine.