Bug 7210 - [UPDATE REQUEST] steam 1.0.0.52
: [UPDATE REQUEST] steam 1.0.0.52
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-13 23:04 MSD by Eugene Shatokhin
Modified: 2016-07-18 18:18 MSD (History)
2 users (show)

See Also:
RPM Package: steam
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2016-07-13 23:04:58 MSD
New upstream version + a number of changes.
Comment 1 Eugene Shatokhin 2016-07-13 23:08:13 MSD
Advisory:
Steam was updated to version 1.0.0.52. Additionally, the following changes were made:
1. "steam" package now pulls in the libraries needed to run Steam without the bundled runtime, that is, using the native system libraries only. This mode is not used by default but can be enabled if STEAM_RUNTIME environment variable is set to 0. This way "Civilization V" is able to run in Steam, for example. 
If a game does not start or fails somehow, the users are encouraged to try it when Steam is started with STEAM_RUNTIME=0.
2. Fixed the problems that did not allow "Unity of Command" and "The Talos Principle" to run in Steam.
3. Disabled saving of the Steam's crash dumps in /tmp/dumps by default. They could consume sizeable amounts of RAM if /tmp is mounted as tmpfs. To re-enable, one needs to set STEAM_ENABLE_DUMPS environment variable to any non-empty value.


Build lists:
i586: https://abf.io/build_lists/2692361


Hints for testing

* Please check for regressions if Steam is launched as is, without changes in the environment variables.
* If a game runs OK in Steam, please check that it runs OK when Steam is started as "STEAM_RUNTIME=0 steam" as well.

Known issues

1. Steam reports segmentation fault at the exit if it was started with STEAM_RUNTIME=0.
Similar to https://github.com/ValveSoftware/steam-for-linux/issues/4395
Seems to make no harm.

2. ../vgui_surfacelib/FontManager.cpp (276) : Assertion Failed: descs.Count() >= 1
Seems to make no harm either

3. If /tmp/dumps was present when Steam was launched, it will not disable/enable crash dumps (depending on STEAM_ENABLE_DUMPS). This is intentional because /tmp/dumps could belong to some other application, not Steam. Steam is unable to clean it up due to technical reasons.
Comment 2 Vladimir Potapov 2016-07-15 13:39:30 MSD
The update is sent to expanded testing
***************************************
Comment 3 Vladimir Potapov 2016-07-15 15:40:47 MSD
on x64 system:

You are missing the following 32-bit libraries, and Steam may not run:
libgtk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0
Comment 4 Vladimir Potapov 2016-07-15 15:48:49 MSD
Если либы добавить, то
STEAM_RUNTIME=0 steam
Running Steam on rosadesktopfresh 2014.1 64-bit
STEAM_RUNTIME is disabled by the user
Installing breakpad exception handler for appid(steam)/version(1468023329)
Installing breakpad exception handler for appid(steam)/version(1468023329)
Gtk-Message: Failed to load module "canberra-gtk-module"
Installing breakpad exception handler for appid(steam)/version(1468023329)
/home/keleg/.local/share/Steam/ubuntu12_32/steamwebhelper: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory
../vgui_surfacelib/FontManager.cpp (276) : Assertion Failed: descs.Count() >= 1
Assert( Assertion Failed: descs.Count() >= 1 ):../vgui_surfacelib/FontManager.cpp:276

Installing breakpad exception handler for appid(steam)/version(1468023329)
crash_20160715194749_5.dmp[10422]: Uploading dump (out-of-process)
/tmp/dumps/crash_20160715194749_5.dmp
../vgui_surfacelib/FontManager.cpp (276) : Assertion Failed: descs.Count() >= 1
../vgui_surfacelib/FontManager.cpp (276) : Assertion Failed: descs.Count() >= 1
../vgui_surfacelib/FontManager.cpp (276) : Assertion Failed: descs.Count() >= 1
../common/steam/client_api.cpp (331) : Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed, most likely because you are missing a 32-bit dependency of steamclient.so (the Steam client is a 32-bit app).

SteamStartup.cpp (834) : Assertion Failed: ! "There was a problem with your Steam installation.\n" "Please reinstall steam.\n"
[2016-07-15 19:47:49] Startup - updater built Jul  8 2016 21:43:51
[2016-07-15 19:47:49] Проверка установки...
[2016-07-15 19:47:49] Verification complete
[2016-07-15 19:47:50] Shutdown
crash_20160715194749_5.dmp[10422]: Finished uploading minidump (out-of-process): success = yes
crash_20160715194749_5.dmp[10422]: response: CrashID=bp-2d1368eb-0526-40fc-9a0b-469122160715
crash_20160715194749_5.dmp[10422]: file ''/tmp/dumps/crash_20160715194749_5.dmp'', upload yes: ''CrashID=bp-2d1368eb-0526-40fc-9a0b-469122160715''
Comment 5 Vladimir Potapov 2016-07-18 17:38:36 MSD
steam-1.0.0.52-3
https://abf.io/build_lists/2692361
*********************** Advisory ******************************
Steam was updated to version 1.0.0.52. Additionally, the following changes were made:
1. "steam" package now pulls in the libraries needed to run Steam without the bundled runtime, that is, using the native system libraries only. This mode is not used by default but can be enabled if STEAM_RUNTIME environment variable is set to 0. This way "Civilization V" is able to run in Steam, for example. 
If a game does not start or fails somehow, the users are encouraged to try it when Steam is started with STEAM_RUNTIME=0.
2. Fixed the problems that did not allow "Unity of Command" and "The Talos Principle" to run in Steam.
3. Disabled saving of the Steam's crash dumps in /tmp/dumps by default. They could consume sizeable amounts of RAM if /tmp is mounted as tmpfs. To re-enable, one needs to set STEAM_ENABLE_DUMPS environment variable to any non-empty value.
***************************************************************
QA Verfied