Bug 7189 - Rosa doesn't detect Intel graphics drivers
: Rosa doesn't detect Intel graphics drivers
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-07 17:09 MSD by Evgeniy
Modified: 2016-07-11 11:33 MSD (History)
1 user (show)

See Also:
RPM Package: x11-driver-video-intel
ISO-related:
Bad POT generating:
Upstream:


Attachments
Hardware information (52.45 KB, application/x-7z-compressed)
2016-07-07 17:09 MSD, Evgeniy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy 2016-07-07 17:09:38 MSD
Created attachment 4495 [details]
Hardware information

Description of problem: I can't set Intel graphics, so I have to use XFree or VESA drivers with x11-driver-video installed.


Version-Release number of selected component (if applicable): R7


How reproducible: Just try Intel HD 4000 hardware


I attach hwinfo, lspci, and dmesg output. hw-probe cannot upload HW data (curl error 6).
Comment 1 Eugene Shatokhin 2016-07-07 20:48:23 MSD
Please provide more info about what you are trying to accomplish.

Most of the time, Intel graphics does not need manual setup (with XFdrake and such) and works fine out-of-the box.

If I understand it right, you started XFdrake (Graphics Settings or whatever) and it does not show the Intel GPU. Or?
Comment 2 Evgeniy 2016-07-07 23:22:49 MSD
I can't turn on wobbly windows because it requires openGL, but I can't turn it on since the drivers are not loaded because the OS shows only i915 and VESA, excluding Intel's HD Graphics.

I have Intel 4000 HD, but the OS seems not to have the proper drivers.
Comment 3 Eugene Shatokhin 2016-07-08 11:21:44 MSD
(In reply to comment #2)
> I can't turn on wobbly windows because it requires openGL, but I can't turn
> it on since the drivers are not loaded because the OS shows only i915 and
> VESA, excluding Intel's HD Graphics.
> 
> I have Intel 4000 HD, but the OS seems not to have the proper drivers.

i915 *is* the driver used for all Intel graphics, including Intel 4000 HD. There is no other.
Comment 4 Eugene Shatokhin 2016-07-08 11:23:03 MSD
As for OpenGL, please upload the output of glxinfo, or, better, try hw-probe again (there were problems on the server lately, should be OK now).
Comment 5 Evgeniy 2016-07-08 12:37:02 MSD
(In reply to comment #4)
> As for OpenGL, please upload the output of glxinfo, or, better, try hw-probe
> again (there were problems on the server lately, should be OK now).

Probe URL: http://hw.rosalinux.ru/index.php?probe=ea01158d39

No openGL =(
Comment 6 Eugene Shatokhin 2016-07-08 13:41:11 MSD
(In reply to comment #5)
> Probe URL: http://hw.rosalinux.ru/index.php?probe=ea01158d39
> 
> No openGL =(

Please try the following now (as root). Create /etc/X11/xorg.conf.d/50-intel.conf with the following contents:


Section "Device"
  Identifier "Device0"
  Driver "Intel"
  Option "AccelMethod" "uxa"
EndSection


Then reboot the system or restart the X server and see if that helps. Please upload the data using hw-probe once again after this.

If it does not help, you can remove that file and try to install a newer kernel, for example 4.6.x, as described here:

http://wiki.rosalab.ru/en/index.php/Installing_unofficial_kernels
Comment 7 Evgeniy 2016-07-11 10:12:56 MSD
 Creation of 50-intel.conf was helpful.
Comment 8 Eugene Shatokhin 2016-07-11 11:33:56 MSD
(In reply to comment #7)
>  Creation of 50-intel.conf was helpful.

Good. So it might be another issue with "SNA" acceleration in the Intel's X11 driver after all.

Let is keep the bug open for now: we might prepare a package with that workaround. Or, perhaps, the problem with "SNA" will be fixed in the future updates of x11-driver-video-intel.