Bug 7172 - qemu-system-tricore missing
: qemu-system-tricore missing
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
http://brezular.com/2014/07/16/cisco-...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-02 06:24 MSD by Zombie Ryushu
Modified: 2016-07-11 19:34 MSD (History)
4 users (show)

See Also:
RPM Package: qemu
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
eugene.shatokhin: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2016-07-02 06:24:27 MSD
qemu-system-tricore is missing from qemu.
Comment 1 Zombie Ryushu 2016-07-02 08:58:48 MSD
/usr/bin/qemu-system-tricore: symbol lookup error: /usr/bin/qemu-system-tricore: undefined symbol: libusb_get_port_numbers

Apparently, there is a symbol lookup error.
Comment 2 Denis Silakov 2016-07-06 16:01:32 MSD
Can't reproduce this, qemu-system-tricore starts fine on my system.

What do the following commands say:
$ rpm -qf /usr/bin/qemu-system-tricore
$ ldd -r /usr/bin/qemu-system-tricore
Comment 3 Zombie Ryushu 2016-07-06 17:31:21 MSD
The file exists, the error is caused by an unresolved symbol error in libusb_get_port_numbers
Comment 4 Denis Silakov 2016-07-06 17:32:27 MSD
yes, that's why I'm asking you to launch the following command:

$ ldd -r /usr/bin/qemu-system-tricore

It will show the libs linker is going to use for this binary.
Comment 5 Zombie Ryushu 2016-07-06 17:32:55 MSD
        linux-vdso.so.1 =>  (0x00007ffc732d1000)
        libepoxy.so.0 => /usr/lib64/libepoxy.so.0 (0x00007efd20473000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007efd20133000)
        libz.so.1 => /lib64/libz.so.1 (0x00007efd1ff17000)
        libaio.so.1 => /usr/lib64/libaio.so.1 (0x00007efd1fd15000)
        libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00007efd1faa1000)
        libssh2.so.1 => /usr/lib64/libssh2.so.1 (0x00007efd1f872000)
        libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x00007efd1f662000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007efd1f3b6000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007efd1f1b2000)
        libnuma.so.1 => /usr/lib64/libnuma.so.1 (0x00007efd1efa6000)
        libbluetooth.so.3 => /lib64/libbluetooth.so.3 (0x00007efd1ed84000)
        libncursesw.so.5 => /lib64/libncursesw.so.5 (0x00007efd1eb18000)
        libasound.so.2 => /usr/lib64/libasound.so.2 (0x00007efd1e813000)
        libpulse.so.0 => /usr/lib64/libpulse.so.0 (0x00007efd1e5c2000)
        libvdeplug.so.3 => /usr/lib64/libvdeplug.so.3 (0x00007efd1e3bb000)
        libuuid.so.1 => /lib64/libuuid.so.1 (0x00007efd1e1b6000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007efd1df5a000)
        libjpeg.so.8 => /usr/lib64/libjpeg.so.8 (0x00007efd1dcd8000)                                                                                                   
        libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007efd1dab9000)                                                                                                 
        libSDL2-2.0.so.0 => /usr/lib64/libSDL2-2.0.so.0 (0x00007efd1d7be000)                                                                                           
        libvte2_90.so.9 => /usr/lib64/libvte2_90.so.9 (0x00007efd1d516000)                                                                                             
        libgtk-3.so.0 => /usr/lib64/libgtk-3.so.0 (0x00007efd1cc3a000)                                                                                                 
        libgdk-3.so.0 => /usr/lib64/libgdk-3.so.0 (0x00007efd1c998000)                                                                                                 
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007efd1c78a000)                                                                               
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007efd1c53e000)                                                                                         
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007efd1c317000)                                                                                             
        libcairo-gobject.so.2 => /usr/lib64/libcairo-gobject.so.2 (0x00007efd1c10d000)                                                                                 
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007efd1bee7000)                                                                               
        libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007efd1bb6c000)                                                                                                 
        libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007efd1b91a000)                                                                                         
        libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007efd1b60c000)                                                                                               
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007efd1b2fc000)                                                                                                 
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007efd1b0e9000)                                                                                                   
        libnettle.so.6 => /usr/lib64/libnettle.so.6 (0x00007efd1aeb0000)                                                                                               
        libgnutls.so.28 => /usr/lib64/libgnutls.so.28 (0x00007efd1abaa000)                                                                                             
        libseccomp.so.2 => /usr/lib64/libseccomp.so.2 (0x00007efd1a97d000)                                                                                             
        libspice-server.so.1 => /usr/lib64/libspice-server.so.1 (0x00007efd1a666000)                                                                                   
        libusb-1.0.so.0 => /lib64/libusb-1.0.so.0 (0x00007efd1a455000)                                                                                                 
        libusbredirparser.so.1 => /usr/lib64/libusbredirparser.so.1 (0x00007efd1a24c000)                                                                               
        libtcmalloc.so.4 => /usr/lib64/libtcmalloc.so.4 (0x00007efd19fd9000)                                                                                           
        libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007efd19dd7000)                                                                                         
        librt.so.1 => /lib64/librt.so.1 (0x00007efd19bce000)                                                                                                           
        libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007efd198c3000)                                                                                                   
        libm.so.6 => /lib64/libm.so.6 (0x00007efd195bc000)                                                                                                             
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007efd193a4000)                                                                                                     
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007efd19187000)                                                                                                 
        libc.so.6 => /lib64/libc.so.6 (0x00007efd18dc3000)                                                                                                             
        /lib64/ld-linux-x86-64.so.2 (0x0000560cd2aa8000)                                                                                                               
        libdl.so.2 => /lib64/libdl.so.2 (0x00007efd18bbe000)                                                                                                           
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007efd1899e000)                                                                                                     
        libcares.so.2 => /usr/lib64/libcares.so.2 (0x00007efd1878c000)                                                                                                 
        libidn.so.11 => /usr/lib64/libidn.so.11 (0x00007efd18556000)                                                                                                   
        libssl.so.1.0.0 => /usr/lib64/libssl.so.1.0.0 (0x00007efd182eb000)                                                                                             
        libcrypto.so.1.0.0 => /usr/lib64/libcrypto.so.1.0.0 (0x00007efd17eda000)
        libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00007efd17c8c000)
        liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2 (0x00007efd17a7d000)
        libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2 (0x00007efd17832000)
        libpulsecommon-8.0.so => /usr/lib64/pulseaudio/libpulsecommon-8.0.so (0x00007efd175b1000)
        libX11-xcb.so.1 => /usr/lib64/libX11-xcb.so.1 (0x00007efd173af000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x00007efd17192000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x00007efd16f89000)
        libXtst.so.6 => /usr/lib64/libXtst.so.6 (0x00007efd16d83000)
        libsystemd.so.0 => /lib64/libsystemd.so.0 (0x00007efd16d59000)
        libjson-c.so.2 => /usr/lib64/libjson-c.so.2 (0x00007efd16b4e000)
        libwrap.so.0 => /lib64/libwrap.so.0 (0x00007efd16943000)
        libsndfile.so.1 => /usr/lib64/libsndfile.so.1 (0x00007efd166d9000)
        libasyncns.so.0 => /usr/lib64/libasyncns.so.0 (0x00007efd164d3000)
        libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007efd16281000)
        libcap.so.2 => /lib64/libcap.so.2 (0x00007efd1607b000)
        libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007efd15e77000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007efd15c66000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007efd15a60000)
        libatk-bridge-2.0.so.0 => /usr/lib64/libatk-bridge-2.0.so.0 (0x00007efd15832000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007efd1561d000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007efd153de000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007efd151db000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007efd14fcf000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007efd14dc4000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007efd14bc1000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007efd149bd000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007efd14714000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007efd144f8000)
        libffi.so.6 => /usr/lib64/libffi.so.6 (0x00007efd142ef000)
        libpcre.so.1 => /lib64/libpcre.so.1 (0x00007efd14082000)
        libxcb-shm.so.0 => /usr/lib64/libxcb-shm.so.0 (0x00007efd13e7e000)
        libxcb-render.so.0 => /usr/lib64/libxcb-render.so.0 (0x00007efd13c74000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007efd13a6a000)
        libp11-kit.so.0 => /usr/lib64/libp11-kit.so.0 (0x00007efd13827000)
        libtasn1.so.6 => /usr/lib64/libtasn1.so.6 (0x00007efd13613000)
        libnettle.so.4 => /usr/lib64/libnettle.so.4 (0x00007efd133e2000)
        libhogweed.so.2 => /usr/lib64/libhogweed.so.2 (0x00007efd131ba000)
        libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007efd12f41000)
        libcelt051.so.0 => /usr/lib64/libcelt051.so.0 (0x00007efd12d32000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007efd12b2d000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007efd12927000)
        libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00007efd12643000)
        libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00007efd12412000)
        libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007efd1220e000)
        libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00007efd12000000)
        libkeyutils.so.1 => /usr/lib64/libkeyutils.so.1 (0x00007efd11dfc000)
        liblzma.so.5 => /lib64/liblzma.so.5 (0x00007efd11bc8000)
        libgcrypt.so.20 => /usr/lib64/libgcrypt.so.20 (0x00007efd118e9000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00007efd116d0000)
        libFLAC.so.8 => /usr/lib64/libFLAC.so.8 (0x00007efd1146a000)
        libogg.so.0 => /usr/lib64/libogg.so.0 (0x00007efd11263000)
        libvorbis.so.0 => /usr/lib64/libvorbis.so.0 (0x00007efd11036000)
        libvorbisenc.so.2 => /usr/lib64/libvorbisenc.so.2 (0x00007efd10d81000)
        libatspi.so.0 => /usr/lib64/libatspi.so.0 (0x00007efd10b50000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007efd108f9000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007efd10592000)
        libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007efd1038c000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007efd1015f000)
undefined symbol: libusb_get_port_numbers       (/usr/bin/qemu-system-tricore)
Comment 6 Denis Silakov 2016-07-06 17:35:03 MSD
Aha. Will it help to install lib64usbx1.0_0 and remove lib64usb1.0_0?
Comment 7 Zombie Ryushu 2016-07-06 17:43:57 MSD
(In reply to comment #6)
> Aha. Will it help to install lib64usbx1.0_0 and remove lib64usb1.0_0?

The error seems to have gone away after doing that.
Comment 8 Andrey Bondrov 2016-07-06 18:32:03 MSD
Advisory: "Follow library packaging policy: rename library subpackages from lib[64]usbx1.0_0 to lib[64]usb1.0_0 because library file is libusb-1.0.so.0, do the same with devel and static-devel subpackages."

https://abf.rosalinux.ru/build_lists/2685092
https://abf.rosalinux.ru/build_lists/2685093
Comment 9 Zombie Ryushu 2016-07-06 19:10:33 MSD
(In reply to comment #8)
> Advisory: "Follow library packaging policy: rename library subpackages from
> lib[64]usbx1.0_0 to lib[64]usb1.0_0 because library file is libusb-1.0.so.0,
> do the same with devel and static-devel subpackages."
> 
> https://abf.rosalinux.ru/build_lists/2685092
> https://abf.rosalinux.ru/build_lists/2685093

I've just verified vLOS Now runs under GNS3, and it didn't before, that was my goal.
Comment 10 Denis Silakov 2016-07-07 12:14:57 MSD
Well, let's follow the formal procedure and wait for QA approval.
Comment 11 Vladimir Potapov 2016-07-07 16:26:19 MSD
The update is sent to expanded testing
****************************************
Comment 12 Vladimir Potapov 2016-07-11 19:12:53 MSD
libusbx-1.0.18-2
https://abf.rosalinux.ru/build_lists/2685092
https://abf.rosalinux.ru/build_lists/2685093
********************************* Advisory ****************************
Follow library packaging policy: rename library subpackages from lib[64]usbx1.0_0 to lib[64]usb1.0_0 because library file is libusb-1.0.so.0, do the same with devel and static-devel subpackages.
***********************************************************************
QA Verified