Bug 7140 - No directory "/etc/pm"
: No directory "/etc/pm"
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-20 15:51 MSD by mtzseb
Modified: 2016-07-05 00:24 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mtzseb 2016-06-20 15:51:27 MSD
Description of problem:

To remove the Hard Disk Drive Head Parking , I wanted to configure hdparm service at the startup with systemd.
(https://wiki.archlinux.fr/Hdparm#KDE_.3D.3E_4.4.4_et_hdparm)

For this, I must start firstly the following command:

touch /etc/pm/power.d/harddrive

What is strange is that on one of my two computers running Rosa Linux Fresh R7, I could follow the tutorial without a problem, and it works, but on the other directory "pm" does not exist in etc !!! So after every restart, the head parking comes back ...

I try to install the pm-utils unsuccessfully for the missing directory ...
Comment 1 mtzseb 2016-06-28 20:15:14 MSD
So ? No solution ? Arghh...
Comment 2 Denis Silakov 2016-07-04 23:17:41 MSD
Have you tried to simply create /etc/pm/power.d folder manually? It is not created by our pm-utils, indeed, but packages that needs to have something in this folder just install it by themselves.

Actually it looks like nobody tried to use this trick for hdparm in our KDE.
Comment 3 mtzseb 2016-07-05 00:24:15 MSD
I try to create /etc/pm/power.d folder manually, but it don't works after reboot...


up-HP-ZBook-15 ~ # systemctl status hdparm.service
● hdparm.service - script_hdparm
   Loaded: loaded (/etc/systemd/system/hdparm.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
up-HP-ZBook-15 ~ # hdparm -B /dev/sda

/dev/sda:
 APM_level      = 128