Bug 7128 - ROSA Fresh 7 Install Kernel Panic
: ROSA Fresh 7 Install Kernel Panic
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: Eugene Shatokhin
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-17 11:46 MSD by darrencleaver
Modified: 2016-06-20 12:12 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Screen shot 1 of 3 (169.17 KB, image/jpeg)
2016-06-17 11:46 MSD, darrencleaver
Details
Attachment 2 of 3 Terminal output of boot error (154.90 KB, image/jpeg)
2016-06-17 11:47 MSD, darrencleaver
Details
Attachment 3 of 3 Terminal output of boot error (168.89 KB, image/jpeg)
2016-06-17 11:47 MSD, darrencleaver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description darrencleaver 2016-06-17 11:46:26 MSD
Created attachment 4479 [details]
Screen shot 1 of 3

Description of problem:
I was running ROSA Fresh Desktop. I tested another OS KaOS Linux, so I installed KaOS removed ROSA Fresh. Once I finished with KaOS I went to re-install ROSA Fresh ISO . When I boot the ISO I get the following errors ( See attachments ) 
RE: Kernel Panic. Hence I can not install. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 darrencleaver 2016-06-17 11:47:15 MSD
Created attachment 4480 [details]
Attachment 2 [details] of 3 Terminal output of boot error
Comment 2 darrencleaver 2016-06-17 11:47:54 MSD
Created attachment 4481 [details]
Attachment 3 [details] of 3 Terminal output of boot error
Comment 3 Eugene Shatokhin 2016-06-17 14:26:04 MSD
There was a problem in the kernel I fixed some time ago, perhaps this is it.

You tried the official ISO image of ROSA R7, right? 
Which variant (KDE, GNOME, ...)?

Please you try the ISO image from here:
https://abf.io/platforms/rosa2014.1/products/86/product_build_lists/15389

It should already contain the fixes for such problems.

Please try it in Live mode first and upload the info about the hardware, etc., to us using hw-probe tool (http://hw.rosalinux.ru/index.php?show=check).

If it is OK in Live mode, you can try to install ROSA from that ISO image.
Comment 4 Eugene Shatokhin 2016-06-17 14:31:09 MSD
If the problem persists even with that new ISO image, please add "intel_iommu=off" (without quotes) to the kernel boot options and see if it helps.
Comment 5 darrencleaver 2016-06-17 14:37:56 MSD
Is there a torrent download or server in Australia for this ISO 

https://abf.io/platforms/rosa2014.1/products/86/product_build_lists/15389

?
Comment 6 Eugene Shatokhin 2016-06-17 19:55:20 MSD
(In reply to comment #5)
> Is there a torrent download or server in Australia for this ISO 
> 
> https://abf.io/platforms/rosa2014.1/products/86/product_build_lists/15389
> 
> ?

No, it is an unofficial image and was not uploaded to the public servers yet.

However, I have uploaded ROSA.FRESH.KDE.R7.15389.b.x86_64.uefi.iso to Google Drive, I hope it will be easier to download it from there.

Link: https://drive.google.com/open?id=0Bx7O_--1DycgSDM0WWVlcWZacE0
MD5: c3512a32af805be9e46f676c8acac37e

Anyway, if it is impossible to download that image, you can try the workaround with "intel_iommu=off" I described earlier. If the systems installs OK that way, you can then update the kernel in it to at least 4.1.25 from our repositories and then remove "intel_iommu=off" from the boot options.
Comment 7 darrencleaver 2016-06-18 11:43:22 MSD
Eugene,

Thanks that ISO you uploaded to GoogleDrive, solved the problem!!!!

Thanks heaps !!!!!!!!!!!!!
Comment 8 darrencleaver 2016-06-18 12:57:15 MSD
Eugine,

Is it true that support for my Distro , the edition you have me will be ending soon? I heard that a New ROSA Fresh KDE is coming out soon. Can I upgrade from my edition to this? I have contacted sales several times about purchase of enterprise and no one has got back to me which is pretty slack! 
One Dev told me that I could not purchase from ROSA Russia as I live in Australia. That I may be able to purchase from a re-seller ? Plus does the new ROSA Fresh plan on mixing KDE 4 and 5 ?
Comment 9 darrencleaver 2016-06-18 17:18:49 MSD
What Kernel will the new ROSA Desktop be running ?
Comment 10 darrencleaver 2016-06-18 19:05:43 MSD
What is the best Kernel to be running ?

http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/rosa2014.1/x86_64/kernel_4_3/release/
Comment 11 Eugene Shatokhin 2016-06-20 11:59:14 MSD
(In reply to comment #7)
> Thanks that ISO you uploaded to GoogleDrive, solved the problem!!!!

Great! I am glad it works now.

> Is it true that support for my Distro , the edition you have me will be ending soon? I heard that a New ROSA Fresh KDE is coming out soon.

ROSA Fresh R8 (KDE) is in a feature-freeze state (kind of) at the moment and we are going to release it as soon as it is ready. 

ROSA R8 will still use kernel 4.1.x, likely - 4.1.25. Other kernel versions (e.g. 4.4.x, 4.6.x) are available in the unofficial repositories.

> Can I upgrade from my edition to this?

Yes, and you do not have to do anything special for that. Just install the updates from time to time via GUI (rpmdrake) or in console (urpmi --auto-update).

By the way, ROSA Fresh you use is a non-commercial distro. It is free, but the company offers no official guarantees of support for it (but we do try to do our best to support it). Should be OK for home use, in my opinion. 

> I heard that a New ROSA Fresh KDE is coming out soon.

Another thing is, the work is under way on the new "platform" for ROSA Fresh. I mean, the major updates to GCC, glibc and other components that can be too risky to update on a day-to-day basis.

The next release of ROSA Fresh *after* the upcoming R8 should be based on that new platform, I suppose. 

Until the new platform stabilizes, ROSA R8 will still be supported (at least, bug fixes will be provided). Then the users will be encouraged to move to the newer ROSA version. We will provide the instructions similar to what we did with the previous update of the platform:

http://wiki.rosalab.ru/en/index.php/Migrating_from_ROSA_Desktop_Fresh_R3_to_R4

As for the kernel for ROSA R9+, it is not decided yet. It will be no older than 4.6-4.7, I think. If the kernel 4.8 will be released early enough, we might pick it. We'll see.

Hope this helps.
Comment 12 Eugene Shatokhin 2016-06-20 12:12:48 MSD
(In reply to comment #10)
> What is the best Kernel to be running ?

It depends. I can only give some hints.

1. Choosing a version

If the "official" kernel (4.1.25 at the moment) works OK for you, then you can stick to it. 

If a bug is uncovered in the "official" kernel, it has a higher priority than the bugs in the unofficial ones.

...But if the "official" kernels do not work well on your systems, e.g. if you have the hardware that is not supported there, you may try the unofficial ones
from http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/rosa2014.1/x86_64/.

4.6.x is the latest there at the moment.

4.4.x may be also worth trying because it is a longterm-supported kernel (see https://kernel.org/category/releases.html).

2. Choosing a flavour

"nrj-desktop" flavour installed by default should be enough for many systems. If you use ROSA on a laptop, you may try "nrj-laptop" flavour as well. It may help reduce power consumption in some cases but the gains vary from negligible to significant on different hardware.

For the 32-bit systems, PAE variants of "nrj-desktop" and "nrj-laptop" are usually a good choice.